Subtitle not showing up in correct format with Chinese for the new version

3 posters

Go down

Subtitle not showing up in correct format with Chinese for the new version Empty Subtitle not showing up in correct format with Chinese for the new version

Post by 糸守湖畔宫水泷 Thu Jul 13, 2023 7:51 am

With the recent update (17.6.Cool, the subtitles in Chinese suddenly become, well, ugly (now I think this should be due to Codec not decoding the subtitle document correctly).
Some characters are large, some are (very) small; some become Chinese (traditional), some seems like not in the same font with the rest.
I attempted to fix this by play>subtitle track>styles, yet, none of the changes made any improvement to the subtitle.
Then I intentionally downloaded V16.0.2 Codec (just randomly chosen that), which then fixed the problem, and now the subtitles are working just normal.
I will leave this problem to you, and I will probably just stick with V16.0.2 for a very long time in the future.

糸守湖畔宫水泷

Posts : 2
Join date : 2023-07-13

Back to top Go down

Subtitle not showing up in correct format with Chinese for the new version Empty Re: Subtitle not showing up in correct format with Chinese for the new version

Post by Admin Fri Jul 14, 2023 12:36 pm

You need to give a link to a file that is not working correctly.

Admin
Admin

Posts : 7461
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Subtitle not showing up in correct format with Chinese for the new version Empty Re: Subtitle not showing up in correct format with Chinese for the new version

Post by 糸守湖畔宫水泷 Sun Jul 16, 2023 9:30 am

Well, obviously I have it downloaded on my device……All I can say is, it is a .mkv file?

糸守湖畔宫水泷

Posts : 2
Join date : 2023-07-13

Back to top Go down

Subtitle not showing up in correct format with Chinese for the new version Empty Re: Subtitle not showing up in correct format with Chinese for the new version

Post by Admin Sun Jul 16, 2023 1:47 pm

I need the actual file. So either tell me where you downloaded it from, or upload the file somewhere.

MKV Files can contain subtitles with different styles and font. It can even have moving text and karaoke effects. So it is possible that the subs are displaying correctly. The player does not randomly change language, fonts, sizes or text.

Admin
Admin

Posts : 7461
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Subtitle not showing up in correct format with Chinese for the new version Empty Re: Subtitle not showing up in correct format with Chinese for the new version

Post by Nospel Fri Jul 28, 2023 8:44 pm

Admin wrote:I need the actual file. So either tell me where you downloaded it from, or upload the file somewhere.

MKV Files can contain subtitles with different styles and font. It can even have moving text and karaoke effects. So it is possible that the subs are displaying correctly. The player does not randomly change language, fonts, sizes or text.

follow up additional subtitle bug reoport for Mega ver. 16.0.8 & 16.0.9:

1.1, internal subtitle renderer with default font type specified to "Microsoft YaHei" loads a .srt format subtitle file (language Simplified Chinese, none font specification), it displays in font "Songti", even when default subtitle function activated, no change happens.
1.2, When it loads a .ass subtitle file with multi-language in both Simplified Chinese (font specified to "Microsoft YaHei") and English (font specified to whatever), the Chinese part will be rendered in font "Songti" while the English part rendered correctly.

This bug happens in both MPC Video Renderer and madVR output.

2, XySubFilter loads a .srt or .ass subtitle file discribed above, it renders only for 1 second (slightly more or less), and then it seems lost the subtitle file or its rendering function, as no subtitle displays with the video. it can be fixed when XySubFilter's "Loading" selected to "Always load" instead of default "Load when needed".

This bug happens with MPC Video Renderer output. In madVR output, XySybFilter renders the subtitle constantly no matter "Always load" or "Load when needed" which is selected.

Expecting these bugs being fixed, and won't happen again.

Nospel

Posts : 7
Join date : 2023-07-28

Back to top Go down

Subtitle not showing up in correct format with Chinese for the new version Empty Re: Subtitle not showing up in correct format with Chinese for the new version

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum