AAC needs to encode/bitstream to my soundbar to work, please help.

2 posters

Go down

AAC needs to encode/bitstream to my soundbar to work, please help. Empty AAC needs to encode/bitstream to my soundbar to work, please help.

Post by phone guy Wed Jul 27, 2022 9:26 am

I need to find a newer solution. I need .aac files (5.1/7.1) to encode and bitstream thru the hdmi port to play them on my soundbar. I am still using WMC on Win10. I had it setup before using ffdshow to only aac, and everything else went thru lav. Can lav audio encode and bitstream thru the hdmi? thats what I need. This is a new install and I cant remember how to do it the old way either. Please help.

in order for tv to work in wmc the pc has to be set to stereo. If the pc is set to anything other than stereo, tv sound in wmc doesnt work. thats why it has to be encoded and bitstream, then the pc sound setting doesnt matter, it acts like dolby or dts and bitstreams. lav usually tries to do pcm, which wont work when set to stereo. I need it encoded to bitstream.

phone guy

Posts : 19
Join date : 2020-06-21

Back to top Go down

AAC needs to encode/bitstream to my soundbar to work, please help. Empty Re: AAC needs to encode/bitstream to my soundbar to work, please help.

Post by Admin Wed Jul 27, 2022 11:58 am

ffdshow is still included in the Mega pack.

During installation, select "ffdshow audio processor" (use manually), so that ffdshow components are installed. Then after installation, enable ffdshow audio decoder with the Codec Tweak Tool. You can also access its configuration with CTT.

What you can also try first is to select "ffdshow audio processor" (load in all apps). Maybe that will also work with WMC. Let me know if it does or not.

Admin
Admin

Posts : 6761
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

AAC needs to encode/bitstream to my soundbar to work, please help. Empty Re: AAC needs to encode/bitstream to my soundbar to work, please help.

Post by phone guy Wed Jul 27, 2022 2:18 pm

Admin wrote:ffdshow is still included in the Mega pack.

During installation, select "ffdshow audio processor" (use manually), so that ffdshow components are installed. Then after installation, enable ffdshow audio decoder with the Codec Tweak Tool. You can also access its configuration with CTT.

What you can also try first is to select "ffdshow audio processor" (load in all apps). Maybe that will also work with WMC. Let me know if it does or not.

I will try, but before I do, does LAV or something else more modern or up to date, do what I need to do? Everything I play is either DD/DTS/ATMOS somekind of bitstream audio, or its mp4/mkv with aac audio. EVERYTHING has aac audio. So I need something that will encode/bitstream aac audio thru the hdmi to my soundbar. Can LAV be made to do that?

phone guy

Posts : 19
Join date : 2020-06-21

Back to top Go down

AAC needs to encode/bitstream to my soundbar to work, please help. Empty Re: AAC needs to encode/bitstream to my soundbar to work, please help.

Post by Admin Wed Jul 27, 2022 7:23 pm

LAV can handle bitstreaming of AC3/DTS/TrueHD/Atmos. It does not transcode AAC to AC3. You need ffdshow only for that.

Admin
Admin

Posts : 6761
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

AAC needs to encode/bitstream to my soundbar to work, please help. Empty Re: AAC needs to encode/bitstream to my soundbar to work, please help.

Post by phone guy Wed Jul 27, 2022 9:53 pm

Admin wrote:LAV can handle bitstreaming of AC3/DTS/TrueHD/Atmos. It does not transcode AAC to AC3. You need ffdshow only for that.
Damn. I wish something else worked.

Admin wrote:Admin wrote:
ffdshow is still included in the Mega pack.

During installation, select "ffdshow audio processor" (use manually), so that ffdshow components are installed. Then after installation, enable ffdshow audio decoder with the Codec Tweak Tool. You can also access its configuration with CTT.

What you can also try first is to select "ffdshow audio processor" (load in all apps). Maybe that will also work with WMC. Let me know if it does or not.

I did a fresh install of 17.10, this time I choose ffdshow audio processor in directshow apps. No change. If I could get wmc to use one of the codecs from the pack maybe the audio issue needing to be in stereo would go away. I do not know how to do that. Any other ideas on that?

As for ffdshow and encoding aac, when I load ffdshow from ctt it has nothing in its codecs list except uncompressed all supported raw. But I enable resample, encode streams, disable try pcm first, then go to lav audio uncheck aac, and when I play an aac file no ffdshow.  I also disabled microsoft dtv-dvd audio audio decoder and x64 in ctt. What am I doing wrong?

BTW: Thanks for the help. Sorry for it being so complicated.

phone guy

Posts : 19
Join date : 2020-06-21

Back to top Go down

AAC needs to encode/bitstream to my soundbar to work, please help. Empty Re: AAC needs to encode/bitstream to my soundbar to work, please help.

Post by Admin Wed Jul 27, 2022 10:26 pm

The ffdshow audio processor can be used in combination with another decoder like LAV. So don't disable all other decoders, otherwise there is active decoder available. If WMC does not load ffdshow processor, then you can use ffdshow audio decoder instead. They are two different filters.

You can enable the ffdshow decoder with CTT in filter management section.

Does any of your TV channels use AAC? Because you could also use WMC just for TV, and use something like Kodi as a media interface for downloaded videos.

Admin
Admin

Posts : 6761
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

AAC needs to encode/bitstream to my soundbar to work, please help. Empty Re: AAC needs to encode/bitstream to my soundbar to work, please help.

Post by Admin Wed Jul 27, 2022 10:27 pm

Assuming that you have a 64-bit system with 64-bit WMC, you of course need to use the 64-bit (x64) filters.

Admin
Admin

Posts : 6761
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

AAC needs to encode/bitstream to my soundbar to work, please help. Empty Re: AAC needs to encode/bitstream to my soundbar to work, please help.

Post by phone guy Wed Jul 27, 2022 11:54 pm

Admin wrote:Assuming that you have a 64-bit system with 64-bit WMC, you of course need to use the 64-bit (x64) filters.

I use Emby inside WMC for "media", which all plays fine, the only issue with wmc is when you watch tv or recorded tv (which come from hdhomerun tuners), if the pc is not in stereo, the audio glitches and repeats the first second or so of audio, if its set to anything other than stereo, so when an encoded streams comes (atmos/truehd/dolby/dts) those bitstream and you get 5.1/7.1. Its whatever codec ms uses for wmc .wtv files. The tv stations usually have a dolby track of somekind (according to the listing)... no aac that I am aware of.

phone guy

Posts : 19
Join date : 2020-06-21

Back to top Go down

AAC needs to encode/bitstream to my soundbar to work, please help. Empty Re: AAC needs to encode/bitstream to my soundbar to work, please help.

Post by phone guy Thu Jul 28, 2022 12:04 am

Admin wrote:The ffdshow audio processor can be used in combination with another decoder like LAV. So don't disable all other decoders, otherwise there is active decoder available. If WMC does not load ffdshow processor, then you can use ffdshow audio decoder instead. They are two different filters.

You can enable the ffdshow decoder with CTT in filter management section.

Does any of your TV channels use AAC? Because you could also use WMC just for TV, and use something like Kodi as a media interface for downloaded videos.

So it seems like my older install had 16.98 and it installed ffdshow audio decoder and the processor, where 17.10 only installs the ffdshow processor.  The decoder has the codec options to select aac, the processor does not.
AAC needs to encode/bitstream to my soundbar to work, please help. Image
AAC needs to encode/bitstream to my soundbar to work, please help. Image
AAC needs to encode/bitstream to my soundbar to work, please help. Image

How do I get the decoder installed? Go back to the older version? I dont see where to re-install the ffdshow decoder in filter managerment?

phone guy

Posts : 19
Join date : 2020-06-21

Back to top Go down

AAC needs to encode/bitstream to my soundbar to work, please help. Empty Re: AAC needs to encode/bitstream to my soundbar to work, please help.

Post by Admin Thu Jul 28, 2022 6:31 pm

The decoder is not enabled by default. You can enable it in the filter management section of CTT.

Admin
Admin

Posts : 6761
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

AAC needs to encode/bitstream to my soundbar to work, please help. Empty Re: AAC needs to encode/bitstream to my soundbar to work, please help.

Post by phone guy Fri Jul 29, 2022 9:52 pm

Admin wrote:The decoder is not enabled by default. You can enable it in the filter management section of CTT.

OK, I was able to get the FFDSHOW decoder and processor installed with 17.10 using the filter management of CTT. I have a question that will hopefully solve this ridiculous issue with WMC completely. WMC requires the pc speaker output set to stereo when playing live tv or recorded .wtv files, otherwise the audio has a glitch where it plays for about 1 second and repeats/skips that 1 second of audio until either you press stop or the video will eventually says failed to play. If the pc speaker setting (left click on speaker in system tray -> stereo) is set to 5.1/7.1 this audio issue happens 99% of the time. When the pc speaker is set to stereo, the only way to get aac files to properly play surround sound (6ch+) is to use ffdshow to encode the audio and bitstream to the connected soundbar.

Is there a way to successfully force wmc to use the klite audio codecs/processors to handle audio without error, this would hopefully eliminate the need to keep the pc in stereo mode, and let lav handle the aac files and everything would play and sound the way its intended. How can I make wmc not use the microsoft audio engines/codecs and play audio from live tv and recorded tv using the klite pack?

I am willing to test and try anything. Please advise.

phone guy

Posts : 19
Join date : 2020-06-21

Back to top Go down

AAC needs to encode/bitstream to my soundbar to work, please help. Empty Re: AAC needs to encode/bitstream to my soundbar to work, please help.

Post by phone guy Fri Jul 29, 2022 11:37 pm

OK... after more testing here what I have.  By disabling MS DTV audio codec (x86/64) in CTT under MS codec tweak, that does force WMC to use LAV audio, or at least it does load and appears in the system tray when playing live tv or recorded tv.  It does NOT solve the issue of the pc speaker needing to be in Stereo to avoid the audio 1 second repeat skip glitch.

I did a clean fresh install of 17.10, choose use ffdshow audio processor in directshow apps, and after install enabled ffdshow audio codec in CTT.  Disabled aac in LAV, enabled aac in ffdshow libavcodec in menu. Enabled resample to 48k, and encode AC3 spdif mode and tried with mixer and without mixer enabled.

If the audio of pc speaker is set to 5.1/7.1 I get the correct surround sound from 2 different test files with aac 5.1 and 7.1 soundtracks (just demo files, I can upload them if you like).  However if the speakers are set to stereo, I do not get surround sound mode from the rear speakers at all, all the audio comes from the front. When playing the files, the ffdshow icon does appear in the system tray, and it does show output spdif, is that different since its hdmi? am I missing another setting? I tried playing the same files in mpc-hc x64 with the same results, surround if speaker is set to 5.1/7.1 and no surround if set to stereo.

So now I am at square one.... and honestly a little lost.
AAC needs to encode/bitstream to my soundbar to work, please help. Image

phone guy

Posts : 19
Join date : 2020-06-21

Back to top Go down

AAC needs to encode/bitstream to my soundbar to work, please help. Empty Re: AAC needs to encode/bitstream to my soundbar to work, please help.

Post by Admin Sat Jul 30, 2022 10:31 am

The PC speaker configuration should not matter when bitstreaming, because that completely bypasses the Windows mixer. Your receiver should indicate that it is getting Dolby Digital input.

If you hover your mouse above the ffdshow icon in the system tray, then you can see its input and output in the tooltip.

Admin
Admin

Posts : 6761
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

AAC needs to encode/bitstream to my soundbar to work, please help. Empty Re: AAC needs to encode/bitstream to my soundbar to work, please help.

Post by phone guy Sun Jul 31, 2022 5:00 am

Admin wrote:The PC speaker configuration should not matter when bitstreaming, because that completely bypasses the Windows mixer. Your receiver should indicate that it is getting Dolby Digital input.

If you hover your mouse above the ffdshow icon in the system tray, then you can see its input and output in the tooltip.

I realize that, however when the pc is set to stereo, nothing comes from the rear speakers. I know thats wrong, but its whats happening. I am testing using an aac encoded dolby test tone sample announcing the speaker names from the speaker it self (this is left speaker, this is right surround speaker, etc) and all sound comes from the front if the pc is in stereo. ffdshow shows spdif mode but it does not work. The only thing I can assume is ffdshow is not encoding properly. Is ffdshow the only option to encode the aac to a bitstream format?

phone guy

Posts : 19
Join date : 2020-06-21

Back to top Go down

AAC needs to encode/bitstream to my soundbar to work, please help. Empty Re: AAC needs to encode/bitstream to my soundbar to work, please help.

Post by Admin Sun Jul 31, 2022 10:49 am

Is ffdshow getting 5.1 input?
The mixer in LAV Audio Decoder should be disabled.

Admin
Admin

Posts : 6761
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

AAC needs to encode/bitstream to my soundbar to work, please help. Empty Re: AAC needs to encode/bitstream to my soundbar to work, please help.

Post by phone guy Mon Aug 01, 2022 10:36 pm

Admin wrote:Is ffdshow getting 5.1 input?
The mixer in LAV Audio Decoder should be disabled.

Yes, ffdshow is getting 6ch aac audio streams, and says it output is ac3 spdif, but that can not be the case because if the pc is set to stereo, still no sound from surround/rear channels.

phone guy

Posts : 19
Join date : 2020-06-21

Back to top Go down

AAC needs to encode/bitstream to my soundbar to work, please help. Empty Re: AAC needs to encode/bitstream to my soundbar to work, please help.

Post by Admin Tue Aug 02, 2022 1:19 pm

Does your soundbar show what kind of input it is getting?

Admin
Admin

Posts : 6761
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

AAC needs to encode/bitstream to my soundbar to work, please help. Empty Re: AAC needs to encode/bitstream to my soundbar to work, please help.

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum