Subtitles can't be turned on after turning them off (there is a fix but it's annoying)

2 posters

Go down

Subtitles can't be turned on after turning them off (there is a fix but it's annoying) Empty Subtitles can't be turned on after turning them off (there is a fix but it's annoying)

Post by Arilando Sun Feb 06, 2022 9:28 pm

Currently if i turn off subtitles i can't turn them back on. Selecting to turn them back on does not make the subtitles come back. If i'm in fullscreen, exiting fullscreen makes the subtitles come back, or if i'm not in fullscreen entering fullscreen does. That's pretty annoying. What could be causing this issue?

Arilando

Posts : 30
Join date : 2020-08-26

Back to top Go down

Subtitles can't be turned on after turning them off (there is a fix but it's annoying) Empty Re: Subtitles can't be turned on after turning them off (there is a fix but it's annoying)

Post by Admin Sun Feb 06, 2022 11:54 pm

Are you using the latest version of the codec pack?

Admin
Admin

Posts : 7451
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Subtitles can't be turned on after turning them off (there is a fix but it's annoying) Empty Re: Subtitles can't be turned on after turning them off (there is a fix but it's annoying)

Post by Arilando Fri Feb 11, 2022 11:06 pm

Admin wrote:Are you using the latest version of the codec pack?
Yes i am.

Arilando

Posts : 30
Join date : 2020-08-26

Back to top Go down

Subtitles can't be turned on after turning them off (there is a fix but it's annoying) Empty Re: Subtitles can't be turned on after turning them off (there is a fix but it's annoying)

Post by Admin Sat Feb 12, 2022 2:02 pm

I am unable to reproduce your problem.

Copy this log here:
Codec Tweak Tool > Generate Log

Admin
Admin

Posts : 7451
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Subtitles can't be turned on after turning them off (there is a fix but it's annoying) Empty Re: Subtitles can't be turned on after turning them off (there is a fix but it's annoying)

Post by Arilando Sun Feb 13, 2022 2:41 pm

Note, i have Windows 10 Pro, don't know why it thinks it's enterprise edition. Also i did recently upgrade my CPU (along with motherboard and RAM), i don't know if that has anything to do with it. I will try to reinstall and see if that fixes it. Here's the log:

Codec Tweak Tool | Log file | Generated at 2022-02-13 15:39:35

##### System Information #####

OS: Windows 10 Enterprise (10.00.19043) (x64)
CPU name: 12th Gen Intel(R) Core(TM) i9-12900KF
CPU details: 3187 MHz | 24 core(s) | Family 6 Model 151 Stepping 2
Memory: 16224 MB
Screen size: 3840x2160 (32bits) (120Hz) (175%)
GPU: NVIDIA GeForce RTX 3080
VendorID: 10de, DeviceID: 2206
GPU memory: 10240 MB
GPU driver: nvldumdx.dll (Version 30.0.15.1165) (1-28-2022) (NV 511.65)
Audio device: NVIDIA High Definition Audio
VendorID: 10de, DeviceID: 009a
Audio driver: nvhda64v.sys (Version 1.3.39.3) (1-2-2022)

##### K-Lite Codec Pack #####

KLCP version: 16.8.0
KLCP type: full

Speaker conf: as is

MPC renderer: madVR
MPC subs: ISR
MPC audio: MPC Audio Renderer

##### Decoder Settings #####

LAV Video:
H264=DXVA2CB HEVC=DXVA2CB VP9=DXVA2CB VC1=0 MPEG2=1 MPEG4=1 WMV3=0

LAV Audio:
MP3=1 AC3=1 DTS=1 DTSHD=1 EAC3=1 TRUEHD=1 AAC=1 Vorbis=1 LPCM=1 WMA=0

##### DirectShow Filters (32-bit) #####

Description: File Source (Soft-Denchi.)
File name: c:\program files (x86)\softdenchi\sdmedia.ax
CLSID: {18832FDB-D9D2-40C8-9051-6400E0053F4C}
Merit: 00400000 = MERIT_UNLIKELY

(A total of 76 filters, 1 shown, 75 hidden)

##### DirectShow Filters (64-bit) #####

(A total of 72 filters, 0 shown, 72 hidden)

##### ICM Class Manager (32-bit) #####

(A total of 2 filters, 0 shown, 2 hidden)

##### ICM Class Manager (64-bit) #####

(A total of 2 filters, 0 shown, 2 hidden)

##### Default source filters (32-bit) #####

.sdmedia{18832FDB-D9D2-40C8-9051-6400E0053F4C} File Source (Soft-denchi.)

(A total of 63 default source filters, 1 shown, 62 hidden)

##### Default source filters (64-bit) #####

(A total of 54 default source filters, 0 shown, 54 hidden)

##### ACM and VFW Codecs (32-bit) #####

(A total of 14 codecs, 0 shown, 14 hidden)

##### ACM and VFW Codecs (64-bit) #####

(A total of 13 codecs, 0 shown, 13 hidden)

Arilando

Posts : 30
Join date : 2020-08-26

Back to top Go down

Subtitles can't be turned on after turning them off (there is a fix but it's annoying) Empty Re: Subtitles can't be turned on after turning them off (there is a fix but it's annoying)

Post by Admin Mon Feb 14, 2022 12:01 pm

Yes, a re-install or reset of settings is worth a try.

Admin
Admin

Posts : 7451
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Subtitles can't be turned on after turning them off (there is a fix but it's annoying) Empty Re: Subtitles can't be turned on after turning them off (there is a fix but it's annoying)

Post by Arilando Mon Feb 14, 2022 9:36 pm

I found a solution to this. Resetting settings or reinstalling did not solve it. What solves it is to set maximum texture resolution to 3840x2160 under the subtitles setting in MPC. The default value seems to be 2560x1440. I would however like to add that as far as i can tell that using the backup and restore feature in the codec tweak tool does not seem to work, that is backing up settings, then resetting setting, and then using restore does not seem to actually restore settings to what they previously were.

Arilando

Posts : 30
Join date : 2020-08-26

Back to top Go down

Subtitles can't be turned on after turning them off (there is a fix but it's annoying) Empty Re: Subtitles can't be turned on after turning them off (there is a fix but it's annoying)

Post by Admin Tue Feb 15, 2022 7:15 pm

Does the problem also occur if you disable subtitles in a maximized window (non-fullscreen)? With the 2560x1440 setting.

Admin
Admin

Posts : 7451
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Subtitles can't be turned on after turning them off (there is a fix but it's annoying) Empty Re: Subtitles can't be turned on after turning them off (there is a fix but it's annoying)

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum