[16.6.5] MPC and LAV - lost settings

2 posters

Go down

[16.6.5] MPC and LAV - lost settings Empty [16.6.5] MPC and LAV - lost settings

Post by shroom Fri Dec 17, 2021 7:10 pm

I've (fast) upgraded from v16.6.3 to v16.6.5 using the full mega installer.
All the settings for MPC and LAV got reset in the process.

I also had to launch MPC in Administrator mode to allow the use of .ini file (I had that option enabled before) and changing the settings in this mode now requires to always launch MPC in Admin mode for them to stick between each launch.

Not sure if this was intended, but this was/is kind of annoying Wink

shroom

Posts : 5
Join date : 2015-11-24

Back to top Go down

[16.6.5] MPC and LAV - lost settings Empty Re: [16.6.5] MPC and LAV - lost settings

Post by Admin Fri Dec 17, 2021 9:35 pm

Using the INI requires that the access permission for that file are adjusted so that the regular "Users" group in Windows has modify access.

The installer now tries to adjust the permissions also during updates. This is to deal with the situation where people manually copied the INI file from a backup, but don't know they also need to adjust the permissions, resulting in settings becoming read-only.

If adjusting permissions fails, then INI file is currently being removed.

I am not sure why it is failing for you. I assume you didn't have any issues with saving settings before?

Regardless of the current issue, using INI is a bad idea. The settings in the Registry can be backed up just as easily.
MPC-HC options > Miscellaneous > Export

Admin
Admin

Posts : 7459
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

[16.6.5] MPC and LAV - lost settings Empty Re: [16.6.5] MPC and LAV - lost settings

Post by Admin Sat Dec 18, 2021 5:24 pm

I think I found the cause. So should probably be fixed in next version. Let me know if it still has issues when its available.

Admin
Admin

Posts : 7459
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

[16.6.5] MPC and LAV - lost settings Empty Re: [16.6.5] MPC and LAV - lost settings

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum