AAC 5.1 questions again

2 posters

Go down

AAC 5.1 questions again Empty AAC 5.1 questions again

Post by We87 Mon Sep 27, 2021 9:25 am

Windows 10
Latest klite

I know I always ask this question, and I apologize for the repeating information on the forum but I am yet again stumped. What I am trying to do is get AAC 5.1 audio to encode using ffdshow so I can watch mkv movies in windows media player or more specifically windows media center with surround sound.

I have reinstalled klite and deselected AAC from LAV and selected it under ffdshow, I opened ffdshow and set it to resample, set the mixer to 5.1, and set it to encode through spdif. I also disabled the Microsoft codecs in the codec tweak tool.

This above configuration makes AAC work in MPC, but does not work in WMP.

I have gotten this to work before but obviously I am missing a step. I need the windows sound mixer to stay in stereo in order to get windows media center to function correctly. When windows is set to 7.1, and I try to watch regular broadcast tv, it stutters and skips and doesn't play.

Is there something else I can try? I have two other machines with from what I can see the same settings and it is working the way I need it to? I just can't remember if I did something else?

We87

Posts : 24
Join date : 2019-12-03

Back to top Go down

AAC 5.1 questions again Empty Re: AAC 5.1 questions again

Post by Admin Mon Sep 27, 2021 2:28 pm

You did not mention what is happening now. Does ffdshow icon show up in the system tray? Maybe you forgot to enable Resample as mentioned in the FAQ?

Windows should be set to Stereo for WMC. Bitstreaming completely bypasses the Windows mixer.

Admin
Admin

Posts : 6108
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

AAC 5.1 questions again Empty Re: AAC 5.1 questions again

Post by We87 Mon Sep 27, 2021 7:19 pm

I apologize, that's correct. I never see the ffdshow icon in the tray when I play the file with windows media player.

We87

Posts : 24
Join date : 2019-12-03

Back to top Go down

AAC 5.1 questions again Empty Re: AAC 5.1 questions again

Post by Admin Mon Sep 27, 2021 9:50 pm

Test playback with the GraphStudioNext tool (from K-lite Mega). Then you can see which filters are being used.

Double-check if the Microsoft DTV-DVD Audio decoder is still disabled. It may get re-enabled by Windows updates.

Admin
Admin

Posts : 6108
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

AAC 5.1 questions again Empty Re: AAC 5.1 questions again

Post by We87 Mon Sep 27, 2021 10:11 pm

According to graph studio, it is going through ffdshow. I rechecked and the Microsoft filters are still disabled (top two)

We87

Posts : 24
Join date : 2019-12-03

Back to top Go down

AAC 5.1 questions again Empty Re: AAC 5.1 questions again

Post by Admin Tue Sep 28, 2021 12:01 pm

Disabled for both 32-bit and 64-bit? WMC is a 64-bit app, while WMP uses its 32-bit version by default.

Does sound currently work in WMC? Meaning another decoder is being used. You can disable SPDIF output in ffdshow to test if it loads then.

I would really recommend using something else for watching video. For example Kodi if you need media library functionality.

Admin
Admin

Posts : 6108
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

AAC 5.1 questions again Empty Re: AAC 5.1 questions again

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum