MPC going blank on puase/play

2 posters

Go down

MPC going blank on puase/play Empty MPC going blank on puase/play

Post by parvee Sat Aug 07, 2021 7:25 pm

Hello,

I have just updated from K-Lite 16.2.0 to 16.3.5 and have been experiencing an issue when pausing my videos. Once I press play again; the screen remains black, but the audio continues as normal. The files i am using worked without issue with 16.2.0. A sample of the media info is pasted below.

I would appreciate any advice to fix the problem. Thank you.

Video
ID : 0
Format : MPEG-4 Visual
Format profile : Advanced Simple@L5
Format settings : BVOP1 / Custom Matrix
Format settings, BVOP : 1
Format settings, QPel : No
Format settings, GMC : No warppoints
Format settings, Matrix : Custom
Codec ID : XVID
Codec ID/Hint : XviD
Duration : 21 min 40 s
Bit rate : 1 009 kb/s
Width : 624 pixels
Height : 352 pixels
Display aspect ratio : 16:9
Frame rate : 23.976 (24000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Compression mode : Lossy
Bits/(Pixel*Frame) : 0.192
Stream size : 156 MiB (89%)
Writing library : XviD 1.2.1 (UTC 2008-12-04)

Audio
ID : 1
Format : MPEG Audio
Format version : Version 1
Format profile : Layer 3
Format settings : Joint stereo / MS Stereo
Codec ID : 55
Codec ID/Hint : MP3
Duration : 21 min 40 s
Bit rate mode : Variable
Bit rate : 108 kb/s
Nominal bit rate : 128 kb/s
Channel(s) : 2 channels
Sampling rate : 48.0 kHz
Frame rate : 41.667 FPS (1152 SPF)
Compression mode : Lossy
Stream size : 16.7 MiB (10%)
Alignment : Aligned on interleaves
Interleave, duration : 24 ms (0.58 video frame)
Interleave, preload duratio : 170 ms
Writing library : LAME3.98r
Encoding settings : -m j -V 4 -q 2 -lowpass 17 --abr 128

parvee

Posts : 2
Join date : 2021-08-07

Back to top Go down

MPC going blank on puase/play Empty Re: MPC going blank on puase/play

Post by Admin Sun Aug 08, 2021 12:30 pm

Very weird. Does it happen on every pause?

Try with a different video renderer:
Options > Playback > Output

Can you copy this log here, so I can see which GPU and graphics driver you have?
Codec Tweak Tool > Generate Log

Admin
Admin

Posts : 6051
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

MPC going blank on puase/play Empty Re: MPC going blank on puase/play

Post by parvee Sun Aug 08, 2021 2:11 pm

Hi, thanks for the response. Yes, it happens on every pause/play (tested on avi & mkv).

Switching the output renderer from MPC Video Renderer to Enhanced Video Renderer seems to have fixed the issue. MPC is playing as usual again

Codec Tweak Tool | Log file | Generated at 2021-08-08 15:07:22

##### System Information #####

OS: Windows 10 Enterprise (10.00.19041) (x64)
CPU name: Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz
CPU details: 2394 MHz | 4 core(s) | Family 6 Model 61 Stepping 4
Memory: 16288 MB
Screen size: 3840x2160 (32bits) (60Hz) (250%)

Audio device: Realtek High Definition Audio
VendorID: 10ec, DeviceID: 0255, SubSys: 1028066f
Audio driver: RTKVHD64.sys (Version 6.0.1.7647) (10-27-2015)

##### K-Lite Codec Pack #####

KLCP version: 16.3.5
KLCP type: full

Speaker conf: 2.0

MPC renderer: EVR
MPC subs: ISR
MPC audio: Internal Audio Renderer
MPC decoder: h264=DXVA2N hevc=0 vp9=0 vc1=0 mpeg2=0

##### Decoder Settings #####

LAV Video:
H264=DXVA2CB HEVC=1 VP9=1 VC1=0 MPEG2=1 MPEG4=1 WMV3=0

LAV Audio:
MP3=1 AC3=1 DTS=1 DTSHD=1 EAC3=1 TRUEHD=1 AAC=1 Vorbis=1 LPCM=1 WMA=0

##### DirectShow Filters (32-bit) #####

(A total of 62 filters, 0 shown, 62 hidden)

##### DirectShow Filters (64-bit) #####

(A total of 72 filters, 0 shown, 72 hidden)

##### ICM Class Manager (32-bit) #####

(A total of 2 filters, 0 shown, 2 hidden)

##### ICM Class Manager (64-bit) #####

(A total of 2 filters, 0 shown, 2 hidden)

##### Default source filters (32-bit) #####

(A total of 12 default source filters, 0 shown, 12 hidden)

##### Default source filters (64-bit) #####

(A total of 56 default source filters, 0 shown, 56 hidden)

##### ACM and VFW Codecs (32-bit) #####

(A total of 14 codecs, 0 shown, 14 hidden)

##### ACM and VFW Codecs (64-bit) #####

(A total of 13 codecs, 0 shown, 13 hidden)

parvee

Posts : 2
Join date : 2021-08-07

Back to top Go down

MPC going blank on puase/play Empty Re: MPC going blank on puase/play

Post by Admin Sun Aug 08, 2021 10:46 pm

I recommend "Enhanced Video Renderer (Custom Presenter)".

Admin
Admin

Posts : 6051
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

MPC going blank on puase/play Empty Re: MPC going blank on puase/play

Post by Admin Mon Aug 09, 2021 4:13 pm

Do you have time test a debug version of MPC Video Renderer for me? That can generate a log file that hopefully shows what ges wrong.

Let me know and I will compile a debug build.

Admin
Admin

Posts : 6051
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

MPC going blank on puase/play Empty Re: MPC going blank on puase/play

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum