Playing video/audio always gets stuck

3 posters

Go down

Playing video/audio always gets stuck Empty Playing video/audio always gets stuck

Post by redapple0204 Thu Jul 22, 2021 11:58 am

Hi there

I have installed the latest version of K-Lite (1635). But when I play the video/audio stored on the mobile hard disk (especially the 1080p Blu ray disk in MKV format), the media player often gets stuck. If I operate the mobile hard disk at this time, it will also be stuck (I can't create or delete any files on the mobile hard disk at this time, otherwise the explorer will also be stuck)

I once suspected that there was something wrong with the mobile hard disk (it is a SMR hard disk), but when I use other third-part players (such as SMPlayer or VLC) to play, this problem will not occur.

My graphics driver is Intel HD graphics 4600, and the latest version of the driver has been installed, so I'm sure it's not the problem with the graphics driver

What can I do to fix this problem?Thanks

redapple0204

Posts : 4
Join date : 2021-07-22

Back to top Go down

Playing video/audio always gets stuck Empty Re: Playing video/audio always gets stuck

Post by Admin Thu Jul 22, 2021 3:44 pm

The player itself does not cause this kind of problem, so any differences you see with other players are just pure coincidence.

1) Do a disk scan on the drive and enable the option to scan for bad sectors. Accessing data that is located in a bad/damaged sector will cause the system to freeze. The drive typically also makes clicking noises when this happens.

2) Look in the Windows Event Viewer. It might show errors related to the external drive.

3) Write down the timestamp of the place in the video where a freeze occurs. If it freeze is reproducible, the problem is likely in the drive itself. If it is totally random, then it could be a USB3 driver or Intel Rapid Storage Driver or motherboard chipset driver issue. Also check if a BIOS update is available.

Admin
Admin

Posts : 6108
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Playing video/audio always gets stuck Empty Re: Playing video/audio always gets stuck

Post by redapple0204 Fri Jul 23, 2021 1:15 am

Thank you for your reply. I will try the methods you mentioned

But there are two things I confused

1. I found that when I increase the values of Max queue memory and Max queue package in LAV splitter(both increase to 16384MB, which seems to be only 256MB in the original), the video playback does not always seem to get stuck, but the audio still seems to get stuck(how can I modify the similar values in audio setting?) . I suspect that some mechanism of SMR hard disk may lead to the need for larger queue memory

2. The 3)  you mentioned makes me feel puzzle. I try to play a video and find that it always gets stuck at 3:41, but when I start playing from a certain time in the middle, it gets stuck after 3:41 from this point

redapple0204

Posts : 4
Join date : 2021-07-22

Back to top Go down

Playing video/audio always gets stuck Empty Re: Playing video/audio always gets stuck

Post by Admin Fri Jul 23, 2021 1:41 am

Max Queue Memory is the amount of data it may buffer. If you have 16GB of total RAM then you should use less than 16384MB, no more than the amount of free RAM. I would say a buffer of 4GB is more than enough.

Max Queue Packets is the amount of parsed data packets. You must set that to a very high value, otherwise it won't be able to fill the large buffer. Audio packets are very small. Use for example 300.000, it never exceeds the memory max, so you can use super high value here.

External drives go into sleep mode very fast when they are not actively accessed. It can take a few seconds for the drive to spin up again. So short freezes are normal. The buffer should of course help.

Copy that video to your internal harddrive and test if it plays ok. Just to confirm that the problem only occurs with the external drive.

Admin
Admin

Posts : 6108
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Playing video/audio always gets stuck Empty Re: Playing video/audio always gets stuck

Post by Admin Fri Jul 23, 2021 1:44 am


Admin
Admin

Posts : 6108
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Playing video/audio always gets stuck Empty Re: Playing video/audio always gets stuck

Post by bob blank Thu Jul 29, 2021 5:39 am

sounds like you have the same problem i had.  soon as you mentioned b-ray mkv. cheek video info. more than likely h265. sometimes encoders do not run full video length audio to save space. the audio triggers out of sync with h265 video freezes at the end of audio track. mpc h265 mkv There seems to be a bug in the audio decoder.
This should help as a workaround:
In the settings of LAV Splitter, increase the value of "Maximum queue packets" to 4000 (or more). Then enough video packets are buffered before the audio problem occurs (sound stops early in the file).  the admin is a wear of the issue. maybe fixed in the next cupule of updates. ext. hd is more than likely crashing due to mkv is still playing, but froze.

bob blank

Posts : 9
Join date : 2021-07-21

Back to top Go down

Playing video/audio always gets stuck Empty Re: Playing video/audio always gets stuck

Post by Admin Thu Jul 29, 2021 1:26 pm

No, your problem is a different one.

Admin
Admin

Posts : 6108
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Playing video/audio always gets stuck Empty Re: Playing video/audio always gets stuck

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum