Codec Guide
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Issues with auto-subtitles despite normal settings

Go down

Issues with auto-subtitles despite normal settings Empty Issues with auto-subtitles despite normal settings

Post by lordlance Sun Feb 14, 2021 12:39 pm

MPC-HC automatically selects an 'eng' subtitle that never matches English subtitles that exist in files. Not only that but because it insists on this English subtitle, I have to manually select the actual English subtitle every time I load a file. This issue is universal across most video file - internal, external subtitles and even those without any subtitles.

I opened this file with both VLC and MPC but only MPC opened an '[auto] Eng' subtitle - https://imgur.com/a/KkZ0oOX. On VLC, it selected no subtitle - https://imgur.com/a/CsJZyCO.
However when I opened this file on MPC-HC, it selected the actual English subtitle both on MPC and VLC.

I use Windows 10 Pro 20H2 and my version of MPC-HC is https://pastebin.com/3qaeUHAP. I have tried removing eng from subtitles in both Playback and 'Misc' under Subtitles. They're all blank as you can see here:
Issues with auto-subtitles despite normal settings Bdhwgkq
Issues with auto-subtitles despite normal settings XdBPhDI

What should I do to remove MPC auto-selecting the wrong subtitle?

lordlance

Posts : 2
Join date : 2021-02-14

Back to top Go down

Issues with auto-subtitles despite normal settings Empty Re: Issues with auto-subtitles despite normal settings

Post by Admin Sun Feb 14, 2021 1:35 pm

It currently doesn't select the full English subtitle because English is configured as your primary language. The automatic track it selects only contains the "forced" part of the Eglish track, which are translations for foreign dialogs (if there are any).

During installation of the pack, on the page where you can select preferred languages, enable the option to "show subtitles for primary language". It is located near the bottom. That should solve your problem.

Admin
Admin

Posts : 5734
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Issues with auto-subtitles despite normal settings Empty Re: Issues with auto-subtitles despite normal settings

Post by lordlance Sun Feb 14, 2021 1:37 pm

Admin wrote:It currently doesn't select the full English subtitle because English is configured as your primary language. The automatic track it selects only contains the "forced" part of the Eglish track, which are translations for foreign dialogs (if there are any).

During installation of the pack, on the page where you can select preferred languages, enable the option to "show subtitles for primary language". It is located near the bottom. That should solve your problem.

What do you mean by 'forced part of the English track'? Are you saying that MPC only correct selects subtitles when the language isn't English?

lordlance

Posts : 2
Join date : 2021-02-14

Back to top Go down

Issues with auto-subtitles despite normal settings Empty Re: Issues with auto-subtitles despite normal settings

Post by Admin Sun Feb 14, 2021 11:45 pm

The file that you linked to contains PGS type subtitles. In such subtitle tracks, individual subtitle lines can be marked as 'forced'. Such lines are typically used for translating parts of a movie where someone talks another language than English.

What the player does is split such tracks into two tracks. One which is equal to the original, containing all subtitle lines. And one that contains only the forced lines. That is the [auto] tracks that you see.

Most people who have English as primary language don't need the English subtitles. So by default the [auto] track is selected. That way do you get subtitles when someone says a few words in German or Russian.

If you do want the full English subtitle then do this:
During installation of the pack, on the page where you can select preferred languages, enable the option to "show subtitles for primary language". It is located near the bottom.

Admin
Admin

Posts : 5734
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Issues with auto-subtitles despite normal settings Empty Re: Issues with auto-subtitles despite normal settings

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum