No colors in vtt subtitles

Go down

No colors in vtt subtitles Empty No colors in vtt subtitles

Post by Niek Thu Feb 11, 2021 2:05 pm

Hi Forum,
Since a few days WMP-HC(x64) on Win10 V2004 build 19041.804 no longer displays colors in vtt files when playing an mp4 file.
<c.yellow>some text</c> is displayed in white.
srt files still display colors: <font color=yellow>some text</font> is correctly displayed in yellow.
I don't know exactly when the problem started. I am shure that k-lite 15.9.5 did display the colors correctly.
After applying the February 9 Win10 update, and updating to k-lite 16.0.1 the problem occurs.
I use the default settings of WMP-HC, and the internal subtitle builder. While playing 3 LAV icons show up in the taskbar.
Is there a solution or workaround?
Thanks.

Niek

Posts : 5
Join date : 2021-02-11

Back to top Go down

No colors in vtt subtitles Empty Re: No colors in vtt subtitles

Post by Admin Thu Feb 11, 2021 10:33 pm

It works here.

Make sure that you did not accidentally enabled the default style override.
Menu > Play > Subtitles > uncheck "Default Style"

Otherwise do a fresh installation of the codec pack.

Admin
Admin

Posts : 5906
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

No colors in vtt subtitles Empty Re: No colors in vtt subtitles

Post by Niek Thu Feb 18, 2021 8:45 am

Hi admin,
Menu > Play > Subtitles > Default Style is unchecked.
I did a full uninstall, then re-installed k-lite 16.0.1, then 16.0.3. The problem remains.
As a workaround I edit the vtt in notepad. Only 2 search and replace commands are enough to change all <c> tags into <font> tags.
But I keep hoping for a real solution.

Niek

Posts : 5
Join date : 2021-02-11

Back to top Go down

No colors in vtt subtitles Empty Re: No colors in vtt subtitles

Post by ale5000 Sun Feb 28, 2021 6:27 pm

@Niek: Try the new version.

ale5000

Posts : 70
Join date : 2015-02-15

Back to top Go down

No colors in vtt subtitles Empty Re: No colors in vtt subtitles

Post by Niek Mon Mar 01, 2021 10:21 am

After installing V16.0.5 subtitles do not display at all.
So I did a full uninstall, and installed 15.9.5.
Result: subtitles display in white only.
Installed 16.0.0 -> subtitles display in white only.
Installed 16.0.3 update -> subtitles display in white only.
Installed 16.0.5 -> no subtitles at all.
Conclusion: the February 9 Win10 update possible causes the missing colors.
16.0.5 certainly causes the totally missing subtitles.
Please help.
Thanks

Niek

Posts : 5
Join date : 2021-02-11

Back to top Go down

No colors in vtt subtitles Empty Re: No colors in vtt subtitles

Post by Admin Mon Mar 01, 2021 10:19 pm

Can you upload a failing .vtt subtitle for me? Then I can investigate what goes wrong.

http://www.sendspace.com

Admin
Admin

Posts : 5906
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

No colors in vtt subtitles Empty Re: No colors in vtt subtitles

Post by Niek Tue Mar 02, 2021 3:06 am

Hi Admin,
Thanks for your help.
The link is www.sendspace.com/file/kzx28p
The first colored title is @ 00:01:19.800.

Niek

Posts : 5
Join date : 2021-02-11

Back to top Go down

No colors in vtt subtitles Empty Re: No colors in vtt subtitles

Post by Admin Tue Mar 02, 2021 4:59 pm

I can reproduce the parse issue with this file. I will have a look at it later.

Admin
Admin

Posts : 5906
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

No colors in vtt subtitles Empty Re: No colors in vtt subtitles

Post by Niek Fri Apr 30, 2021 7:51 pm

Somewhere between V16.0.5 and 16.1.4 the problem was solved. Subtitles display again, display in color, and both <c> and <font> tags are recognized.
The topic can be closed.

Niek

Posts : 5
Join date : 2021-02-11

Back to top Go down

No colors in vtt subtitles Empty Re: No colors in vtt subtitles

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum