Codec Guide
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Installed and Uninstalled SVP, now madvr lagging.

Go down

Installed and Uninstalled SVP, now madvr lagging. Empty Installed and Uninstalled SVP, now madvr lagging.

Post by lolcocks on Wed Dec 16, 2020 2:09 pm

Hello,

I wanted to test out SVP, so I installed it, I didn't like it, so I removed it and AVISynth that came along with it.

But madvr is lagging for some reason. Few videos, 1 frame every second, other videos starts off with 10 frames a second and eventually smooth out.

Any idea why this is happening?

I installed madvr with the following settings:
https://imgur.com/a/4oi2b4W

I have tried reinstalling K-Lite Codec and restarting my computer multiple times. Any idea why this is happening?

Kind Regards,
Lolcocks.

lolcocks

Posts : 7
Join date : 2017-06-26

Back to top Go down

Installed and Uninstalled SVP, now madvr lagging. Empty Re: Installed and Uninstalled SVP, now madvr lagging.

Post by Admin on Wed Dec 16, 2020 4:22 pm

First look here:
MPC-HC menu > Play > Filters

It should be using LAV Splitter and decoders. If you see ffdshow there, then uninstall it, or disable it with Codec Tweak Tool.
Click on LAV Video Decoder and check if hardware decoding is enabled. Recommend in combination with madVR is either DXVA2 Copyback or D3D11.

Press Ctrl+Shift+Esc to open the Windows Task Manager. Check that CPU isn't near 100% during playback.

Press Ctrl+J to view the madVR statistics overlay during playback. Look at the rendertime and the amount of dropped frames. For a 24fps video, the rendertime should be below 41 ms. If it is higher, then you need to adjust madVR settings to use simpler scaling algorithms.

If you need more help, then give a screenshot of the statistics overlay. Also mention which GPU(s) you have. If you have two, then you may need to set the powerful one as preferred for MPC-HC. You can do that in the Windows 10 display settings.

Admin
Admin

Posts : 5638
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Installed and Uninstalled SVP, now madvr lagging. Empty Re: Installed and Uninstalled SVP, now madvr lagging.

Post by lolcocks on Thu Dec 17, 2020 10:33 am

Admin wrote:First look here:
MPC-HC menu > Play > Filters

It should be using LAV Splitter and decoders. If you see ffdshow there, then uninstall it, or disable it with Codec Tweak Tool.

Seems as expected. No ffdshow here.

Installed and Uninstalled SVP, now madvr lagging. BoPgWfu

Admin wrote:Click on LAV Video Decoder and check if hardware decoding is enabled. Recommend in combination with madVR is either DXVA2 Copyback or D3D11.

Tried both DXVA2 and D3D11, same results (lagging).

Installed and Uninstalled SVP, now madvr lagging. ZgdvHXi

Admin wrote:Press Ctrl+Shift+Esc to open the Windows Task Manager. Check that CPU isn't near 100% during playback.

It is consuming 19% of CPU for some reason. Even though madvr is working. Before SVP, it surely wasn't this high.

Installed and Uninstalled SVP, now madvr lagging. IZ6DoiB

Admin wrote:Press Ctrl+J to view the madVR statistics overlay during playback. Look at the rendertime and the amount of dropped frames. For a 24fps video, the rendertime should be below 41 ms. If it is higher, then you need to adjust madVR settings to use simpler scaling algorithms.

I am not sure if something is awry here:

Installed and Uninstalled SVP, now madvr lagging. ChY2iB6

Admin wrote:If you need more help, then give a screenshot of the statistics overlay. Also mention which GPU(s) you have. If you have two, then you may need to set the powerful one as preferred for MPC-HC. You can do that in the Windows 10 display settings.

Already done.
https://i.imgur.com/4zviYBq.png

I have a NVIDIA 1060 (ZOTAC) 6GB.


SVP has surely changed some settings..... But I am not able to find exactly which ones it changed. Even after reinstalls the same settings persist.

lolcocks

Posts : 7
Join date : 2017-06-26

Back to top Go down

Installed and Uninstalled SVP, now madvr lagging. Empty Re: Installed and Uninstalled SVP, now madvr lagging.

Post by Admin on Thu Dec 17, 2020 8:35 pm

madvr settings > rendering > window mode > video frames presented in advance = 3
Make same change for exclusive mode. If value 3 does not solve it, then try value 1.

You can reduce frequency of frame repeats by changing your refresh rate to 59 Hz.

Admin
Admin

Posts : 5638
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Installed and Uninstalled SVP, now madvr lagging. Empty Re: Installed and Uninstalled SVP, now madvr lagging.

Post by Admin on Thu Dec 17, 2020 8:38 pm

CPU usage is not unusual. With 4k video a lot of data needed to be copied to and from memory, which is done by the CPU.

Admin
Admin

Posts : 5638
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Installed and Uninstalled SVP, now madvr lagging. Empty Re: Installed and Uninstalled SVP, now madvr lagging.

Post by lolcocks on Fri Dec 18, 2020 5:52 pm

Admin wrote:madvr settings > rendering > window mode > video frames presented in advance = 3
Make same change for exclusive mode. If value 3 does not solve it, then try value 1.

You can reduce frequency of frame repeats by changing your refresh rate to 59 Hz.


Tried everything. Still not working. Sad

I just realized, only 4K 60FPS video is taking a hit. Everything else seems fine.

What the hell did SVP do? Is there a way to completely reset madvr settings? I think reinstall did it but I am not 100% sure.

Confusing times. Sad

lolcocks

Posts : 7
Join date : 2017-06-26

Back to top Go down

Installed and Uninstalled SVP, now madvr lagging. Empty Re: Installed and Uninstalled SVP, now madvr lagging.

Post by Admin on Fri Dec 18, 2020 11:36 pm

You can reset settings of madVR with the Codec Tweak Tool.

With 60 fps video, the rendertime in madVR must be no higher than 16 milliseconds.

Admin
Admin

Posts : 5638
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Installed and Uninstalled SVP, now madvr lagging. Empty Re: Installed and Uninstalled SVP, now madvr lagging.

Post by lolcocks on Sun Dec 27, 2020 4:07 pm

Admin wrote:You can reset settings of madVR with the Codec Tweak Tool.

With 60 fps video, the rendertime in madVR must be no higher than 16 milliseconds.

Okay, I finally fixed the issue.

It seems that SVP makes changes to the NVIDIA drivers.

I reinstalled NVIDIA drivers (with the "perform clean install" option checked) and everything started working perfectly.

Thank you for all your help and thank you for bundling everything together for so many years. I am sure you have an idea how extremely convenient K-Lite Codec Pack is.

lolcocks

Posts : 7
Join date : 2017-06-26

Back to top Go down

Installed and Uninstalled SVP, now madvr lagging. Empty Re: Installed and Uninstalled SVP, now madvr lagging.

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum