Codec Guide
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Audio HDMI passthrough not working above 1.5.4.8

Go down

Audio HDMI passthrough not working above 1.5.4.8 Empty Audio HDMI passthrough not working above 1.5.4.8

Post by ryek on Wed Nov 11, 2020 7:24 pm

Sorry for my bad English.
I have problem with audio HDMI passthrough on fresh install K-Lite Mega Codec above 1.5.4.8. 1.5.4.8 is lattest version then HDMI passthrough works. Off corse in all above version i check hdmi passthrough but not working - then on my LCD ampituner is STEREO. When I install fresh version 1.5.4.8 and then the newest then all is working.
Why doesn't work in fresh install of newest version K-Lite ?

Thanks,
Thomas

ryek

Posts : 3
Join date : 2020-11-11

Back to top Go down

Audio HDMI passthrough not working above 1.5.4.8 Empty Re: Audio HDMI passthrough not working above 1.5.4.8

Post by Admin on Wed Nov 11, 2020 10:56 pm

Most likely the correct audio device is not set as the default one in the Windows sound settings.

Otherwise disable "Fallback to PCM if bitstreaming is not supported" option in LAV Audio decoder.

Admin
Admin

Posts : 5542
Join date : 2011-06-17

https://codecs.forumotion.net

ryek likes this post

Back to top Go down

Audio HDMI passthrough not working above 1.5.4.8 Empty Re: Audio HDMI passthrough not working above 1.5.4.8

Post by ryek on Thu Nov 12, 2020 1:57 pm

Ok. It is working now but in previous version this option is enabled on deffault and HDMI passthrough is working. Strange.
When I install 1.5.4.8 and then the newest version is working too with enabled "Fallback to PCM...".
Only then I fresh install above 1.5.4.8 the I must disable "Fallback to PCM...".
Thanks.

ryek

Posts : 3
Join date : 2020-11-11

Back to top Go down

Audio HDMI passthrough not working above 1.5.4.8 Empty Re: Audio HDMI passthrough not working above 1.5.4.8

Post by Admin on Thu Nov 12, 2020 2:00 pm

Check what is different here:
MPC menu > Play > Filters

Maybe it is because of internal audio renderer?

Admin
Admin

Posts : 5542
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Audio HDMI passthrough not working above 1.5.4.8 Empty Re: Audio HDMI passthrough not working above 1.5.4.8

Post by ryek on Thu Nov 12, 2020 3:51 pm

No. Always LAV Audio Decoder.

ryek

Posts : 3
Join date : 2020-11-11

Back to top Go down

Audio HDMI passthrough not working above 1.5.4.8 Empty Re: Audio HDMI passthrough not working above 1.5.4.8

Post by Admin on Thu Nov 12, 2020 4:51 pm

Decoder and renderer are two different things. The output of the decoder goes into the renderer.

The internal audio renderer was not used by default in the past. You can change the renderer here:
Options > Playback > Output

Admin
Admin

Posts : 5542
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Audio HDMI passthrough not working above 1.5.4.8 Empty Re: Audio HDMI passthrough not working above 1.5.4.8

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum