Codec Guide
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Interesting possible codec issue.

Go down

Interesting possible codec issue. Empty Interesting possible codec issue.

Post by Cryonixia on Wed Sep 23, 2020 11:38 pm

So I have a unique issue at which I'm not sure where to start.

I have several older games that I play from platforms that have updated them to Windows 10, one being Panzer General 2. This game runs fine, the music is all good, however the SFX does not work after a update of the updates from the Codec pack I did. Unfortunately it could have been any within 7 1/2 months from the day before yesterday which was the last time I played it.

I'm running Mega Codec pack and the latest 15.7.5. On Windows Pro 10.

I have gone through all the troubleshooting outside of the Codec pack that I have been able to find, and got in touch with support from the game itself with no luck. The biggest issue for this game I've found that people having this issue is the MCI is the Media Control Interface in Windows.

I'm not 100% if the Codec pack changes these, or does something with it, but I'm out of options outside of asking for help on if there is something specific in some setting or something somewhere I can change things to work on adjusting settings to see if my SFX will return to the game. I just know it's somewhere within the Codec pack I downloaded as my SFX works on one of my other computers with a similar setup without the pack.

Obivously I could uinstall it, but I rather like the options and especially the player that the pack comes with. If going to a lower pack would fix this I would be fine with that, as long as I could use the player. I just have not tried that as I'm not to sure how much each changes with each for the codecs' or even want to uninstall if it has nothing somehow related to it.

PS: Forgot to add I'm using Arctis Pro Wireless! Not sure if that will help any.

Thanks in advanced!

Cryonixia

Posts : 3
Join date : 2020-09-23

Back to top Go down

Interesting possible codec issue. Empty Re: Interesting possible codec issue.

Post by Admin on Thu Sep 24, 2020 12:35 pm

Do you know which audio file format the game uses for the SFX?

You can compare MCI registry keys on two systems:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\MCI Extensions
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\MCI32

Admin
Admin

Posts : 5445
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Interesting possible codec issue. Empty Re: Interesting possible codec issue.

Post by Cryonixia on Thu Sep 24, 2020 6:26 pm

Admin wrote:Do you know which audio file format the game uses for the SFX?

You can compare MCI registry keys on two systems:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\MCI Extensions
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\MCI32

I am not sure what format other than .MEL with what I see in the sound files and what I can find online. Tho not really sure if that's the format. As far as the registry keys I'll have a look at that. Will be a few days unfortunately as I'm not at home. Thank you for the idea, will look at that first chance I get. =)

Cryonixia

Posts : 3
Join date : 2020-09-23

Back to top Go down

Interesting possible codec issue. Empty Re: Interesting possible codec issue.

Post by Admin on Fri Sep 25, 2020 11:38 am

I found that the .mel files contain WAV audio. At least in the original game.

Admin
Admin

Posts : 5445
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Interesting possible codec issue. Empty Re: Interesting possible codec issue.

Post by Admin on Fri Sep 25, 2020 11:43 am

You can use this to compare installed codecs:
Codec Tweak Tool > Generate Log

Admin
Admin

Posts : 5445
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Interesting possible codec issue. Empty Re: Interesting possible codec issue.

Post by Cryonixia on Mon Sep 28, 2020 10:25 am

I'm not sure what I did, but I uninstalled my Codec Pack, and installed the Standard version instead of the higher one. Then updated it, and things are working now. Something in one of the higher packs from an old install was causing the issue. It could of been a number of things. Thankfully with the checking the Codecs the Standard one when installed matched it. ^.^; So a bonus, thank you for the help! Matching them up help me find the problem even if I don't know what one it was. Lol

Cryonixia

Posts : 3
Join date : 2020-09-23

Back to top Go down

Interesting possible codec issue. Empty Re: Interesting possible codec issue.

Post by Admin on Mon Sep 28, 2020 7:25 pm

It is probably just the re-install that fixed it. Other applications such as video converters often mess with the codecs. Big Windows 10 updates can also "undo" some of the changes made by the pack.

Admin
Admin

Posts : 5445
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Interesting possible codec issue. Empty Re: Interesting possible codec issue.

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum