Codec Guide
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Audio madness

Go down

Audio madness Empty Audio madness

Post by Arpegius on Sun Aug 23, 2020 4:56 pm

Hello,

I would like to report a "problem", or at least a change of behavior with MPC-HC and its codecs.
With Windows 7, Windows 8/8.1, and with Windows 10 1809, MPC-HC (with the standard installation of the LAV codecs of Mega Pack) used to send PCM audio to my Home Theater (a 7.2 system), but at least the audio was on par with the video file's one - it sent PCM 2.0 for stereo, 5.1 for 5.1, 7.1 for 7.1.
But then, with Windows 10 updates 1903, 1909 and now 2004, MPC-HC simply broke out - it can only send PCM 2.0, no matter what.

I searched for a solution and found the ffdshow "AC3 (S/PDIF encode mode)" + "Resample to 48000Hz" solution, which worked great - it transformed everything to Dolby: Normal Stereo became Dolby Digital 2.1, and what used to be played as PCM 5.1 became Dolby Digital 5.1 - even DTS became Dolby Digital 5.1.

But not everything was roses. First, this encoder was has a bitrate limit of 640, which destroys the audio quality of many releases. It can't play some audio types as well, when they're correctly encoded to something other than AAC or AC3 (bellow).

I also tried to look for problems in Windows, but to no avail. In fact, Windows showed some real nice tidbits. I installed those Windows Media Codecs from the Microsoft Store (HEVC, AV1, VP9 and MPEG-2) and opened some video files with them. The result, to my surprise, was perfect decoding of both the Dolby and DTS plethora, natively, unlike the ffdshow gimmick.

But again, not everything was roses. Movies & TV (and WMP) failed to recognize something as a Mono AC3 file (bellow), becoming mute, and also an AC3 not properly encoded (this example is not in the photos bellow).

Bellow is the comparison of 3 movies I took pictures of (observe the receiver's display):

Audio madness Aac_lc10
Here is [aac lc 48000 mono 127kbs mpc-hc], with MPC-HC converting it to Dolby Digital Mono via ffdshow.

Audio madness Aac_lc11
Here the same movie, but with Movies & TV [aac lc 48000 mono 127kbs movies and tv] - it breaks and show a Mute Stereo (the BD symbol is the name of the receiver's HDMI port)

Audio madness Ac3_4810
A different movie, now [ac3 48000 5.1 640kbs mpc-hc]. ffdshow makes it Dolby Digital 5.1 (3/2.1).

Audio madness Ac3_4811
But with Movies & TV [ac3 48000 5.1 640kbs movies and tv], it shows differently, and I think, more correctly: Dolby Digital EX. The rear speakers got filled as well, making the 5.1 turn into a "7.1" of sorts.

Audio madness Dts-hd11
Finally, a DTS-HD Master Audio movie, encoded to 6 channels [dts-hd ma 48000 6.1 s16 mpc-hc]. MPC-HC breaks and mutes it - ffdshow doesn't convert it to some sort of Dolby 5.1 either.

Audio madness Dts-hd10
But when using Movies & TV [dts-hd ma 48000 6.1 s16 movies and tv], it displays pretty much as it should correctly.

So, I'm out of options.
I really didn't want to ditch your MPC-HC before (there's really no other good player out there), and it seems I can't really do this now (subtitles for Movies & TV are also very bad). A mix of the two players must be used depending on how the audio is presented.

Is there any solution to this problem? Can MPC-HC incorporate some of these high quality Windows Codecs? Also, is there a better way to fix its own audio problems without the limited ffdshow fix?

Thank you very much for your work, by the way. I use your software since the olden times of Kazaa and eMule and they've never failed me before. I much appreciate your work.

Arpegius

Posts : 9
Join date : 2020-08-23

Back to top Go down

Audio madness Empty Re: Audio madness

Post by Admin on Sun Aug 23, 2020 7:23 pm

You should use ffdshow audio processor instead of ffdshow audio decoder. Use LAV Audio decoder for decoding everything. In LAV Audio settings, enable bitstreaming for all formats that are supported by your receiver. Those are then send untouched to your receiver, so you will get full quality. Only the formats that can't be bitstreamed directly (mostly AAC) will be processed by ffdshow and converted to AC3.

More details here:
http://codecguide.com/faq_configuration.htm#item7

Enabling Resample and Mixer in ffdshow as described in the FAQ should solve problem where certain formats are not converted correctly.

Admin
Admin

Posts : 5378
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Audio madness Empty Re: Audio madness

Post by Admin on Sun Aug 23, 2020 7:24 pm

Dolby Digital EX = E-AC3

Admin
Admin

Posts : 5378
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Audio madness Empty Re: Audio madness

Post by Arpegius on Sun Aug 23, 2020 7:48 pm

Thank you for your reply, but I've already tried what you said (every option). 7.1 audio, or more advanced formats like Dolby TrueHD and DTS-HD MA aren't supported by the ffdshow encoding (I'm using it as a processor, along with LAV as decoder).

I tried bitstream as well, to no avail. It seems to be a problem exclusive to MPC-HC's LAV, as other codecs (Windows) work correctly.

Arpegius

Posts : 9
Join date : 2020-08-23

Back to top Go down

Audio madness Empty Re: Audio madness

Post by Admin on Sun Aug 23, 2020 11:14 pm

The LAV decoder works perfectly fine for others, so problem must be on your end.

1) Do a fresh install of the codec pack. Use default settings, so do not enable ffdshow yet.
2) Enable bitstreaming in LAV Audio.
3) Test if bitstreaming works for AC3 and DTS.
Then test if TrueHD or DTS-HD MA works.
4) If it doesn't work at all, then check if correct audio device is selected here:
MPC-HC options > Internal Filters > Audio Renderer
For example often Speakers is set as default in Windows instead of the HDMI device.
If it is correct there, then test different audio renderer (default is internal one).
MPC-HC options > Playback > Output > Audio Renderer
5) If everything above is correct, but bitstreaming still does not work then go here:
Windows Control Panel > Sound > device > Properties
There is a tab where you can see the supported formats for bitstreaming. Check that everything is enabled and listed there.
6) If you have latest NVIDIA driver, then try an older version, as it has some HDMI issues.

Once bitstreaming works in LAV, you can add ffdshow audio processor for handling conversion of other audio formats.

Admin
Admin

Posts : 5378
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Audio madness Empty Re: Audio madness

Post by Arpegius on Mon Aug 24, 2020 2:09 am

Thank you again. But I tried everything you said again, and nothing works.

My device supports these formats, so, it would support bitstreaming, and the fact that WMP/Movies&TV make it work says something).

This problem presents itself in two devices here, an ASUS notebook and a Dell one, both with only an integrated Intel card.

I came here precisely because nothing works, I've tried it all.

But, still, thank you very much for your time. I appreciate your work immensely.
Best regards.

Arpegius

Posts : 9
Join date : 2020-08-23

Back to top Go down

Audio madness Empty Re: Audio madness

Post by Admin on Mon Aug 24, 2020 1:38 pm

I do not give up easily Wink

Could you make a screenshot of your audio device list?
Codec Tweak Tool > Audio Output > Windows Sound Settings

Which filters are active during playback?
MPC-HC menu > Play > Filters > copy to clipboard

WMP is sometimes able to find the 'correct' output device even when that one isn't the default one. A common cause of bitstreaming failure is wrong one being set as default.

In LAV Audio there is an option called "Fallback to PCM if bitstreaming is not supported". Try with that option disabled. That may help if another filter is interfering. If the audio renderer does not accept the bitstreaming input, then LAV Audio will now fail to load. So check filter list.

Admin
Admin

Posts : 5378
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Audio madness Empty Re: Audio madness

Post by Arpegius on Mon Aug 24, 2020 6:46 pm

Admin wrote:I do not give up easily Wink
Thank you very much! Because this here worked:
Admin wrote:In LAV Audio there is an option called "Fallback to PCM if bitstreaming is not supported". Try with that option disabled. That may help if another filter is interfering. If the audio renderer does not accept the bitstreaming input, then LAV Audio will now fail to load. So check filter list.
I tried doing that in the ffdshow processor, but it didn't work - but it did with LAV.
Admin wrote:Could you make a screenshot of your audio device list?
Codec Tweak Tool > Audio Output > Windows Sound Settings
Audio madness Asus_l10
(it's in portuguese, but you might understand the stuff)
Admin wrote:Which filters are active during playback?
MPC-HC menu > Play > Filters > copy to clipboard
Filters currently loaded:
 - Default DirectSound Device
 - Video Renderer Aprimorado (personalizado) [enhanced video renderer]
 - Audio Switcher
 - LAV Video Decoder (internal)
 - ffdshow Audio Processor
 - LAV Audio Decoder (internal)
 - LAV Splitter Source (internal)
Admin wrote:WMP is sometimes able to find the 'correct' output device even when that one isn't the default one. A common cause of bitstreaming failure is wrong one being set as default.
It seems like this was really the case. Now MPC-HC is decoding just like WMP.
Now it would be the case to promote this solution for other people that might need it, or maybe fix this (I don't know if it's possible) by default.
Thank you again! You rock!

Arpegius

Posts : 9
Join date : 2020-08-23

Back to top Go down

Audio madness Empty Re: Audio madness

Post by Admin on Mon Aug 24, 2020 6:54 pm

Now I am confused. Which change solved the problem? Disabling "Fallback to PCM if bitstreaming is not supported", or setting correct audio device as default?

Admin
Admin

Posts : 5378
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Audio madness Empty Re: Audio madness

Post by Arpegius on Mon Aug 24, 2020 7:18 pm

Admin wrote:Now I am confused. Which change solved the problem? Disabling "Fallback to PCM if bitstreaming is not supported", or setting correct audio device as default?
Disabling "Fallback to PCM if bitstreaming is not supported" in LAV fixed it.
My audio device was already set up correctly.


Last edited by Arpegius on Mon Aug 24, 2020 7:36 pm; edited 2 times in total

Arpegius

Posts : 9
Join date : 2020-08-23

Back to top Go down

Audio madness Empty Re: Audio madness

Post by Admin on Mon Aug 24, 2020 7:31 pm

Can you confirm the following?
1) If you play AC3/DTS with fallback option disabled, then filter list does not contain ffdshow (LAV bitstreams). Correct?
2) If you play AC3/DTS with fallback option enabled, does the filter list show ffdshow?

LAV has a workaround to prevent connection to ffdshow when it tries to bitstream. But perhaps that is not working properly. I need to check that. Disabling the fallback achieves the same, but can fail playback when no device is available for bitstreaming.

Admin
Admin

Posts : 5378
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Audio madness Empty Re: Audio madness

Post by Arpegius on Mon Aug 24, 2020 7:54 pm

Admin wrote:Can you confirm the following?
1) If you play AC3/DTS with fallback option disabled, then filter list does not contain ffdshow (LAV bitstreams). Correct?
dts-hd ma, 48000Hz, 6.1, s16 wrote:Filters currently loaded:
 - Default DirectSound Device
 - Video Renderer Aprimorado (personalizado)
 - Audio Switcher
 - LAV Video Decoder (internal)
 - LAV Audio Decoder (internal)
 - LAV Splitter Source (internal)
ac3, 48000 Hz, 5.1, 640 kb/s wrote:Filters currently loaded:
 - Default DirectSound Device
 - Video Renderer Aprimorado (personalizado)
 - Audio Switcher
 - LAV Video Decoder (internal)
 - LAV Audio Decoder (internal)
 - LAV Splitter Source (internal)
aac lc, 48000 Hz, 5.1 wrote:This one needs ffdshow to work (it worked here), or audio breaks
Filters currently loaded:
 - Default DirectSound Device
 - Video Renderer Aprimorado (personalizado)
 - Audio Switcher
 - LAV Video Decoder (internal)
 - ffdshow Audio Processor
 - LAV Audio Decoder (internal)
 - LAV Splitter Source (internal)
Admin wrote:2) If you play AC3/DTS with fallback option enabled, does the filter list show ffdshow?
Not so much. Same list as above:
dts-hd ma, 48000Hz, 6.1, s16 wrote:Audio broke
Filters currently loaded:
 - Internal Audio Renderer
 - Video Renderer Aprimorado (personalizado)
 - Audio Switcher
 - LAV Video Decoder (internal)
 - LAV Audio Decoder (internal)
 - LAV Splitter Source (internal)
ac3, 48000 Hz, 5.1, 640 kb/s wrote:Audio broke
Filters currently loaded:
 - Internal Audio Renderer
 - Video Renderer Aprimorado (personalizado)
 - Audio Switcher
 - LAV Video Decoder (internal)
 - LAV Audio Decoder (internal)
 - LAV Splitter Source (internal)
aac lc, 48000 Hz, 5.1 wrote:ffdshow turned it into Dolby Digital 5.1 correctly
Filters currently loaded:
 - Default DirectSound Device
 - Video Renderer Aprimorado (personalizado)
 - Audio Switcher
 - LAV Video Decoder (internal)
 - ffdshow Audio Processor
 - LAV Audio Decoder (internal)
 - LAV Splitter Source (internal)
Admin wrote:LAV has a workaround to prevent connection to ffdshow when it tries to bitstream. But perhaps that is not working properly. I need to check that. Disabling the fallback achieves the same, but can fail playback when no device is available for bitstreaming.
It seems that it wasn't the case, because ffdshow wasn't active in the first two movies, before or after, with Bitstream turned on.
When Bitstream is turned off, ffdshow works on these 3 movies on both accounts of "Fall back to PCM": enable and disabled. In the second movie, whereas it was Dolby Digital EX 3/2.1 before, it turns into a generic Dolby Digital 3/2.1. The first movie just breaks the audio.

Still and of notice: PCM wasn't working. Prior to versions 2004, 1909 and 1903, every Windows 10 (and 7 and 8/8.1) version worked correctly sending the PCM to the receiver.

Arpegius

Posts : 9
Join date : 2020-08-23

Back to top Go down

Audio madness Empty Re: Audio madness

Post by Admin on Mon Aug 24, 2020 11:03 pm

Thanks for testing. I will investigate why the workaround isn't working as intended. You can keep the "Fallback to PCM" option disabled.

Regarding PCM output. I assume you mean the problem that it only does 2.0 PCM, right?

Check these two settings:
1) Mixing in LAV Audio. Disable its mixer and it should output the same amount of channels as the audio track has.
2) Mixing done by Windows. Click on the Configure button for your device in the Windows sound settings. There you can configure the speaker count. I suspect this setting is currently wrong.

Of course, when you have 7.1 PCM working again, then you don't need ffdshow anymore.

Admin
Admin

Posts : 5378
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Audio madness Empty Re: Audio madness

Post by Arpegius on Mon Aug 24, 2020 11:28 pm

Admin wrote:Thanks for testing. I will investigate why the workaround isn't working as intended. You can keep the "Fallback to PCM" option disabled.
My pleasure.
Admin wrote:Regarding PCM output. I assume you mean the problem that it only does 2.0 PCM, right?
Yes, correct.
Admin wrote:Check these two settings:
1) Mixing in LAV Audio. Disable its mixer and it should output the same amount of channels as the audio track has.
This here I keep disabled, precisely because on or off, it doesn't do anything.
Audio madness Mix10
Admin wrote:2) Mixing done by Windows. Click on the Configure button for your device in the Windows sound settings. There you can configure the speaker count. I suspect this setting is currently wrong.
You mean this? I think it's correct. (I set up it all the range, from 16/44.1 to 24/192, and none of the options made a difference) (I could take a photo of the compatible audio format list my receiver supports from my PS3, but basically, it can do every single PCM).
Audio madness 7110
Admin wrote:Of course, when you have 7.1 PCM working again, then you don't need ffdshow anymore.
Yes, this whole saga started precisely because 7.1 PCM stopped working, but I think this isn't a MPC-HC problem, nor a K-Lite one, but something must have broken in Windows with these updates (I did clean installs already, and the problem happens with other machines).

Arpegius

Posts : 9
Join date : 2020-08-23

Back to top Go down

Audio madness Empty Re: Audio madness

Post by Admin on Tue Aug 25, 2020 12:13 am

That all looks correct.

Another thing to try:
MPC-HC options > Playback > Output > Audio Renderer > Internal Audio Renderer
MPC-HC options > Internal Filters > Audio Renderer > Enable Exclusive Mode

If that doesn't help, then it is probably a driver issue, considering that everything is configured correctly. Try with a newer version of the Intel driver. Let me know your GPU model if you need help finding driver.

Or what you can also try is to replace the Intel driver with the generic "Microsoft High Definition Audio Device" driver. That one works pretty good, and is a good alternative for buggy drivers from other vendors.

Admin
Admin

Posts : 5378
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Audio madness Empty Re: Audio madness

Post by Arpegius on Tue Aug 25, 2020 12:52 am

That didn't help with PCM, but something came out of it: if I enable Exclusive Mode, I can also enable "Fall back to PCM" in LAV. It doesn't actually render as PCM (of course, Bitstream is On), it keeps outputing Dolby or DTS.
If I remove their Bitstream options, PCM doesn't show up either, audio just breaks.

The notebooks use Intel Graphics, but their audio drivers are generic Microsoft High Definition ones.
I really think something broke within Windows with 2004, 1909 and 1903.

Arpegius

Posts : 9
Join date : 2020-08-23

Back to top Go down

Audio madness Empty Re: Audio madness

Post by Admin on Tue Aug 25, 2020 3:37 pm

Interesting. When it breaks, can you make a screenshot of the status page of the audio renderer?
Menu > Play > Filters > Internal Audio Renderer

Does it accept PCM if you enable mixer in LAV and set it to stereo? Then it really seems like a bug in the driver that breaks with 5.1/7.1 PCM input.

Admin
Admin

Posts : 5378
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Audio madness Empty Re: Audio madness

Post by Arpegius on Tue Aug 25, 2020 4:46 pm

Admin wrote:Interesting. When it breaks, can you make a screenshot of the status page of the audio renderer?
Menu > Play > Filters > Internal Audio Renderer

Does it accept PCM if you enable mixer in LAV and set it to stereo? Then it really seems like a bug in the driver that breaks with 5.1/7.1 PCM input.
Audio madness Iar10
Audio madness List10
Audio madness List210
LAV mixer is turned off here. But then this happens:
If I enable LAV Mixer in 7.1, audio breaks into PCM 2.0.
LAV Mixer in 5.1, it goes to ffdshow and returns as Dolby Digital 5.1 (this is a DTS 6.1 movie).
LAV Mixer in 2.0, it goes to ffdshow and returns as Dolby Digital 2.0.
If I disable ffdshow, no matter what I put in the LAV Mixer, it outputs as PCM 2.0.
Also, I tried putting the receiver on 16bit (44.1, 48, 96, etc), but it makes no difference.

This is when LAV Mixer is on 7.1 (but they all break into PCM 2.0 anyway) and ffdshow is off:
Audio madness Iar210

Finally, this here is how it is when it works on Bitstream (and also when LAV Mixer is set to 2.0/5.1 and ffdshow is converting it to Dolby Digital):
Audio madness Iar310

So, PCM 2.0 works, everything beyond it is broken.

Arpegius

Posts : 9
Join date : 2020-08-23

Back to top Go down

Audio madness Empty Re: Audio madness

Post by Admin on Tue Aug 25, 2020 10:26 pm

I don't see anything wrong in the renderer status. The problem must be in the driver or the receiver.

I am out of ideas. But luckily you have a way to avoid the problem.

Admin
Admin

Posts : 5378
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Audio madness Empty Re: Audio madness

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum