Painfully loud noise with E-AC-3 audio and an optical cable

Go down

Painfully loud noise with E-AC-3 audio and an optical cable Empty Painfully loud noise with E-AC-3 audio and an optical cable

Post by Codec42 on Wed May 06, 2020 7:56 pm

Some video files, when played in Windows Media Player and using an optical (S/PDIF) cable, make a noise that sounds like a machine gun. Even though the volume is set to the lowest level it plays at full volume. Using MediaInfo it appears to only occur with mkv files that use the E-AC-3 (Enhanced AC-3) format. If I change to a USB cable instead of optical then it works, and if I use VLC instead of Windows Media Player then it works.

I'm using version 15.4.6. I noticed in the FAQ the question about AC3 audio giving noise in WMP12 so I tried disabling "Microsoft DTV-DVD Audio Decoder" (and the 64-bit one) but it didn't make a difference. I've also tried changing all of the bitstreaming settings in Codec Tweak Tool > Audio output.

How can I get the noises to stop? It's quite a scare accidentally opening one of these files...

Codec42

Posts : 5
Join date : 2020-05-06

Back to top Go down

Painfully loud noise with E-AC-3 audio and an optical cable Empty Re: Painfully loud noise with E-AC-3 audio and an optical cable

Post by Admin on Wed May 06, 2020 9:48 pm

I recommend using Media Player Classic from the codec pack. WMP is a huge piece of shit.

Bitstreaming E-AC3 over SPDIF is not possible. It seems it is somehow being handled as regular AC3. Try disabling bitstreaming. When the Microsoft decoder is disabled, WMP should use LAV Audio Decoder. You should see a blue icon for it in the system tray when it is active.

Admin
Admin

Posts : 5136
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Painfully loud noise with E-AC-3 audio and an optical cable Empty Re: Painfully loud noise with E-AC-3 audio and an optical cable

Post by Codec42 on Wed May 06, 2020 9:59 pm

I'd prefer not to use MPC just because I dislike its UI.

I've tried disabling bitstreaming in Codec Tweak Tool > Audio output and disabling the "Microsoft DTV-DVD Audio Decoder" but no LAV Audio Decoder icon shows up. The icon does show up with other videos.

I just noticed the issue occurs with AC-3 as well as E-AC-3 videos.

Codec42

Posts : 5
Join date : 2020-05-06

Back to top Go down

Painfully loud noise with E-AC-3 audio and an optical cable Empty Re: Painfully loud noise with E-AC-3 audio and an optical cable

Post by Codec42 on Wed May 06, 2020 10:12 pm

Actually with further checking, I'm not seeing the icons on any videos anymore, I used to. It does seem like LAV Audio Decoder is enabled throughout the tweak pages and the three "Enable System Tray Icon" checkboxes are checked.

Codec42

Posts : 5
Join date : 2020-05-06

Back to top Go down

Painfully loud noise with E-AC-3 audio and an optical cable Empty Re: Painfully loud noise with E-AC-3 audio and an optical cable

Post by Admin on Wed May 06, 2020 10:15 pm

Are you using Windows 10? Then you must disable Media Foundation for .mkv with the Codec Tweak Tool.

Admin
Admin

Posts : 5136
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Painfully loud noise with E-AC-3 audio and an optical cable Empty Re: Painfully loud noise with E-AC-3 audio and an optical cable

Post by Codec42 on Wed May 06, 2020 10:19 pm

Yes I am. That worked, thank you! Now to research exactly why it works.

Codec42

Posts : 5
Join date : 2020-05-06

Back to top Go down

Painfully loud noise with E-AC-3 audio and an optical cable Empty Re: Painfully loud noise with E-AC-3 audio and an optical cable

Post by Codec42 on Wed May 06, 2020 10:24 pm

Ah, there's actually a FAQ entry here for that.

Codec42

Posts : 5
Join date : 2020-05-06

Back to top Go down

Painfully loud noise with E-AC-3 audio and an optical cable Empty Re: Painfully loud noise with E-AC-3 audio and an optical cable

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum