Codec Guide
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Persistent "Missing codec" message

Go down

Persistent "Missing codec" message Empty Persistent "Missing codec" message

Post by js3k on Tue Jul 30, 2019 12:25 am

Hi, I received this message when trying to play *.mov files taken from my iPhoneXSMAX:

Missing codec This item was encoded in a format that's not supported. 0xc00d5212

The same files from my previous iPhone still play.

In trying to resolve this, I installed the K-Lite_Codec_Pack_1500_Mega following the instructions seen here: https://www.youtube.com/watch?v=GEyKdQqZ9HM

All this did however was make the thumbnails of the codex-missing *.mov files gray and pastel colored, instead of the previous default icon. The same message is generated:

Missing codec This item was encoded in a format that's not supported. 0xc00d5212

What can I do?

js3k

Posts : 7
Join date : 2019-07-30

Back to top Go down

Persistent "Missing codec" message Empty Re: Persistent "Missing codec" message

Post by Admin on Tue Jul 30, 2019 1:11 pm

Solution can be found on the bottom here:
http://codecguide.com/faq_wmp.htm#item13

Could you make a short test recording and upload it for me? Then I can get the thumbnails fixed. You can upload the file to http://www.sendspace.com or another file hosting site.

Admin
Admin

Posts : 5445
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Persistent "Missing codec" message Empty Re: Persistent "Missing codec" message

Post by js3k on Fri Aug 02, 2019 12:42 am

Hi, thank you for your swift reply. I neglected to add that I’m using Windows 10.

So I followed your link to the bottom to download MPEG-2, and successfully installed that.

After rebooting, the problem persisted.

Here is a link to a screenshot:
https://drive.google.com/open?id=1WsPE0_FRPmsRNxPvUKsXJY7-v78HoDIp (I have removed personal/irrelevant file information from the screenshot.)

The gray-pastel .MOV files stand out from 2018-10-05 onward.

What else can I download? Thanks again for your help!

js3k

Posts : 7
Join date : 2019-07-30

Back to top Go down

Persistent "Missing codec" message Empty Re: Persistent "Missing codec" message

Post by Admin on Fri Aug 02, 2019 3:02 pm

The videos probably need the HEVC codec.

Alternatively, you can do this to force WMP to use the codecs from K-Lite:
Codec Tweak Tool > Media Foundation > disable for .mov

Could you still please upload one of those videos for me? A few seconds long test recording is fine. That would be helpful for getting the thumbnail fixed. You can send link as a private message if desired.

Admin
Admin

Posts : 5445
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Persistent "Missing codec" message Empty Re: Persistent "Missing codec" message

Post by js3k on Fri Aug 09, 2019 5:42 pm

So I found that the videos from my iPhone XS MAX are only missing a codec when uploaded to Dropbox on my home Windows 10 computer. On my work Windows 10 computer those same videos play fine when viewed in Dropbox.

When I email the same video to myself or upload it to Google Drive, the video plays fine on my home computer.

I uploaded a test video that was uploaded to Dropbox and is missing a codec on my home computer: https://drive.google.com/open?id=1rUzW4A5rDVjXtXiMrifMvOHdZ9QOq2KV

Based on this more exact information, what action can I take?

js3k

Posts : 7
Join date : 2019-07-30

Back to top Go down

Persistent "Missing codec" message Empty Re: Persistent "Missing codec" message

Post by Admin on Sat Aug 10, 2019 3:23 pm

The video uses HEVC format as expected.

You can get this codec in the Windows Store:
https://www.microsoft.com/en-us/p/hevc-video-extensions-from-device-manufacturer/9n4wgh0z6vhq
or
https://www.microsoft.com/en-us/p/hevc-video-extensions/9nmzlz57r3t7
First link is a free version, but requires a graphics card with HEVC acceleration. Second one costs $1.

Older versions of Windows 10 included the codec, so that is why it may have worked on your other computer.

The K-Lite Codec Pack also contains a decoder for HEVC, but WMP doesn't use it by default. Two ways for force WMP to use the codecs from K-Lite:
1) Rename the video from .mov to .video
2) Use Codec Tweak Tool to disable Media Foundation

Another option is to use the MPC-HC player from K-Lite to play the files. That plays everything.

Admin
Admin

Posts : 5445
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Persistent "Missing codec" message Empty Re: Persistent "Missing codec" message

Post by js3k on Wed Aug 14, 2019 3:30 am

Success! I installed the latest version of your K-Lite_Codec_Pack_1512_Mega. Thanks for your patience. You are wonderful.

The thumbnails are still pastel-gray. But in the Codec Tweak Tool I can select .mov (under Miscellaneous > Thumbnails). Is this the menu where this can be corrected? I'm a little confused, it's late here, and don't want to guess. Thanks again.

js3k

Posts : 7
Join date : 2019-07-30

Back to top Go down

Persistent "Missing codec" message Empty Re: Persistent "Missing codec" message

Post by Admin on Wed Aug 14, 2019 2:45 pm

The thumbnail issue will be solved in a future update.

Admin
Admin

Posts : 5445
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Persistent "Missing codec" message Empty Re: Persistent "Missing codec" message

Post by js3k on Wed Aug 14, 2019 2:53 pm

Ok, thank you.

js3k

Posts : 7
Join date : 2019-07-30

Back to top Go down

Persistent "Missing codec" message Empty Re: Persistent "Missing codec" message

Post by js3k on Mon Oct 14, 2019 1:39 am

Hi there, just installed the latest update (15.2.0 Mega) and I noticed the thumbnails are sill pastel gray. Is there anything I can do to fix that?

js3k

Posts : 7
Join date : 2019-07-30

Back to top Go down

Persistent "Missing codec" message Empty Re: Persistent "Missing codec" message

Post by Admin on Mon Oct 14, 2019 2:36 pm

Try cleaning the thumbnail cache with the Windows cleanmgr.exe tool.

If it still happens after that could you send me another sample file?

Admin
Admin

Posts : 5445
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Persistent "Missing codec" message Empty Re: Persistent "Missing codec" message

Post by js3k on Mon Oct 14, 2019 11:32 pm

Yes! That was the trick. Thanks bro! Very Happy

js3k

Posts : 7
Join date : 2019-07-30

Back to top Go down

Persistent "Missing codec" message Empty Re: Persistent "Missing codec" message

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum