Codec Guide
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Cannot load external subtitle

Go down

Cannot load external subtitle Empty Cannot load external subtitle

Post by minhtri on Thu Jun 06, 2019 5:48 pm

Hi,

I am using Windows 10 and just upgrade to version 14.9.8 (from version 13.7.5). Now I cannot load the external subtitle (already rename video and subtitle file as same name).

Before, I use the VSFitler and it was working fine. Now only MPC HC ISR can load external subtitle but VSFilter or XySubFilter cannot.

How can I fix it ?

Tks.

minhtri

Posts : 5
Join date : 2019-06-06

Back to top Go down

Cannot load external subtitle Empty Re: Cannot load external subtitle

Post by Admin on Fri Jun 07, 2019 1:02 pm

In case of VSFilter you may need to adjust the hardware decoder setting in the LAV video decoder. It is not compatible with DXVA2 native. You need to change that to DXVA2 copyback.
XySubFilter only works in combination with compatible video renderers.

Apart from the above, both VSFilter and XySubFilter still work fine here on Win10. Perhaps problem was only with a specific subtitle file? Try a few others.

Are you using any other non-default settings?

Admin
Admin

Posts : 5453
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Cannot load external subtitle Empty Re: Cannot load external subtitle

Post by minhtri on Fri Jun 07, 2019 3:13 pm

Hi, thank for your reply.

Edit:
I found that this issue only happen begin from K-Like Code pack version 14.8.8
I install and check, the XySubFilter & DirectVobSub is working well with external subtitle on version 14.8.4

In case of VSFilter you may need to adjust the hardware decoder setting in the LAV video decoder. It is not compatible with DXVA2 native. You need to change that to DXVA2 copyback.
-> I already change to software decoder to make sure.

XySubFilter only works in combination with compatible video renderers.
-> I am using LAV decoder. Is is compatiable with XySubFilter. Anyway, I am using and fine with VSFilter.

Apart from the above, both VSFilter and XySubFilter still work fine here on Win10. Perhaps problem was only with a specific subtitle file? Try a few others.

-> This happen with all external subtitle.

Are you using any other non-default settings?
-> I was trying default settings but no use.

This is my currently settings
Cannot load external subtitle Mpc10
Cannot load external subtitle Lavs10
Cannot load external subtitle Lavv10
Cannot load external subtitle Lava10


I notice that the VSFilter is difference that old K Like Code pack version
Cannot load external subtitle Vobsub10
Cannot load external subtitle Vobsub11

minhtri

Posts : 5
Join date : 2019-06-06

Back to top Go down

Cannot load external subtitle Empty Re: Cannot load external subtitle

Post by Admin on Fri Jun 07, 2019 6:50 pm

Very weird. The differences between 14.8.4 and 14.8.8 is small.

Do subtitles that are embedded in the file still work?

Can you test this version:
http://files2.codecguide.com/beta/K-Lite_Codec_Pack_1499_Mega.exe

Admin
Admin

Posts : 5453
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Cannot load external subtitle Empty Re: Cannot load external subtitle

Post by minhtri on Sat Jun 08, 2019 3:28 am

Admin wrote:Very weird. The differences between 14.8.4 and 14.8.8 is small.

Do subtitles that are embedded in the file still work?

Can you test this version:
http://files2.codecguide.com/beta/K-Lite_Codec_Pack_1499_Mega.exe

The embedded subtitle works fine for every filter.

I try the beta version but it does not work. Even I downgrade back to 14.8.4 and it works fine.

minhtri

Posts : 5
Join date : 2019-06-06

Back to top Go down

Cannot load external subtitle Empty Re: Cannot load external subtitle

Post by Admin on Sat Jun 08, 2019 1:28 pm

I was able to reproduce the problem. Working on a fix now.


Last edited by Admin on Sat Jun 08, 2019 5:49 pm; edited 1 time in total

Admin
Admin

Posts : 5453
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Cannot load external subtitle Empty Re: Cannot load external subtitle

Post by minhtri on Sat Jun 08, 2019 6:20 pm

Thank you very much. Hope to hear good news soon. cheers

minhtri

Posts : 5
Join date : 2019-06-06

Back to top Go down

Cannot load external subtitle Empty Re: Cannot load external subtitle

Post by Admin on Sat Jun 08, 2019 7:59 pm

14.9.9 is available

Admin
Admin

Posts : 5453
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Cannot load external subtitle Empty Re: Cannot load external subtitle

Post by minhtri on Sun Jun 09, 2019 3:58 am

Thank you very much. The issue is fixed. Very Happy Very Happy

minhtri

Posts : 5
Join date : 2019-06-06

Back to top Go down

Cannot load external subtitle Empty Re: Cannot load external subtitle

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum