Codec Guide
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Error 183 when installing

Go down

Error 183 when installing Empty Error 183 when installing

Post by Earldor on Fri Apr 19, 2019 2:25 pm

Hi!

Tried to update K-Lite Mega Codec pack from 1.4.8.8 to 1.4.9.0, and ran into problems.

I'm running Windows 7 64-bit.

Tried to update normally a couple of times (downloading the update through tools ie. downloading the new installation file and running it). This failed. Everything seemed to go nicely, but when I checked, the program version had not changed. Still 1.4.8.8.

I then uninstalled the pack through Control Panel and rebooted. Then I tried to install the pack by running the installation file, but it failed. I checked and the previous version was still in the list of installed programs. Tried to uninstall it again. Windows reports that the path is missing. Cannot uninstall.

Ran registry check. It said everything is fine. Codec Pack is still installed according to Windows (without the path references).

I then installed CCleaner and removed the pack with it.

Again, tried to install the latest codec pack. Now I get an error 183 message saying that there is already a K-Lite directory in Program Files (86x).

Tried removing and recreating the directory. No go.

Any advice? I need the codecs for a rush job fairly soon.

Thanks in advance.

Earldor

Posts : 3
Join date : 2019-04-19

Back to top Go down

Error 183 when installing Empty Re: Error 183 when installing

Post by Admin on Fri Apr 19, 2019 2:51 pm

So if I understand correctly the following happened:
1) The update install completed without error. But the version in control panel did not change.
2) Uninstall also completed without error. But entry in control panel still exists.

Then most likely the security permissions on this Registry key got broken:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\KLiteCodecPack_is1
CCleaner might have already removed it.

Does the folder in program files still exist?
If you choose "advanced" install you can use a different folder name.

Admin
Admin

Posts : 5445
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Error 183 when installing Empty Re: Error 183 when installing

Post by Admin on Fri Apr 19, 2019 3:10 pm

I am unable to reproduce the problem even with a leftover folder or registry key. So it is most likely related to the access permissions being broken.

Admin
Admin

Posts : 5445
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Error 183 when installing Empty Re: Error 183 when installing

Post by Admin on Fri Apr 19, 2019 3:28 pm

Your virus scanner or a tool like malwarebytes can in rare cases also cause this error.

Admin
Admin

Posts : 5445
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Error 183 when installing Empty Re: Error 183 when installing

Post by Admin on Fri Apr 19, 2019 3:32 pm

Did you perhaps disable some Windows services? Disabling the "Application Experience" service can cause issues.

Admin
Admin

Posts : 5445
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Error 183 when installing Empty Re: Error 183 when installing

Post by Earldor on Fri Apr 19, 2019 4:54 pm

Admin wrote:So if I understand correctly the following happened:
1) The update install completed without error. But the version in control panel did not change.
2) Uninstall also completed without error. But entry in control panel still exists.

Then most likely the security permissions on this Registry key got broken:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\KLiteCodecPack_is1
CCleaner might have already removed it.

Does the folder in program files still exist?
If you choose "advanced" install you can use a different folder name.

You did understand the problem correctly (I believe Wink

The folder did still exist, I have since removed it and recreated it (with the same name).

I also have Malwarebytes installed on my machine. Any other AV programs or applications, I should temporarily shut down?

So, I will try the remedies you suggest, when I get back home.

Thanks for the prompt reply.

Earldor

Posts : 3
Join date : 2019-04-19

Back to top Go down

Error 183 when installing Empty Re: Error 183 when installing

Post by Admin on Fri Apr 19, 2019 7:31 pm

Just temporary disable any security related tool as a test.

The installer creates a log file in the temporary files folder. Might contain some helpful information.
Copy %TEMP% in Explorer address bar to quickly open the temp folder.

Admin
Admin

Posts : 5445
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Error 183 when installing Empty Re: Error 183 when installing

Post by Earldor on Sat Apr 20, 2019 12:05 pm

Admin wrote:Just temporary disable any security related tool as a test.

The installer creates a log file in the temporary files folder. Might contain some helpful information.
Copy %TEMP% in Explorer address bar to quickly open the temp folder.

Got it to install. It seems that the culprit in this case was Comodo AV, which I'm currently testing.

Thanks for you help. Much appreciated.

Earldor

Posts : 3
Join date : 2019-04-19

Back to top Go down

Error 183 when installing Empty Re: Error 183 when installing

Post by Admin on Sat Apr 20, 2019 7:39 pm

Thanks for the info.

Admin
Admin

Posts : 5445
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Error 183 when installing Empty Re: Error 183 when installing

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum