Codec Guide
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Youtube playback problems

Go down

Youtube playback problems Empty Youtube playback problems

Post by kosmo on Wed Feb 10, 2016 1:45 pm

Hi!
I`m not sure if this is a codec-related problem but I`ve wasted many hours looking for solution and nothing seem to work. Maybe someone here can help. Please do if any of you know something about this.

I`ve got problem playing videos on pages like Youtube using Firefox or Chrome - crappy playback, dropping frames, stuttering. I`ve recently installed "youtube flash video player" and changed default player to flash in place of html5. Playback got way-better but it`s still not smooth. You might say that my PC is to weak/old but the thing is when I play the same videos on Internet Explorer there are no problems at all. Playback i smooth and uninterupted, nomatter what I do. It doesn`t even matter if I use html5 or flash player. I tried disabling Media Foundation but it changed nothing, on FF and IE as well. Turning on hardware acceleration also doesnt change much. CPU usage is less then 50% at full hd.

What more can I try short of switching browser for good?

Sorry for bad language, i haven`t use english for some time and i`m a little bit rusty Razz

Please help. Thanks.

kosmo

Posts : 8
Join date : 2016-02-10

Back to top Go down

Youtube playback problems Empty Re: Youtube playback problems

Post by Admin on Wed Feb 10, 2016 2:03 pm

The Adobe Flash plugin does not use Media Foundation or any other external codecs.

Updating your graphics driver might improve smoothness.

Admin
Admin

Posts : 5442
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Youtube playback problems Empty Re: Youtube playback problems

Post by kosmo on Wed Feb 10, 2016 2:05 pm

The thing is I already got latest g. driver. Anyway what I don`t understand is why everything ok using IE browser .+

kosmo

Posts : 8
Join date : 2016-02-10

Back to top Go down

Youtube playback problems Empty Re: Youtube playback problems

Post by Admin on Wed Feb 10, 2016 2:16 pm

Something to try:
Type about:config in the Firefox address bar. Change value of browser.sessionstore.enabled to False.

Admin
Admin

Posts : 5442
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Youtube playback problems Empty Re: Youtube playback problems

Post by Admin on Wed Feb 10, 2016 2:20 pm

Firefox options > Advanced > General > disable hardware acceleration

Admin
Admin

Posts : 5442
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Youtube playback problems Empty Re: Youtube playback problems

Post by kosmo on Wed Feb 10, 2016 2:34 pm

Admin wrote:Something to try:
Type about:config in the Firefox address bar. Change value of browser.sessionstore.enabled to False.

no such entry

hardware acceleration already disabled

kosmo

Posts : 8
Join date : 2016-02-10

Back to top Go down

Youtube playback problems Empty Re: Youtube playback problems

Post by Admin on Wed Feb 10, 2016 8:14 pm

You can create the value if it is missing.

You can also try changing browser.sessionstore.interval from 15000 to a larger value such as 60000.

Admin
Admin

Posts : 5442
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Youtube playback problems Empty Re: Youtube playback problems

Post by kosmo on Thu Feb 11, 2016 7:34 am

no effect

kosmo

Posts : 8
Join date : 2016-02-10

Back to top Go down

Youtube playback problems Empty Re: Youtube playback problems

Post by kosmo on Thu Feb 11, 2016 7:57 am

update: this is wierd because i think it worked on flash as good as on htm5 using IE before but now when i`m using flash on IE everything is exactly like on FF. still, IE + html5 = perfect playback, FF + html5 = high frame drop, FF + flash = some frame drop

kosmo

Posts : 8
Join date : 2016-02-10

Back to top Go down

Youtube playback problems Empty Re: Youtube playback problems

Post by Admin on Thu Feb 11, 2016 1:22 pm

You probably have disabled hardware acceleration in the Flash settings? That might explain why IE has worse performance compared to html5.

Admin
Admin

Posts : 5442
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Youtube playback problems Empty Re: Youtube playback problems

Post by kosmo on Thu Feb 11, 2016 1:58 pm

enabled or disabled no difference

kosmo

Posts : 8
Join date : 2016-02-10

Back to top Go down

Youtube playback problems Empty Re: Youtube playback problems

Post by Admin on Thu Feb 11, 2016 3:35 pm

dom.ipc.plugins.flash.disable-protected-mode = True

Remove folder:
%localappdata\Macromedia\Flash Player

Admin
Admin

Posts : 5442
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Youtube playback problems Empty Re: Youtube playback problems

Post by kosmo on Thu Feb 11, 2016 7:49 pm

i`m not sure, maybe it got a little bit better on html5 but it`s hard to tell. still far from smooth playback

kosmo

Posts : 8
Join date : 2016-02-10

Back to top Go down

Youtube playback problems Empty Re: Youtube playback problems

Post by Admin on Fri Feb 12, 2016 2:20 pm

The settings above are all possible solutions I could find.

Admin
Admin

Posts : 5442
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Youtube playback problems Empty Re: Youtube playback problems

Post by kosmo on Fri Feb 12, 2016 3:31 pm

ok, thank you for trying Smile

kosmo

Posts : 8
Join date : 2016-02-10

Back to top Go down

Youtube playback problems Empty Re: Youtube playback problems

Post by kockarche on Tue Jul 07, 2020 8:00 pm

When i try to play video from youtube MPC-HC shows the following message

"No videos formats found; please report this issue on https://yt-dl.org/bug. make sure you are using the latest version; type youtube-dl -U to update. Be sure to call youtube -dl with the --verbose flag and include it's complete output".

I tried to update it via powershell and Command prompt in the same directory but it show error. Maybe i was wrong. Why not just integrate youtube-dl in codecguide installation package and update it along with the other media player components.

kockarche

Posts : 5
Join date : 2019-07-07

Back to top Go down

Youtube playback problems Empty Re: Youtube playback problems

Post by Admin on Tue Jul 07, 2020 8:16 pm

There are plans to add an option in the installer the download/update it during installation.

But it may still be needed to update it manually once in a while. Youtube often makes changes on their site that requires a fix in youtube-dl.

You can download it here:
http://ytdl-org.github.io/youtube-dl/download.html

Admin
Admin

Posts : 5442
Join date : 2011-06-17

https://codecs.forumotion.net

Back to top Go down

Youtube playback problems Empty Re: Youtube playback problems

Post by ale5000 on Tue Aug 11, 2020 9:25 pm

Isn't possible to set a task on Windows that run?
Code:
youtube-dl.exe -U

ale5000

Posts : 44
Join date : 2015-02-15

Back to top Go down

Youtube playback problems Empty Re: Youtube playback problems

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum