Mkv Cover-Art Don't Display Transparencies Under Windows10

Go down

Mkv Cover-Art Don't Display Transparencies Under Windows10

Post by SorryForMyEN on Fri Feb 02, 2018 7:51 pm

This problem was only observed under Windows 10 with the K-Lite 1380 version. In others Windows versions it don't occur. I have mkv movie thumbnails edited with custom movie strips and leaked with transparencies. I use IcoFX 1.4.6 to edit them by creating pngs with transparencies and inserting them into mkv containers with MKVmerge 7.8.0. But now the film strips have a black background where they should be transparent. Any configuration I try in K-Lite and then clear the thumbnail cache returns the same problem. I researched sources about Icaros, but as far as I know this problem has not yet been reported.
Thanks for KL

SorryForMyEN

Posts : 6
Join date : 2018-02-02

View user profile

Back to top Go down

Re: Mkv Cover-Art Don't Display Transparencies Under Windows10

Post by Admin on Sat Feb 03, 2018 4:32 pm

Can you upload a sample file for me? Then I can check if it is a bug/limitation of Windows 10 or something that can be fixed in Icaros.
http://www.datafilehost.com

I assume the PNGs themselves have correct thumbnails?


Admin
Admin

Posts : 4074
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Mkv Cover-Art Don't Display Transparencies Under Windows10

Post by SorryForMyEN on Thu Feb 08, 2018 2:41 pm

It was taking a long time to upload complete movies, so I edited small music clips, which show the same unexpected behavior. See for yourself:

https://www.datafilehost.com/d/181c25d4

For me, the problem doesn't always occur, it is more often if you reload the folder. It only disappear when clearing the cache or rebooting the system, but it comes back again as soon as the thumbnails are refreshed.

SorryForMyEN

Posts : 6
Join date : 2018-02-02

View user profile

Back to top Go down

Re: Mkv Cover-Art Don't Display Transparencies Under Windows10

Post by Admin on Thu Feb 08, 2018 3:29 pm

They are rendered correctly here (on Win 7 and 10). But I will keep an eye on it, since you say it is a bit random.

Thumbnail problems for PNGs are a common issue for some Windows 10 users. Windows 10 is a bit buggy in that regard. What helps for some is the following:
1) Set the Photos app as default for PNG
2) Update the Photos app through the Windows Store

The K-Lite installer has an option to activate a secondary cache for Icaros (as a backup for the Windows cache). This will speed up re-generating thumbnails. Might be useful for you.

Admin
Admin

Posts : 4074
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Mkv Cover-Art Don't Display Transparencies Under Windows10

Post by Admin on Thu Feb 08, 2018 3:34 pm

Applications that install a shell extension for PNG thumbnails can also cause problems:
https://www.thewichitacomputerguy.com/blog/fix-windows-10-white-background-taskbar-app-store-icons

Admin
Admin

Posts : 4074
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Mkv Cover-Art Don't Display Transparencies Under Windows10

Post by SorryForMyEN on Thu Feb 08, 2018 6:02 pm

Admin wrote:
The K-Lite installer has an option to activate a secondary cache for Icaros (as a backup for the Windows cache). This will speed up re-generating thumbnails. Might be useful for you.
Well, this seems to be working so far, I will follow up and post here any relevant news.

[editing...]

Unfortunately, the secondary cache did not fix the problem, but I'll keep it, it seems to leave the thumbnail loading really faster.

SorryForMyEN

Posts : 6
Join date : 2018-02-02

View user profile

Back to top Go down

Re: Mkv Cover-Art Don't Display Transparencies Under Windows10

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum