10bit videos won't play in MPC-HC after K-lite and Intel iGPU driver update

View previous topic View next topic Go down

10bit videos won't play in MPC-HC after K-lite and Intel iGPU driver update

Post by ProTofik on Thu Jan 29, 2015 11:04 pm

Hello.
I've recently noticed that some of my videos won't start in MPC-HC. When opening them, MPC starts but then nothing happens; the screen reminds black.
I recently updated iGPU drivers and K-Lite pack to their latest versions and that's when the problem started occurring. I did it on 3 computers at the same time and all of them are affected.

2 computers have Intel HD 4600 iGPU, and 1 is HD 4400. All running 15.36.14.4080 version of Intel's driver and KLCP 1.0.9.8 with MPC x64, Lot of stuff installation, and Intel QuickSync acceleration in LAV decoder. All running Windows 8.1 x64 with all latest updates.

Also it looks like all files that won't open are encoded in 10 bits (basically anime, but also some films). The problem is affecting only MPC-HC, WMP opens them without a problem.

I guess something is incompatible here. I don't know if it's KLite's or Intel's update that broke it.

Edit:
MediaInfo of an example file that won't open: http://pastebin.com/F4nwQZjt

ProTofik

Posts : 12
Join date : 2015-01-29

View user profile

Back to top Go down

Re: 10bit videos won't play in MPC-HC after K-lite and Intel iGPU driver update

Post by Admin on Fri Jan 30, 2015 2:08 am

It is a bug in the Intel driver. You can fix the problem by disabling the P010 and P016 output formats in the settings of LAV Video decoder.

Admin
Admin

Posts : 2987
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: 10bit videos won't play in MPC-HC after K-lite and Intel iGPU driver update

Post by ProTofik on Fri Jan 30, 2015 2:18 am

Admin wrote:It is a bug in the Intel driver. You can fix the problem by disabling the P010 and P016 output formats in the settings of LAV Video decoder.
Thanks, it fixed it but can you tell me how does it affect my playback? Does it reduce quality or something?

If is causes trouble then it should be disabled by default.

ProTofik

Posts : 12
Join date : 2015-01-29

View user profile

Back to top Go down

Re: 10bit videos won't play in MPC-HC after K-lite and Intel iGPU driver update

Post by Admin on Sat Jan 31, 2015 2:42 am

It does not effect quality. The driver bug causes the video renderer to accept input that it does not actually understand. So before the bug it would never use those output formats either.

The only renderer that actually supports the 10-bit and 16-bit formats is madVR.

The pack disables these formats by default if a broken driver is detected. It already does that for recent NVIDIA drivers that have a similar bug. However, since this Intel bug is more recent than the latest version of the pack, it will be detected only by the next version of the pack, not the current one.

Admin
Admin

Posts : 2987
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: 10bit videos won't play in MPC-HC after K-lite and Intel iGPU driver update

Post by Sponsored content Today at 9:17 am


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum