cannot load subtitle.

View previous topic View next topic Go down

cannot load subtitle.

Post by lucifer93 on Thu Jan 12, 2012 9:23 pm

ok, when I click on 'Load Subtitles' I get this error message:

"To load subtitles you have to change the video renderer type and reopen the file.
-DirectShow : VMR7 or VMR9 renderless
-RealMedia: special renderer for RealMedia, or open it through DirectShow
-Quicktime: DX7 or DX9 render for QuickTime
-ShockWave: n/a"

I changed everything to what they say in View -> Options -> Playback -> Output -> (VMR9renderless and DX9 were in grey, so i did VMR7renderless and DX7). I closed the file and reopened it, but I still got the message when I tried to load the subtitles. I rechecked the options and they were properly set this time.

I reinstalled media player classic ... same thing.

Last time it used to work.. now it just wont work anymore. I have tried to google the solution. Still can't find the problem.
I hope someone could help me.

lucifer93

Posts : 4
Join date : 2012-01-12

View user profile

Back to top Go down

Re: cannot load subtitle.

Post by Admin on Fri Jan 13, 2012 4:54 am

If those renderers are greyed out in the options it means something is seriously wrong. Some important DirectX files might be missing on your system, or something is wrong with the standard DirectShow filters of Windows.

Try this:
1) Codec Tweak Tool -> Fixes -> Re-register base DirectShow filters
2) Update DirectX with this installer:
http://www.microsoft.com/download/en/details.aspx?id=35

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: cannot load subtitle.

Post by lucifer93 on Sun Jan 15, 2012 1:03 am

just applied what you suggested. Now the renderers are fine. Just having problem to load subtitles.

Any suggestion?

lucifer93

Posts : 4
Join date : 2012-01-12

View user profile

Back to top Go down

Re: cannot load subtitle.

Post by kuro on Sun Jan 15, 2012 3:39 am

you can activate MPC-HC internal subtitle filter with VMR7/VMR9 renderless or EVR.
but if you still can't load subtitles either subtitle file is bad or maybe MPC internal subtitle filter is broken
or you should try xy-vsfilter http://code.google.com/p/xy-vsfilter/
it never gives me any problem
disable "Auto-Load Subtitles" from MPC-HC > Options > Playback
if it prevents xy-vsfilter from loading in system tray for you

to install VSFILTER.dll mod just add it to MPC-HC > Options > External Filters
Set to "Prefer" & Restart MPC-HC


Last edited by kuro on Sun Jan 15, 2012 6:18 am; edited 1 time in total

kuro

Posts : 4
Join date : 2011-12-18

View user profile

Back to top Go down

Re: cannot load subtitle.

Post by Admin on Sun Jan 15, 2012 4:45 am

It might be possible that the renderers are still not working properly. In that case MPC will fall back to using the system default renderer, which is VMR-7 (windowed). That renderer is not compatible with the internal subtitle renderer.

To use VSFilter for subtitles, which is included in the pack, you need to disable the internal subtitle functionality of MPC. Disable: Options->Player->Auto-load subtitles

Subtitles are loaded automatically by VSFilter is they are properly named, meaning same filename as the video.

What kind of graphics card is in your computer? You might need to re-install the driver to fix the other renderers.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: cannot load subtitle.

Post by lucifer93 on Sun Jan 15, 2012 4:24 pm

Named the subtitle same as the file name.. it works.
However, it wont work if i use "ctrl+L" can anyone explain?


lucifer93

Posts : 4
Join date : 2012-01-12

View user profile

Back to top Go down

Re: cannot load subtitle.

Post by Admin on Mon Jan 16, 2012 6:40 am

The load subtitle function only works with the internal subtitle functionality of MPC-HC.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: cannot load subtitle.

Post by lucifer93 on Mon Jan 16, 2012 5:50 pm

ok. thats all for now.. thankz for all the help..
really helpful..

lucifer93

Posts : 4
Join date : 2012-01-12

View user profile

Back to top Go down

Re: cannot load subtitle.

Post by Majlo on Sat Mar 23, 2013 9:04 pm

I have a same problem. And typically help reinstall or actualization. But now nothing work. I do all from your´s post but with same effect. I have a last version (9.8.0_Mega).

THX for reply

Majlo

Posts : 4
Join date : 2013-03-23

View user profile

Back to top Go down

Re: cannot load subtitle.

Post by Admin on Sun Mar 24, 2013 12:41 am

You need to be more specific about what EXACTLY is not working in your case.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: cannot load subtitle.

Post by Majlo on Sun Mar 24, 2013 1:21 am

Admin wrote:You need to be more specific about what EXACTLY is not working in your case.

I said! I have a same problem

It not work. I try upload subtitles manualy with combination Ctrl+L and automaticali upload dont work, too.

I do everything from this topic thread and it not work, too.


If you need more specific, maybe you specify your specific.

Thanks beforehand
eM

Majlo

Posts : 4
Join date : 2013-03-23

View user profile

Back to top Go down

Re: cannot load subtitle.

Post by Admin on Sun Mar 24, 2013 10:36 am

Change the renderer to VMR-7 (windowed). Then DirectVobSub should get used for subtitles.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: cannot load subtitle.

Post by Majlo on Sun Mar 24, 2013 8:22 pm

Admin wrote:Change the renderer to VMR-7 (windowed). Then DirectVobSub should get used for subtitles.

I said that I reinstall KLM with a settings by error window. But in last post, didnt add this screenshots. Sorry, that is my mistake, that I had to check it out. And sorry for language, but some people in my environment need windows in their native language.

http://ulozto.cz/xAUBnrD/screen2-jpg


http://ulozto.cz/xHwEZpM/bez-nazvu-1-jpg

Majlo

Posts : 4
Join date : 2013-03-23

View user profile

Back to top Go down

Re: cannot load subtitle.

Post by Admin on Wed Mar 27, 2013 7:47 am

The internal subtitle functionality does not work with that renderer. So you cant use ´load subtitle´ or the subtitle downloader. However, subtitles will load fully automatically with DirectVobSub if you name the subtitles correctly:

movie name.avi
movie name.srt

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: cannot load subtitle.

Post by Majlo on Wed Mar 27, 2013 8:11 am

Admin wrote:The internal subtitle functionality does not work with that renderer. So you cant use ´load subtitle´ or the subtitle downloader. However, subtitles will load fully automatically with DirectVobSub if you name the subtitles correctly:

movie name.avi
movie name.srt

Yeah thats work (method same name), but I finding answer for functional ´load subtitle´. What I need setup to work this.

Majlo

Posts : 4
Join date : 2013-03-23

View user profile

Back to top Go down

Re: cannot load subtitle.

Post by Admin on Thu Mar 28, 2013 4:21 am

You can see in the settings which renderers are compatible. For example vmr9 (renderless)

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: cannot load subtitle.

Post by Sponsored content Today at 9:27 am


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum