Conflict between XYplorer, nVidia Driver & HEVC or VP9

Go down

Conflict between XYplorer, nVidia Driver & HEVC or VP9 Empty Conflict between XYplorer, nVidia Driver & HEVC or VP9

Post by amrbab on Sat Nov 23, 2019 2:46 pm

Hi, my O.S is windows 10 & VGA card is nVIDIA 1030. I installed latest driver. but there is a problem in media preview with XYplorer. When i preview every video with vp9 format for once next i am unable to watch any videos but only audio is present. The problem is determined as VP9 format. I tried different versions of K-codec pack & there is no problem with versions 10.1 to 10.6.5. I found 3 solutions. First one is using microsoft basic vga adaptor, second one is versions 10.1 to 10.6.5 of k-codec & the third one is using windows 7 or 8.1 with the latest nvidia driver. Please investigate.

amrbab

Posts : 5
Join date : 2019-11-23

Back to top Go down

Conflict between XYplorer, nVidia Driver & HEVC or VP9 Empty Re: Conflict between XYplorer, nVidia Driver & HEVC or VP9

Post by Admin on Sat Nov 23, 2019 4:29 pm

Try the latest version of K-Lite (15.2.6) and disable VP9 hardware acceleration in LAV Video decoder settings.

Admin
Admin

Posts : 4851
Join date : 2011-06-17

http://codecs.forumotion.net

Back to top Go down

Conflict between XYplorer, nVidia Driver & HEVC or VP9 Empty Re: Conflict between XYplorer, nVidia Driver & HEVC or VP9

Post by amrbab on Sun Nov 24, 2019 3:30 am

I tried that, no problem in win 8.1 but bug still remains in win 10 Conflict between XYplorer, nVidia Driver & HEVC or VP9 File

amrbab

Posts : 5
Join date : 2019-11-23

Back to top Go down

Conflict between XYplorer, nVidia Driver & HEVC or VP9 Empty Re: Conflict between XYplorer, nVidia Driver & HEVC or VP9

Post by amrbab on Sun Nov 24, 2019 5:39 am

* I found that windows screen saver can trigger this bug while watching videos too.
* Using software decoding is not effective.
Conclusion until this moment:
1. Version
10.0.5 to 10.1.0 ~ 2013-10-25
Updated LAV Filters to version 0.58.2-90-g602b085
Updated xy-VSFilter to version 3.0.0.236
Updated Codec Tweak Tool to version 5.7.3
Updated Icaros to version 2.2.4 b1
Added support for decoding HEVC (aka H.265) and VP9 video

is fine with latest nVidia driver on win 10!

2. Using microsoft basic VGA adaptor instead of nvidia driver solves the problem in win 10 regardless of codec version.

3. There is no problem with nVidia latest driver & latest K-Mega codec in windows 7 & 8.1.

amrbab

Posts : 5
Join date : 2019-11-23

Back to top Go down

Conflict between XYplorer, nVidia Driver & HEVC or VP9 Empty Re: Conflict between XYplorer, nVidia Driver & HEVC or VP9

Post by Admin on Sun Nov 24, 2019 6:01 pm

Hardware acceleration for HEVC video was added shortly after 10.6.5. So try with hardware acceleration disabled completely.

Found topic with similar problem:
https://www.xyplorer.com/xyfc/viewtopic.php?t=19230

There the video works when opening a second instance of XYplorer. Can you test if that is the case for you as well? I have seen people with the same problem in other applications (such as Irfanview) on Windows 10. In that case it was also related to the NVIDIA driver.

Admin
Admin

Posts : 4851
Join date : 2011-06-17

http://codecs.forumotion.net

Back to top Go down

Conflict between XYplorer, nVidia Driver & HEVC or VP9 Empty Re: Conflict between XYplorer, nVidia Driver & HEVC or VP9

Post by amrbab on Sun Nov 24, 2019 6:28 pm

I disabled hardware acceleration completely but the problem still remains.
"it was also related to the NVIDIA driver", yes there is no problem with Microsoft Basic Display Adapter.
" the video works when opening a second instance of XYplorer", exactly as mine!
I tried different codec in addition to k-lite codec but all have the same issue.
Screen saver triggers the bug while watching videos in different formats!

amrbab

Posts : 5
Join date : 2019-11-23

Back to top Go down

Conflict between XYplorer, nVidia Driver & HEVC or VP9 Empty Re: Conflict between XYplorer, nVidia Driver & HEVC or VP9

Post by Admin on Sun Nov 24, 2019 9:34 pm

It works with 10.6.5. So is version 10.7.1 the first version that has the problem? If we can pinpoint what change triggers the driver bug, then maybe a workaround is possible.

Another interesting thing to test would be to change the system default video renderer. By default Windows uses the ancient VMR-7 renderer.

You can change it to the newer VMR-9 renderer with the GraphStudioNext tool from the codec pack.
GraphStudioNext menu > Graph > Insert Filter > Video Mixing Render 9 > Change merit > set to MERIT_PREFERRED+1

Admin
Admin

Posts : 4851
Join date : 2011-06-17

http://codecs.forumotion.net

Back to top Go down

Conflict between XYplorer, nVidia Driver & HEVC or VP9 Empty Re: Conflict between XYplorer, nVidia Driver & HEVC or VP9

Post by amrbab on Mon Nov 25, 2019 6:55 pm

1. Version 10.6.5 works, vp9 can not trigger the bug, but screen saver or I think losing focus (ALT+TAB) still triggers the bug.
2. Version 10.7.1 couldn`t be installed because of
Conflict between XYplorer, nVidia Driver & HEVC or VP9 70ho_untitled
3. VMR-9 renderer made no difference.
4. It is worth to know that when the bug is triggered, nothing except windows restore point can`t solve the problem! even uninstalling XYplorer & codec pack.
5. "the video works when opening a second instance of XYplorer", one of the instance must play a video then every thing is fine with second one.

amrbab

Posts : 5
Join date : 2019-11-23

Back to top Go down

Conflict between XYplorer, nVidia Driver & HEVC or VP9 Empty Re: Conflict between XYplorer, nVidia Driver & HEVC or VP9

Post by Admin on Mon Nov 25, 2019 8:54 pm

You should consider doing a completely fresh install of Windows 10. That often solves weird driver and stability issues.

Or maybe first try removing the NVIDIA driver with Display Driver Uninstaller (DDU) and then do a fresh install of the driver.

I know the codecs are working properly and this is a rendering issue, which means it is the fault of the driver and/or Windows.

Admin
Admin

Posts : 4851
Join date : 2011-06-17

http://codecs.forumotion.net

Back to top Go down

Conflict between XYplorer, nVidia Driver & HEVC or VP9 Empty Re: Conflict between XYplorer, nVidia Driver & HEVC or VP9

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum