K-Lite Codec Pack installer doesn't launch!

Go down

K-Lite Codec Pack installer doesn't launch! Empty K-Lite Codec Pack installer doesn't launch!

Post by Iceberg233 on Sat Jun 29, 2019 11:44 am

Hello guys,

I'm really confused about this one. I got the latest version of K-Lite Codec Pack (Mega) from the official website, but when I run the installer I can see a little tab appearing on my taskbar, then disappearing after about 3 seconds, and then nothing happens... I tried an older version, different type of codec (standard), running as admin, compatibility mode (Windows 7,Cool, restarting my laptop, nothing helps! The problem stays exactly the same. I've been already running an older version of K-Lite Codec Pack, prior to this install attempt and everything worked fine. I just wanted to do a fresh install of the updated version + upgrade from Standard => Mega. Before attempting to install the new version I uninstalled the old one through Windows 10's "Add or remove programs" thing. I even went to the Setup Log, but it doesn't show any errors there. The last line states: "InitializeSetup complete".

Really counting on your help here guys!

Iceberg233

Posts : 7
Join date : 2019-06-29

Back to top Go down

K-Lite Codec Pack installer doesn't launch! Empty Re: K-Lite Codec Pack installer doesn't launch!

Post by Admin on Sat Jun 29, 2019 12:16 pm

If that is the last line in the log, then most likely something else is terminating the process. Perhaps your virusscanner?

Admin
Admin

Posts : 4835
Join date : 2011-06-17

http://codecs.forumotion.net

Back to top Go down

K-Lite Codec Pack installer doesn't launch! Empty Re: K-Lite Codec Pack installer doesn't launch!

Post by Iceberg233 on Sat Jun 29, 2019 6:59 pm

Thanks for your reply, however I've already tried adding the installer to exceptions. I'm using AVG, and I just tried disabling it, but no luck... Sad Is there anything else I can try, or perhaps do something with Windows Defender? It does look like something is preventing the install launcher to go through.

Iceberg233

Posts : 7
Join date : 2019-06-29

Back to top Go down

K-Lite Codec Pack installer doesn't launch! Empty Re: K-Lite Codec Pack installer doesn't launch!

Post by Iceberg233 on Sat Jun 29, 2019 7:24 pm

I investigated further and noticed that right before the installation process would terminate in Task Manager, the "Windows Problem Reporting" process would also appear for a second. So I found that log and here's what is says:

Source
Setup/Uninstall

Summary
Stopped working

Date
‎6/‎29/‎2019 11:11 AM

Status
Report sent

Description
Faulting Application Path: C:\Users\ICE-NO~1\AppData\Local\Temp\is-NF250.tmp\K-Lite_Codec_Pack_1500_Mega.tmp

Problem signature
Problem Event Name: APPCRASH
Application Name: K-Lite_Codec_Pack_1500_Mega.tmp
Application Version: 51.1052.0.0
Application Timestamp: 5cc45ac2
Fault Module Name: d3d9.dll
Fault Module Version: 10.0.17763.1
Fault Module Timestamp: 9ec0ce62
Exception Code: c000008e
Exception Offset: 0004c067
OS Version: 10.0.17763.2.0.0.768.101
Locale ID: 1033
Additional Information 1: 289d
Additional Information 2: 289d2d01246ad3393c4ae7cdf9b09d8b
Additional Information 3: 222b
Additional Information 4: 222b397dda6446946cd95d5e4b306be1

Extra information about the problem
Bucket ID: eb6b67724d07a49e675dddfb89f9576a (1683745908127782762)

Iceberg233

Posts : 7
Join date : 2019-06-29

Back to top Go down

K-Lite Codec Pack installer doesn't launch! Empty Re: K-Lite Codec Pack installer doesn't launch!

Post by Admin on Sat Jun 29, 2019 10:53 pm

The crash happens in d3d9.dll. I am not sure what precisely is going wrong.

Try this version, which has a little bit more logging:
http://files2.codecguide.com/beta/K-Lite_Codec_Pack_1502_Mega.exe

Copy the whole log here. Maybe I see something unusual.

Admin
Admin

Posts : 4835
Join date : 2011-06-17

http://codecs.forumotion.net

Back to top Go down

K-Lite Codec Pack installer doesn't launch! Empty Re: K-Lite Codec Pack installer doesn't launch!

Post by Iceberg233 on Sat Jun 29, 2019 11:58 pm

This is what I got:

Source
Setup/Uninstall

Summary
Stopped working

Date
‎6/‎29/‎2019 3:52 PM

Status
Report sent

Description
Faulting Application Path: C:\Users\ICE-NO~1\AppData\Local\Temp\is-IAL99.tmp\K-Lite_Codec_Pack_1502_Mega.tmp

Problem signature
Problem Event Name: APPCRASH
Application Name: K-Lite_Codec_Pack_1502_Mega.tmp
Application Version: 51.1052.0.0
Application Timestamp: 5cc45ac2
Fault Module Name: d3d9.dll
Fault Module Version: 10.0.17763.1
Fault Module Timestamp: 9ec0ce62
Exception Code: c000041d
Exception Offset: 0004c067
OS Version: 10.0.17763.2.0.0.768.101
Locale ID: 1033
Additional Information 1: 870c
Additional Information 2: 870c64c9ff374077768cb1a64e2e22c6
Additional Information 3: 4d10
Additional Information 4: 4d1045ce96344a8c248214efa5a0fb15

Extra information about the problem
Bucket ID: f4a5502633f06392c203672ad8a806f0 (1297994551334012656)



2019-06-29 15:52:10.053 Log opened. (Time zone: UTC-07:00)
2019-06-29 15:52:10.053 Setup version: Inno Setup version 6.0.2 (u)
2019-06-29 15:52:10.053 Original Setup EXE: C:\Users\Ice-Notebook\Desktop\K-Lite_Codec_Pack_1502_Mega.exe
2019-06-29 15:52:10.053 Setup command line: /SL5="$170828,58957161,402944,C:\Users\Ice-Notebook\Desktop\K-Lite_Codec_Pack_1502_Mega.exe" /SPAWNWND=$E0518 /NOTIFYWND=$16094E
2019-06-29 15:52:10.053 Windows version: 10.0.17763 (NT platform: Yes)
2019-06-29 15:52:10.053 64-bit Windows: Yes
2019-06-29 15:52:10.053 Processor architecture: x64
2019-06-29 15:52:10.054 User privileges: Administrative
2019-06-29 15:52:10.062 Administrative install mode: Yes
2019-06-29 15:52:10.062 Install mode root key: HKEY_LOCAL_MACHINE
2019-06-29 15:52:10.062 64-bit install mode: No
2019-06-29 15:52:10.065 Created temporary directory: C:\Users\ICE-NO~1\AppData\Local\Temp\is-K4TFK.tmp
2019-06-29 15:52:10.081 Extracting temporary file: C:\Users\ICE-NO~1\AppData\Local\Temp\is-K4TFK.tmp\klcp_detect.dll
2019-06-29 15:52:10.086 Extracting temporary file: C:\Users\ICE-NO~1\AppData\Local\Temp\is-K4TFK.tmp\klcp_detect2.dll
2019-06-29 15:52:10.098 Detecting if an old version of the K-Lite Codec Pack is currently installed.
2019-06-29 15:52:10.098 Detecting if other codec packs are installed.
2019-06-29 15:52:10.103 Validating if important DirectShow components are working correctly.
2019-06-29 15:52:10.109 Detecting existing codecs and filters.
2019-06-29 15:52:10.134 CPU capabilities: MMX=1,SSE=1,SSE2=1,SSE3=1,SSSE3=1,SSE41=1,SSE42=1,AVX=1,AVX2=1
2019-06-29 15:52:10.134 Checking hardware and driver details.
2019-06-29 15:52:10.152 Video card 1: Intel(R) UHD Graphics 630
VendorID: 8086, DeviceID: 3e9b, SubSys: 086f1028
Video mem: 1024 MB
Video driver: igdumdim64.dll (Version 24.20.100.6287) (8-15-2018)
Video card 2: NVIDIA GeForce GTX 1050 Ti
VendorID: 10de, DeviceID: 1c8c, SubSys: 086f1028
Video mem: 4096 MB
Video driver: nvldumdx.dll (Version 24.21.13.9836) (6-24-2018) (NV 398.36)
2019-06-29 15:52:10.153 Audio device: Intel(R) Display Audio
VendorID: 8086, DeviceID: 280b, SubSys: 80860101
Audio driver: IntcDAud.sys (Version 10.25.0.10) (7-18-2018)
2019-06-29 15:52:10.154 Screen size: 1920x1080 (32bits) (60Hz) (114%)
2019-06-29 15:52:10.154 Detecting hardware acceleration capabilities
2019-06-29 15:52:10.154 Detecting GPU PixelShader capabilities
2019-06-29 15:52:11.451 GPU PixelShader version: 5.0
2019-06-29 15:52:11.536 Found nvcuvid.dll version 7.17.13.9836
2019-06-29 15:52:11.536 Checking for known buggy drivers
2019-06-29 15:52:11.537 Initializing default settings
2019-06-29 15:52:11.537 Detecting Windows speaker configuration
2019-06-29 15:52:11.537 Speaker config = 4 (read from Registry)
2019-06-29 15:52:11.537 Locale: 1, UILang: 1033, Location: 244
2019-06-29 15:52:11.538 Detecting known players.
2019-06-29 15:52:11.550 C:\Program Files (x86)\Windows Media Player\wmplayer.exe
2019-06-29 15:52:11.550 C:\Program Files\Windows Media Player\wmplayer.exe
2019-06-29 15:52:11.550 AppX6eg8h5sxqq90pv53845wmnbewywdqq5h
2019-06-29 15:52:11.550 c:\software\light alloy\la.exe
2019-06-29 15:52:11.550 c:\users\ice-notebook\appdata\roaming\acestream\player\ace_player.exe
2019-06-29 15:52:11.550 AppXqj98qxeaynz6dv4459ayz6bnqxbyaqcs
2019-06-29 15:52:12.115 Default browser: Chrome
2019-06-29 15:52:12.115 InitializeSetup complete

Iceberg233

Posts : 7
Join date : 2019-06-29

Back to top Go down

K-Lite Codec Pack installer doesn't launch! Empty Re: K-Lite Codec Pack installer doesn't launch!

Post by Admin on Sun Jun 30, 2019 2:01 pm

Updated installer:
http://files2.codecguide.com/beta/K-Lite_Codec_Pack_1502_Mega.exe

First try it normally. If it still crashes try with commandline parameter /skipd3d

Admin
Admin

Posts : 4835
Join date : 2011-06-17

http://codecs.forumotion.net

Back to top Go down

K-Lite Codec Pack installer doesn't launch! Empty Re: K-Lite Codec Pack installer doesn't launch!

Post by Iceberg233 on Sun Jun 30, 2019 8:44 pm

Admin wrote:Updated installer:
http://files2.codecguide.com/beta/K-Lite_Codec_Pack_1502_Mega.exe

First try it normally. If it still crashes try with commandline parameter /skipd3d

Thank you so much! It still crashed, but adding the commandline parameter fixed it! Very Happy

Iceberg233

Posts : 7
Join date : 2019-06-29

Back to top Go down

K-Lite Codec Pack installer doesn't launch! Empty Re: K-Lite Codec Pack installer doesn't launch!

Post by Admin on Sun Jun 30, 2019 8:52 pm

Good. At least some progress.

One thing I noticed in your log in this: "Screen size: 1920x1080 (32bits) (60Hz) (114%)"
Is it correct that you have DPI scaling (Text size option in Window) set to 114%? If so, could you test if setting it to 100% makes any difference?

Admin
Admin

Posts : 4835
Join date : 2011-06-17

http://codecs.forumotion.net

Back to top Go down

K-Lite Codec Pack installer doesn't launch! Empty Re: K-Lite Codec Pack installer doesn't launch!

Post by Iceberg233 on Tue Jul 02, 2019 5:42 am

Admin wrote:Good. At least some progress.

One thing I noticed in your log in this: "Screen size: 1920x1080 (32bits) (60Hz) (114%)"
Is it correct that you have DPI scaling (Text size option in Window) set to 114%? If so, could you test if setting it to 100% makes any difference?

I tried resetting the scaling back to 100%, but the installers keep crashing (without comm ln args).

Iceberg233

Posts : 7
Join date : 2019-06-29

Back to top Go down

K-Lite Codec Pack installer doesn't launch! Empty Re: K-Lite Codec Pack installer doesn't launch!

Post by Admin on Tue Jul 02, 2019 3:17 pm

Another update:
http://files2.codecguide.com/beta/K-Lite_Codec_Pack_1503_Mega.exe

Crash might be avoided now. If not, it should detect a previous crash and apply workaround automatically.

The crash itself is due to a bug in Windows 10. But it seems a rare occurrence only on specific systems.

Admin
Admin

Posts : 4835
Join date : 2011-06-17

http://codecs.forumotion.net

Back to top Go down

K-Lite Codec Pack installer doesn't launch! Empty Re: K-Lite Codec Pack installer doesn't launch!

Post by Iceberg233 on Sat Jul 06, 2019 12:03 am

Admin wrote:Another update:
http://files2.codecguide.com/beta/K-Lite_Codec_Pack_1503_Mega.exe

Crash might be avoided now. If not, it should detect a previous crash and apply workaround automatically.

The crash itself is due to a bug in Windows 10. But it seems a rare occurrence only on specific systems.

This version launched great! Didn't have to use command line args. Thumbsup. Smile

Iceberg233

Posts : 7
Join date : 2019-06-29

Back to top Go down

K-Lite Codec Pack installer doesn't launch! Empty Re: K-Lite Codec Pack installer doesn't launch!

Post by Admin on Sat Jul 06, 2019 3:49 pm

Great.

Admin
Admin

Posts : 4835
Join date : 2011-06-17

http://codecs.forumotion.net

Back to top Go down

K-Lite Codec Pack installer doesn't launch! Empty Re: K-Lite Codec Pack installer doesn't launch!

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum