Issue opening gif files with K-Lite Basic installed on Windows 10 1803

Go down

Issue opening gif files with K-Lite Basic installed on Windows 10 1803

Post by murmanox on Tue Oct 09, 2018 8:07 pm

I seem to be having an issue with MPC-HC after installing K-Lite Basic. Whenever I load a .gif file the gif is animated, but it's being shown as black and white, with white vertical lines through it, and will cut off part of the image.

I've attached an example of this below:


If I go into "Options>Internal Filters" and disable "GIF" under under "Source Filters", then the image will regain its colour and resolution, but will play at ~half speed and look choppy. Have any of you encountered this issue before?

Here is the codectweaker log, and I'm on version 17134.112 of Windows 10:
Code:
Codec Tweak Tool | Log file | Generated at 2018-10-09 19:56:55

#####  System Information  #####

OS:           Windows 10 Home (10.00.17134) (x64)
CPU name:     Intel(R) Core(TM) i5-8600K CPU @ 3.60GHz
CPU speed:    3600 MHz (6t)
Memory:       16352 MB
Screen size:  1920x1080 (32bits) (144Hz), 1920x1080 (32bits) (60Hz)
Video card:   NVIDIA GeForce GTX 1080
              VendorID: 10de, DeviceID: 1b80
Video mem:    8192 MB
Video driver: nvldumdx.dll (Version 25.21.14.1616) (10-2-2018) (NV 416.16)
Audio device: NVIDIA Virtual Audio Device (Wave Extensible) (WDM)
              VendorID: 0955, DeviceID: 9000
Audio driver: nvvad64v.sys (Version 4.8.3.0) (6-5-2018)

#####  K-Lite Codec Pack  #####

KLCP version: 14.5.2
KLCP type:    basic

Speaker conf: 2.0

#####  Decoder Settings #####

LAV Video:
H264=DXVA2CB HEVC=DXVA2CB VP9=DXVA2CB VC1=1 MPEG2=1 MPEG4=1 WMV3=0

LAV Audio:
MP3=1 AC3=1 DTS=1 DTSHD=1 EAC3=1 TRUEHD=1 AAC=1 Vorbis=1 LPCM=1 WMA=0

#####  DirectShow Filters (32-bit)  #####

(A total of 62 filters, 0 shown, 62 hidden)

#####  DirectShow Filters (64-bit)  #####

(A total of 68 filters, 0 shown, 68 hidden)

#####  ICM Class Manager (32-bit)  #####

(A total of 2 filters, 0 shown, 2 hidden)

#####  ICM Class Manager (64-bit)  #####

(A total of 2 filters, 0 shown, 2 hidden)

#####  Default source filters (32-bit)  #####

(A total of 15 default source filters, 0 shown, 15 hidden)

#####  Default source filters (64-bit)  #####

(A total of 56 default source filters, 0 shown, 56 hidden)

#####  ACM and VFW Codecs (32-bit)  #####

Description:  Fraps Video Decompressor
ID:           VIDC.FPS1
File name:    C:\WINDOWS\SysWOW64\frapsvid.dll

(A total of 15 codecs, 1 shown, 14 hidden)

#####  ACM and VFW Codecs (64-bit)  #####

Description:  Fraps Video Decompressor
ID:           VIDC.FPS1
File name:    C:\WINDOWS\system32\frapsv64.dll

(A total of 14 codecs, 1 shown, 13 hidden)

Thanks,
Murmanox

murmanox

Posts : 3
Join date : 2018-10-09

View user profile

Back to top Go down

Re: Issue opening gif files with K-Lite Basic installed on Windows 10 1803

Post by Admin on Wed Oct 10, 2018 1:59 pm

Can you give me a sample .gif that has this problem? I tried a few here, but they play ok with LAV Splitter/Decoder.

Admin
Admin

Posts : 4194
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Issue opening gif files with K-Lite Basic installed on Windows 10 1803

Post by murmanox on Wed Oct 10, 2018 6:17 pm

I can't figure out how to upload a file, so I'll just link the webpage that I downloaded the example from.

https://giphy.com/gifs/afv-funny-fail-kid-xTiTncVep2khPGhK1i

This happens with every gif file I try to open within MPC, though. If I open it from the "Photos" built in Microsoft app it works fine, but lacks the functionality of MPC-HC.

Thanks for your time,
Murmanox

murmanox

Posts : 3
Join date : 2018-10-09

View user profile

Back to top Go down

Re: Issue opening gif files with K-Lite Basic installed on Windows 10 1803

Post by Admin on Thu Oct 11, 2018 2:31 pm

I have tried on both Windows 7 and Windows 10 1809 and no problem here.

I have this in Menu > Play > Filters:
- Enhanced Video Renderer (custom presenter)
- LAV Video Decoder
- LAV Splitter Source (internal)

Admin
Admin

Posts : 4194
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Issue opening gif files with K-Lite Basic installed on Windows 10 1803

Post by murmanox on Thu Oct 11, 2018 6:41 pm

I can't update to 1809 right now due to it being delayed for deleting users' files, but my filters seem to be the set up how you described.



If I uninstall K-Lite Basic then gifs start working within MPC-HC again (I need K-Lite for some other software), but when I reinstall it MPC-HC goes back to displaying them the same as in the image above. Could it be an issue with some of the settings I have under LAV Video Decoder or LAV Splitter Source?

Thanks,
Murmanox

EDIT:
Just installed it on a second Windows 1803 PC with the same results. First time ever installing K-Lite and MPC-HC on that PC. I'll wait until 1809 is available and give it another try then. Thanks for your help.

murmanox

Posts : 3
Join date : 2018-10-09

View user profile

Back to top Go down

Re: Issue opening gif files with K-Lite Basic installed on Windows 10 1803

Post by Admin on Fri Oct 12, 2018 1:23 pm

Might be due to an old version of MPC-HC.

If you use K-Lite Standard instead of Basic, then it also includes the very latest version of MPC-HC.

Admin
Admin

Posts : 4194
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Issue opening gif files with K-Lite Basic installed on Windows 10 1803

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum