5.1 sound randomly breaks after pausing/unpausing MPC-HC

Go down

5.1 sound randomly breaks after pausing/unpausing MPC-HC

Post by AtomicStryker on Tue Sep 11, 2018 6:14 pm

CMD says my version of Windows is 10.0.17134.228 (x64)
The string in the bottom right of my desktop says "Build 17134.rs4_release.180410-1804"

I am 90% certain this is a Windows induced problem, as the first time i experienced the problem was after the last update...

- It also made Windows audio device "refresh" (when plugging in different HDMI consumers) unresponsive, i have to open up the sound devices list to get the dumb thing to update at all -

My sound device is my Geforce 1080 Ti - i use the "onboard" sound to output 5.1 PCM over HDMI to an AVR which in turn powers my speakers.
Using the newest Nvidia driver. Windows output is configured to 5.1, 192k PCM.
Using K-Lite Codec Pack 14.4.2, video through MadVR and audio to LAV, output configuration 5.1, didn't change audio settings otherwise.


The problem: When playing (mostly .mkv) files which have 6 channels, my 5.1 sound output randomly breaks as i pause and unpause the playback.
Mercifully, this does not appear to happen in games which have surround sound, or when i play stereo music.


Define break: The "foreground" sounds such as usually speech are suddenly EXTREMELY quiet and the "surround" parts are slightly louder, aka i can only hear the surround parts.
I think they are also suddenly coming from the front speakers.

Once "broken", the only thing i can do to fix it is turn my AVR (HDMI receiver) off and on again. Restarting the video does not help.
Changing windows settings does not help. Triggering the rear speakers or subwoofer manually through the sound configuration screen yields only silence.

I have never had this issue despite of using this sound setup for years now, i've also swapped the AVR to rule it out, it happens with different AVR, so the problem is software side.
Really the only thing that changed was Windows and driver updates, also Codec pack.

AtomicStryker

Posts : 2
Join date : 2018-09-11

View user profile

Back to top Go down

Re: 5.1 sound randomly breaks after pausing/unpausing MPC-HC

Post by Admin on Tue Sep 11, 2018 8:24 pm

The release notes of the latest NVIDIA driver lists this under known issues: "AV receiver switches to
2-channel stereo mode after 5 seconds of audio idle. "

That appear to be the problem that you are having.

Admin
Admin

Posts : 4154
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: 5.1 sound randomly breaks after pausing/unpausing MPC-HC

Post by AtomicStryker on Tue Sep 11, 2018 9:42 pm

SON OF A
Thank you.

EDIT: Says GTX 1060, but it's fairly close to my issue so i'm going to blame Nvidia for it either way

AtomicStryker

Posts : 2
Join date : 2018-09-11

View user profile

Back to top Go down

Re: 5.1 sound randomly breaks after pausing/unpausing MPC-HC

Post by Admin on Wed Sep 12, 2018 12:35 pm

When their release notes mention a specific GPU, it usually just means that the initial bug report was by a user with that GPU. Most of the time the bug applies to other GPUs as well.

Admin
Admin

Posts : 4154
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: 5.1 sound randomly breaks after pausing/unpausing MPC-HC

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum