Lost Sound for ALL playback after 14.2.5 update

Go down

Lost Sound for ALL playback after 14.2.5 update

Post by Ronson on Mon Jun 25, 2018 12:39 am

Ronson Here. I am posting this info re a recent update that I allowed to install namely update 14.2.5. Later on I came back to computer and found that I had no sound whatsoever. After restarting, checking all sound files, drivers, playback, media players I could not find what the issue was. This was going on for a few days. No sound at all except a tiny tick sound that went nowhere, but told me that my speakers were ok and that they DID want to play but something was in conflict. Thus I assumed a conflict was occurring somewhere. Today I started working backwards to find out when the issue started. The issue I was experiencing only occurred after the 14.2.5 update.

I decided to open up the k_lite tweak tool and check for updates thinking that there would be 'no way' another update would be availabel......but YES v14.2.6 . I could only hope something in the update might rectify the issue caused by update 14.2.5.

I allowed update 14.2.6 and monitored it, to then, to my delight, audio playback has now been restored to almost ALL sound files except certain music mp4 video files. ALL my media players are now playing back my sound. I am extremely happy. I have no idea what I would have done if there had been no further update - I would be at a loss I think.

I have no idea what was in 14.2.6 that fixed the issues that 14.2.5 had caused, but hopefully the team can take note of their changelog and other fixes surrounding these two update incase of future sound blackouts after an update. Cheers for now, and thank you for all you do. Ronson

Ronson

Posts : 1
Join date : 2018-06-25

View user profile

Back to top Go down

Re: Lost Sound for ALL playback after 14.2.5 update

Post by Admin on Mon Jun 25, 2018 12:56 pm

It is very unlikely that your problem was related to the codec pack. It is just a coincidence that it happened around the same time as the update. Except maybe if you enabled audio bitstreaming on a system that doesn't support that. But that would only affect certain players.

Which players are you using?


Admin
Admin

Posts : 4194
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Lost Sound for ALL playback after 14.2.5 update

Post by MayDai on Sat Jun 30, 2018 9:00 pm

its not a coincidence because i had the same issue, after this update my sound for most videos stopped working, i tried reinstalling without success, this new update screws up all settings made in previous setup of K-Lite.
I had to restore my settings from previous K-lite installation and that mostly worked but now its not giving me sound for the most normal video files and ive had to uninstall the codec pack due to it being very buggy now.
I reinstalled the application with a windows restart in between and it restored only partial sound, now all audio skips constantly and cuts in and out, something with the new K-Lite settings have messed up the old setup BIG TIME.

MayDai

Posts : 6
Join date : 2018-06-30

View user profile

Back to top Go down

Re: Lost Sound for ALL playback after 14.2.5 update

Post by Admin on Sat Jun 30, 2018 11:09 pm

There have not been any changes to settings. Only updated codecs. There have been some bitstreaming related changes in LAV Audio Decoder. Are you using bitstreaming to a receiver?

Please copy this info here:
Codec Tweak Tool > Generate Log

Do you make any noteworthy audio related changes in the settings, compared to the default settings?

What kind of files are you currently having trouble with? MediaInfo can show details about the files.

Admin
Admin

Posts : 4194
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Lost Sound for ALL playback after 14.2.5 update

Post by Admin on Sat Jun 30, 2018 11:37 pm


Admin
Admin

Posts : 4194
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Lost Sound for ALL playback after 14.2.5 update

Post by MayDai on Mon Jul 02, 2018 7:38 am

I again uninstalled the copy i had installed, then installed a new copy with restoring my settings and with a few options tweaked my sound has returned.
I dont know what happened when the new version updated, i also dont know why it had sound cutting in and out when i reinstalled the first time and now that its working i cannot recreate the error which would had helped determine why it was happening.
if this happens again i will for sure generate a log file and post here, thank you very much for replying with help.

MayDai

Posts : 6
Join date : 2018-06-30

View user profile

Back to top Go down

Re: Lost Sound for ALL playback after 14.2.5 update

Post by Admin on Mon Jul 02, 2018 1:04 pm

Good. Since the changes between versions are very minimal, I still suspect some external factor is involved. Certainly in the case where audio is lost for all files.

If it ever happens again, then have a look at:
MPC-HC menu > Play > Filters
This list should normally include LAV Splitter. It you hover your mouse on it, the submenu will show the tracks in the file. Verify that it sees the audio, and the audio format is correct.
The list should also include LAV Audio Decoder. Click on that and then go to its Status tab. That shows what format it is decoding. It also shows the volume for each channel of the decoded audio. If that looks ok, then decoding is working.

If that is all working as normal, then the problem lies almost always in the audio renderer or driver. A complete loss of sound can happen for example when an incorrect audio device is selected as default in the Windows Control Panel. This can (rarely) happen after a driver update or big Windows update.

You can override the device in MPC-HC settings:
MPC-HC options > Playback > Output > Audio Renderer
By default it uses the default DirectSound device. When selecting a specific device, pick the "DirectSound" one (when it is listed twice).

Admin
Admin

Posts : 4194
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Lost Sound for ALL playback after 14.2.5 update

Post by MayDai on Thu Jul 05, 2018 8:30 pm

im having low sound quality and it cuts in and out here and there, im pasting my log file to show what is happening.
now it cut out completely and i have no sound at all.
what is happening in this new codec pack? something bad is happening.
i uninstalled and deleted k-lite codec pack, it was messing up my computer far more than i could deal with. whatever this update did its super bad and is causing a lot of errors.
I dont know what is going on but something BIG is going on and this k-lite codec pack just became absolute ASSSSSSS
Codec Tweak Tool | Log file | Generated at 2018-07-05 12:28:47

#####  System Information  #####

OS:           Windows 10 Home (10.00.16299) (x64)
CPU name:     AMD A8-7600 Radeon R7, 10 Compute Cores 4C+6G
CPU speed:    3094 MHz (4t)
Memory:       12256 MB
Screen size:  1920x1080 (32bits) (60Hz)
Video card:   NVIDIA GeForce GTX 1050 Ti
             VendorID: 10de, DeviceID: 1c82
Video mem:    4096 MB
Video driver: nvldumdx.dll (Version 24.21.13.9836) (6-24-2018) (NV 398.36)
Audio device: USB Audio Device
Audio driver: USBAUDIO.sys (Version 10.0.16299.15) (9-28-2017)

#####  K-Lite Codec Pack  #####

KLCP version: 14.2.6 (base 14.2.5)
KLCP type:    mega

Speaker conf: as is

MPC renderer: EVR CP
MPC subs:     ISR

#####  Decoder Settings #####

LAV Video:
H264=DXVA2CB HEVC=DXVA2CB VP9=1 VC1=DXVA2CB MPEG2=DXVA2CB MPEG4=1 WMV3=0

LAV Audio:
MP3=1 AC3=B DTS=B DTSHD=B EAC3=B TRUEHD=B AAC=1 Vorbis=1 LPCM=1 WMA=1

#####  DirectShow Filters (32-bit)  #####

Description:  LAV Splitter
File name:    c:\program files (x86)\k-lite codec pack\filters\lav\lavsplitter.ax
CLSID:        {171252A0-8820-4AFE-9DF8-5C92B2D66B04}
Merit:        00400001 = MERIT_UNLIKELY + 1

Description:  VSFilter (auto-loading version)
File name:    c:\program files (x86)\k-lite codec pack\filters\directvobsub\vsfilter.dll
CLSID:        {9852A670-F845-491B-9BE6-EBD841B8A613}
Merit:        00800002 = MERIT_PREFERRED + 2

Description:  AC3Filter
File name:    c:\program files (x86)\k-lite codec pack\filters\ac3filter\ac3filter.ax
CLSID:        {A753A1EC-973E-4718-AF8E-A3F554D45C44}
Merit:        40000000

Description:  DC-Bass Source
File name:    c:\program files (x86)\k-lite codec pack\filters\dcbass\dcbasssourcemod.ax
CLSID:        {ABE7B1D9-4B3E-4ACD-A0D1-92611D3A4492}
Merit:        00400000 = MERIT_UNLIKELY

Description:  LAV Splitter Source
File name:    c:\program files (x86)\k-lite codec pack\filters\lav\lavsplitter.ax
CLSID:        {B98D13E7-55DB-4385-A33D-09FD1BA26338}
Merit:        00400001 = MERIT_UNLIKELY + 1

Description:  LAV Audio Decoder
File name:    c:\program files (x86)\k-lite codec pack\filters\lav\lavaudio.ax
CLSID:        {E8E73B6B-4CB3-44A4-BE99-4F7BCB96E491}
Merit:        00800003 = MERIT_PREFERRED + 3

Description:  LAV Video Decoder
File name:    c:\program files (x86)\k-lite codec pack\filters\lav\lavvideo.ax
CLSID:        {EE30215D-164F-4A92-A4EB-9D4C13390F9F}
Merit:        FF800000

(A total of 74 filters, 7 shown, 67 hidden)

#####  DirectShow Filters (64-bit)  #####

Description:  LAV Splitter
File name:    c:\program files (x86)\k-lite codec pack\filters\lav64\lavsplitter.ax
CLSID:        {171252A0-8820-4AFE-9DF8-5C92B2D66B04}
Merit:        00400001 = MERIT_UNLIKELY + 1

Description:  VSFilter (auto-loading version)
File name:    c:\program files (x86)\k-lite codec pack\filters\directvobsub64\vsfilter.dll
CLSID:        {9852A670-F845-491B-9BE6-EBD841B8A613}
Merit:        00800002 = MERIT_PREFERRED + 2

Description:  AC3Filter
File name:    c:\program files (x86)\k-lite codec pack\filters\ac3filter64\ac3filter64.ax
CLSID:        {A753A1EC-973E-4718-AF8E-A3F554D45C44}
Merit:        40000000

Description:  LAV Splitter Source
File name:    c:\program files (x86)\k-lite codec pack\filters\lav64\lavsplitter.ax
CLSID:        {B98D13E7-55DB-4385-A33D-09FD1BA26338}
Merit:        00400001 = MERIT_UNLIKELY + 1

Description:  LAV Audio Decoder
File name:    c:\program files (x86)\k-lite codec pack\filters\lav64\lavaudio.ax
CLSID:        {E8E73B6B-4CB3-44A4-BE99-4F7BCB96E491}
Merit:        00800003 = MERIT_PREFERRED + 3

Description:  LAV Video Decoder
File name:    c:\program files (x86)\k-lite codec pack\filters\lav64\lavvideo.ax
CLSID:        {EE30215D-164F-4A92-A4EB-9D4C13390F9F}
Merit:        FF800000

(A total of 73 filters, 6 shown, 67 hidden)

#####  ICM Class Manager (32-bit)  #####

Description:  ffdshow video encoder
File name:    c:\program files (x86)\k-lite codec pack\filters\ffdshow\ffdshow.ax
CLSID:        {4DB2B5D9-4556-4340-B189-AD20110D953F} (ffdshow video encoder)
Merit:        00100000 = MERIT_SW_COMPRESSOR

(A total of 3 filters, 1 shown, 2 hidden)

#####  ICM Class Manager (64-bit)  #####

Description:  ffdshow video encoder
File name:    c:\program files (x86)\k-lite codec pack\filters\ffdshow64\ffdshow.ax
CLSID:        {4DB2B5D9-4556-4340-B189-AD20110D953F} (ffdshow video encoder)
Merit:        00100000 = MERIT_SW_COMPRESSOR

(A total of 3 filters, 1 shown, 2 hidden)

#####  Default source filters (32-bit)  #####

.3g2    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.3gp    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.3gp2   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.3gpp   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.aac    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.ac3    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.alac   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.amr    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.ape    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.avs    {D3588AB0-0781-11CE-B03A-0020AF0BA770}  AVI/WAV File Source
.bdmv   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.dts    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.dv     {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.evo    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.f4v    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.flv    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.hdmov  {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.it     {ABE7B1D9-4B3E-4ACD-A0D1-92611D3A4492}  DC-Bass Source
.m2t    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.m2ts   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.m4a    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.m4v    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mk3d   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mka    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mks    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mkv    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mo3    {ABE7B1D9-4B3E-4ACD-A0D1-92611D3A4492}  DC-Bass Source
.mov    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mp4    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mp4v   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mpc    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mpls   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mpv4   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mtm    {ABE7B1D9-4B3E-4ACD-A0D1-92611D3A4492}  DC-Bass Source
.mts    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.ofr    {ABE7B1D9-4B3E-4ACD-A0D1-92611D3A4492}  DC-Bass Source
.ofs    {ABE7B1D9-4B3E-4ACD-A0D1-92611D3A4492}  DC-Bass Source
.oga    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.ogg    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.ogm    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.ogv    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.ra     {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.rm     {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.rmvb   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.s3m    {ABE7B1D9-4B3E-4ACD-A0D1-92611D3A4492}  DC-Bass Source
.ssif   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.tp     {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.ts     {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.umx    {ABE7B1D9-4B3E-4ACD-A0D1-92611D3A4492}  DC-Bass Source
.webm   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.wv     {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.xm     {ABE7B1D9-4B3E-4ACD-A0D1-92611D3A4492}  DC-Bass Source

(A total of 64 default source filters, 52 shown, 12 hidden)

#####  Default source filters (64-bit)  #####

.3g2    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.3gp    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.3gp2   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.3gpp   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.aac    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.ac3    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.alac   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.amr    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.ape    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.bdmv   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.dts    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.dv     {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.evo    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.f4v    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.flv    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.hdmov  {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.m2t    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.m2ts   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.m4a    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.m4v    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mk3d   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mka    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mks    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mkv    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mov    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mp4    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mp4v   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mpc    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mpls   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mpv4   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.mts    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.oga    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.ogg    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.ogm    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.ogv    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.ra     {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.rm     {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.rmvb   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.ssif   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.tp     {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.ts     {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.webm   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.wv     {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source

(A total of 55 default source filters, 43 shown, 12 hidden)

#####  ACM and VFW Codecs (32-bit)  #####

Description:  RivaTuner Video Codec
ID:           VIDC.RTV1
File name:    C:\Windows\SysWOW64\rtvcvfw32.dll

Description:  Fraps Video Decompressor
ID:           VIDC.FPS1
File name:    C:\Windows\SysWOW64\frapsvid.dll

Description:  x264 H.264 video codec
ID:           VIDC.X264
File name:    C:\Windows\SysWOW64\x264vfw.dll

Description:  Lagarith lossless video codec
ID:           VIDC.LAGS
File name:    C:\Windows\SysWOW64\lagarith.dll

Description:  Xvid MPEG-4 video codec 1.3.5
ID:           VIDC.XVID
File name:    C:\Windows\SysWOW64\xvidvfw.dll

Description:  ffdshow video codec
ID:           VIDC.FFDS
File name:    C:\Windows\SysWOW64\ff_vfw.dll

Description:  AC3 ACM codec
ID:           msacm.ac3acm
File name:    C:\Windows\SysWOW64\ac3acm.acm

(A total of 22 codecs, 7 shown, 15 hidden)

#####  ACM and VFW Codecs (64-bit)  #####

Description:  RivaTuner Video Codec
ID:           VIDC.RTV1
File name:    C:\Windows\system32\rtvcvfw64.dll

Description:  Fraps Video Decompressor
ID:           VIDC.FPS1
File name:    C:\Windows\system32\frapsv64.dll

Description:  x264 H.264 video codec
ID:           VIDC.X264
File name:    C:\Windows\system32\x264vfw64.dll

Description:  Lagarith lossless video codec
ID:           VIDC.LAGS
File name:    C:\Windows\system32\lagarith.dll

Description:  Xvid MPEG-4 video codec 1.3.5
ID:           VIDC.XVID
File name:    C:\Windows\system32\xvidvfw.dll

Description:  AC3 ACM codec
ID:           msacm.ac3acm
File name:    C:\Windows\system32\ac3acm.acm

(A total of 20 codecs, 6 shown, 14 hidden)

MayDai

Posts : 6
Join date : 2018-06-30

View user profile

Back to top Go down

Re: Lost Sound for ALL playback after 14.2.5 update

Post by Admin on Thu Jul 05, 2018 10:11 pm

The log shows that you have bitstreaming enabled. Do you actually have a receiver? Even if so, does playback work if you disable bitstreaming?

Also try disabling AC3Filter with the Codec Tweak Tool, under Filter Management.

Admin
Admin

Posts : 4194
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Lost Sound for ALL playback after 14.2.5 update

Post by Admin on Thu Jul 05, 2018 11:29 pm

Dropouts can occur because of a DPC latency issue. Here is a tool that can check if you have any drivers that cause such issues:
http://www.resplendence.com/latencymon

Admin
Admin

Posts : 4194
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Lost Sound for ALL playback after 14.2.5 update

Post by MayDai on Fri Jul 06, 2018 12:35 am

Thank you will start troubleshooting now.
Update#1 - I have an reciever yes, its going in from computer and out to tv, i had set my k-lite codec settings absolutely perfect to work with my reciever and use all its capabilities and after this update something in it messed that entire perfect setup and made it absolutely not work at all.
So far without AC3 codec my sound works but is very quiet and only plays through HDMI PCM, where as my setup before had Dolby logos and such on my reciever turned on, it had amazing sound.
i reinstalled k-lite without the AC3 and i dont get as many options anymore for my reciever, i cannot turn on any features of the reciever, i dont know what to do to fix this, but whatever this new update did no longer my saved settings for years are working, my old settings that were flawless and i used everytime for many years are now not working and causing many errors.

Update #2 - so far if i just use LAV codec i have sound but its quiet as i said before, im trying to figure out how i can get the codecs to work properly with my reciever again, seems my old settings just aren't working anymore after that update and not exactly sure why.

Update #3 - reinstalled k-lite codec pack again, restored old settings and once again it seems to be working fine with flawless sound and im not sure why these same settings didnt work before, then worked, then didnt work and now work again?. Whats happening with my codecs and why is it picking and choosing when to work properly?, i dont mess with any sound settings to have to not work and i also restored these same settings before with it giving me errors but also restored these settings and it worked fine as well but only for a tiny bit.
How can i figure out whats happening in a larger scale?, something must be giving out false positives.

MayDai

Posts : 6
Join date : 2018-06-30

View user profile

Back to top Go down

Re: Lost Sound for ALL playback after 14.2.5 update

Post by Admin on Fri Jul 06, 2018 11:58 am

In previous versions, when you enabled bitstreaming in LAV Audio decoder, it would either use bitstreaming when possible, or the filter would fail when not possible. In that case another decoder would get used.

Current version of LAV Audio Decoder has a fallback that temporarily deactivates bitstreaming when the downstream filter does not support it. If you use AC3Filter or ffdshow audio processor, then bitstreaming gets deactivated in current version. While in older version those filter would not load in the case when the renderer supports bitstreaming, thus allowing to process only non-bitstreamed audio formats. I am investigating a way to optionally restore that ability. However, that is mostly useful for SPDIF users who want to re-encode surround audio. HDMI supports up to 7.1 PCM audio, so re-encoding is not needed.

I suggest to start with a fresh set of settings, at least for the decoders.
Use only LAV Audio Decoder, and enable bitstreaming in its options (or in the K-Lite installer). That should give proper playback of Dolby Digital (AC3), DTS, TrueHD, etcetera. Formats that can't be bitstreamed will be send to your receiver as PCM audio. I recommend to set the speaker configuration in the pack to either "Same as input" or to your actual speaker setup. In first case the receiver is responsible for channel upmixing when it for example gets stereo input.

If volume is low for PCM, then click on the Windows speaker icon in the right bottom corner of the screen. Check that "Volume Mixer" isn't set too low. If that isn't enough, then there are several ways to boost the volume. For example Volume Normalization (MPC-HC options > Audio Switcher > Normalize) or Loudness Equalization enhancement in the Windows Sound settings. Your receiver may also have options for how it handles PCM input. Receiver settings like "Night Mode" also affect volume.

You can see which filters are loaded by looking at:
MPC-HC menu > Play > Filters
If you click on LAV Audio decoder in that list, then you can see what it does on its Status tab. It will say "bitstreaming" or PCM.

Admin
Admin

Posts : 4194
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Lost Sound for ALL playback after 14.2.5 update

Post by MayDai on Fri Jul 06, 2018 8:07 pm

Ah i see, before it my ampilifier reciever had to be not encoding the bitstream, i had to use codecs to do so even with an HDMI cord.
i see now the options have now changed, i can now use HDMI or SPDIF for output and i can also choose the Dolby Digital and DTS TRUE HD settings underneath the HDMI setting at end up setup.
I guess its time for a new bunch of settings and trying to figure out how to get LAV working good, seems it has very minimul and again my sound is ridiculously low, its not my settings thats doing it either.
on other codecs i run at 30 on sound and its super loud, with LAV i have to have this over 50!

MayDai

Posts : 6
Join date : 2018-06-30

View user profile

Back to top Go down

Re: Lost Sound for ALL playback after 14.2.5 update

Post by Admin on Fri Jul 06, 2018 10:25 pm

Please give details about which audio formats give low volume. Also mention the number of audio channels (stereo/5.1/etc). Then I can give advice on settings.

You should not have volume issue when bitstreaming is active because in that case the receiver is doing all decoding and volume control. So check that bistreaming is working correctly when playing a file that has a bitsteamable audio format. If it isn't working, then verify that the correct audio device is set as the default in the Windows Control Panel.

Admin
Admin

Posts : 4194
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Lost Sound for ALL playback after 14.2.5 update

Post by MayDai on Sat Jul 07, 2018 12:34 am

I am using a 5.1 speaker setup at 24bit 4800Khz; bitstreaming turned on in LAV, ffdshow and etc; this setup is now currently the settings i have now it is working fully with amazing loud crisp sound, i followed what you said on previous step above: installed new copy over already installed copy of K-lite codec pack, at end of setup i set sound to same as input and output HDMI and turned on all the options beneath such as Dolby Digital (AC3), DTS, TrueHD and etc; I then restored my backup copy of original settings which should only restore certain codec settings i had set on the LAV, ffdshow, Ac3codec and if any etc; seems to have no issues so far.

MayDai

Posts : 6
Join date : 2018-06-30

View user profile

Back to top Go down

Re: Lost Sound for ALL playback after 14.2.5 update

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum