Terrible sound in mp4 files with AAC sound

View previous topic View next topic Go down

Terrible sound in mp4 files with AAC sound

Post by necroguttural on Mon Jun 19, 2017 7:01 pm

I have always had the problem mentioned in the title. I use win 10 x64 and all mp4 files with AAC sound just terrible and distorted

necroguttural

Posts : 3
Join date : 2017-06-19
Age : 38

View user profile

Back to top Go down

Re: Terrible sound in mp4 files with AAC sound

Post by Admin on Mon Jun 19, 2017 8:08 pm

Which player are you using?

Admin
Admin

Posts : 3625
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Terrible sound in mp4 files with AAC sound

Post by necroguttural on Tue Jun 20, 2017 6:12 pm

I use media player classic and havent touched anything in options. The same files all sound great in any other media player

necroguttural

Posts : 3
Join date : 2017-06-19
Age : 38

View user profile

Back to top Go down

Re: Terrible sound in mp4 files with AAC sound

Post by Admin on Tue Jun 20, 2017 8:16 pm

Are these videos with 5.1 surround audio and are your speakers set to Stereo? Then try this:

LAV Audio decoder settings > Mixing
Set LFE MIx Level to 0.00 and Center Mix Level to 0.71

Admin
Admin

Posts : 3625
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Terrible sound in mp4 files with AAC sound

Post by necroguttural on Tue Jun 20, 2017 8:53 pm

No multi channel this time. the sound is distorted
Audio
ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC
Codec ID : 40
Duration : 5 min 57 s
Bit rate mode : Variable
Bit rate : 126 kb/s
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 44.1 kHz
Frame rate : 43.066 FPS (1024 spf)
Compression mode : Lossy
Stream size : 5.36 MiB (4%)
Default : Yes
Alternate group : 1

necroguttural

Posts : 3
Join date : 2017-06-19
Age : 38

View user profile

Back to top Go down

Re: Terrible sound in mp4 files with AAC sound

Post by Admin on Wed Jun 21, 2017 1:10 pm

MPC-HC menu > Play > Filters

It should look like this during playback:
- Default DirectSound Device
- Enhanced Video Renderer (custom presenter)
- Audio Switcher
- LAV Video Decoder
- LAV Audio Decoder
- LAV Splitter Source

Let me know if it shows any other filters.

Assuming the filter list is correct. Click on LAV Audio decoder. Disable "32-bit floating point" as output format. This could potentially help if the audio was badly encoded and has overflow problems.

On the Status tab in LAV Audio decoder you can see (during playback) what the volume levels are. If the green bars are almost constantly near the top it could indicate overflow.

Admin
Admin

Posts : 3625
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum