Can't control my WMP with the media buttons on my keyboard after updating MPC

View previous topic View next topic Go down

Can't control my WMP with the media buttons on my keyboard after updating MPC

Post by BlackEdition on Thu May 11, 2017 7:06 am

Hi,

I was using K-Lite Codec Pack version 8.x.x (can't remember all the numbers, but it was in the 8s), and I just updated to the latest version 13.1.6 but I discovered something that doesn't really work for me and I really hate to go back to older versions if I can't find a way to fix this (although I can't see any differences in the latest version, but new updates are always better). I'm not sure whether it's related to the new default settings in MPC or something else? I went through the entire options but I couldn't figure out how to fix this or what's causing it to happen.

First of all, I always have 2 players open whenever I'm on my computer, MPC to play videos and Windows Media Player to play my audio files, but I don't play all of them at the same time. I use the media buttons (play, stop...etc) on my keyboard to control my audio on WMP and it's been working great for me for years until now. I use my mouse if I want to control my video on MPC, and the media buttons on my keyboard works great on WMP by default as I can control my audio even if the WMP window itself isn't focused (it's minimized), but now whenever I try to control something with the media buttons on my keyboard it automatically controls my video on MPC instead which is something I don't like. It seems I can only control WMP when MPC is fully closed, which means there could be something that's making MPC to be on top, the highest priority or something but I'm not sure if I can edit this in the settings?

If it helps, I'm on Windows 10 Pro 64bit and I have a monitor and a TV connected to my PC, and I only play MPC videos on my TV. I would like to fix this as soon as possible please! It's hard to change something major like this when you've been doing it for years and years.

I hope my issue was clear enough. Please let me know if you don't understand what I'm talking about.

Thank you

BlackEdition

Posts : 2
Join date : 2017-05-11

View user profile

Back to top Go down

Re: Can't control my WMP with the media buttons on my keyboard after updating MPC

Post by BlackEdition on Thu May 11, 2017 7:24 am

Nevermind I found the option to configure this. All I had to do is disable "Global Media Keys" under Options > Keys. Now I can control my WMP all the time whether it's focused or not, and I can also control MPC with the media buttons but only if it's focused (that's how I want it to be).

I found the answer when I just googled it. I'm really sorry I didn't think I would find someone with the same questions out there. I'm just not sure if this option was disabled by default in the previous versions? I can't really remember.

BlackEdition

Posts : 2
Join date : 2017-05-11

View user profile

Back to top Go down

Re: Can't control my WMP with the media buttons on my keyboard after updating MPC

Post by Admin on Thu May 11, 2017 1:16 pm

This setting has been this way for at least a few years. It is the default value of MPC.

Admin
Admin

Posts : 3445
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum