mjpeg files playing as interlaced with fields reversed

View previous topic View next topic Go down

mjpeg files playing as interlaced with fields reversed

Post by debileMental on Sat Apr 01, 2017 7:12 am

Hi -
I've installed K-lite codec pack 13.0.0 and I'm trying to play AVI files that are encoded with MJPG codec.
I have another machine on which these look fine - but on this machine, they look like interlaced files with the fields inverted.
Even though the frames are supposed to be progressive, mediainfo reports they are interlaced with top field first. That may have been my mistake when encoding them, but the point is, one computer is reading them with fields one way, the other (new) computer is reading them with fields the other way.
I would compare the mjpeg codec/version in both machines, but I don't know how to list the actual codecs that come with K-lite, much less their version numbers...
Seems like I need to somehow tell K-Lite to use a different kind of MJpeg decoder, or at least, tweak the Mjpeg decoder's default settings.
Does anybody know how I can do that?
I'm new to K-lite and a bit overwhelmed by all these options!
Many thanks-



debileMental

Posts : 2
Join date : 2017-04-01

View user profile

Back to top Go down

Re: mjpeg files playing as interlaced with fields reversed

Post by Admin on Sun Apr 02, 2017 4:39 pm

It is easy to see which codec is used:
MPC-HC menu > Play > Filters

It is most likely either LAV Video decoder or the decoder from Microsoft. You can enable/disable MJPEG in LAV Video decoder settings.

Admin
Admin

Posts : 3681
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: mjpeg files playing as interlaced with fields reversed

Post by debileMental on Mon Apr 03, 2017 3:04 am

I'll look into that thank you!

debileMental

Posts : 2
Join date : 2017-04-01

View user profile

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum