video stop after black screen ans after a few seconds it accelerates / Ryzen / x265

View previous topic View next topic Go down

video stop after black screen ans after a few seconds it accelerates / Ryzen / x265

Post by djlaludo on Sun Mar 26, 2017 7:03 pm

On win7 or 10, when I'm watching a film. At the beginning it's ok and after a balck screen, sounds continue but video is on 'pause' and after a few seconds, the video accelerate until it synchronizes with sound... And it does that all the movie. I've the last standard version of k-lite. I use LAV-madVR. It does that apparently on MKV with x265 codec.

I pressent a bug with my new hardware..
I've a GTX980 and now a RYZEN 1700 on ASUS-X370 chipset (up to date).

But when I use VLC I've not this problem (but some problems with subtitles it's why I prefer using mpc with k-lite)
Anyone has this type of problem? Or an idea of its origin?

Thank you!

djlaludo

Posts : 1
Join date : 2017-03-26

View user profile

Back to top Go down

Re: video stop after black screen ans after a few seconds it accelerates / Ryzen / x265

Post by Admin on Mon Mar 27, 2017 3:32 pm

Test if playback is good when using "Enhanced Video Renderer (Custom Presenter)" instead of MadVR. If it is, then you need to adjust MadVR settings.

If it also happens with EVR, then adjust hardware acceleration settings in LAV Video decoder. Your GTX980 only has partial acceleration for HEVC/H.265. Try all available options and test which one performs best in your case.

Admin
Admin

Posts : 3625
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: video stop after black screen ans after a few seconds it accelerates / Ryzen / x265

Post by nemanjic on Sat Jun 17, 2017 8:09 pm

Hi @Admin, can you please show us step by step and slowly in details on how to carefully setup these settings for x265 videos can not be reproduced with the latest version of Klite mega from MPC HC x64. thanks


Last edited by nemanjic on Sat Jun 17, 2017 8:10 pm; edited 1 time in total (Reason for editing : grammar)

nemanjic

Posts : 7
Join date : 2017-06-17

View user profile

Back to top Go down

Re: video stop after black screen ans after a few seconds it accelerates / Ryzen / x265

Post by Admin on Sun Jun 18, 2017 12:01 pm

It should already play with default settings.

If you have a problem then you need to provide details about your CPU and graphics card. Your system might not be capable of playing high resolution x265 videos.

Admin
Admin

Posts : 3625
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: video stop after black screen ans after a few seconds it accelerates / Ryzen / x265

Post by nemanjic on Tue Jun 20, 2017 3:41 am

ok sorry here are details below please note that km and some other players play x265 flawlessly with no errors & no juddering whatsoever .latest codecs klite mega installed latest mp hc x64
CPU i5 m430 2.27mhz
graph nvidia geforce 330m
RAM 4gb
win exp index 5.9
os win 7 x64

nemanjic

Posts : 7
Join date : 2017-06-17

View user profile

Back to top Go down

Re: video stop after black screen ans after a few seconds it accelerates / Ryzen / x265

Post by Admin on Tue Jun 20, 2017 2:02 pm

Your GPU does not support HEVC, so there is no hardware acceleration. Your CPU should be able to handle 720p video and maybe even 1080p.

What is the CPU usage with kmplayer?

Admin
Admin

Posts : 3625
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: video stop after black screen ans after a few seconds it accelerates / Ryzen / x265

Post by nemanjic on Wed Jun 21, 2017 12:33 am

all 1080p videos have been reproduced perfectly up until the moment i noticed it would not render h265. say how do i check the cpu usage with km player while reproducing HEVC? i find it unusual and not logical thatt km plays it perfectly whereas mpc hc simply doesn't reproduce video content but solely audio.


Last edited by nemanjic on Wed Jun 21, 2017 12:39 am; edited 1 time in total (Reason for editing : grammar stop asking me for reason for editing. thank you)

nemanjic

Posts : 7
Join date : 2017-06-17

View user profile

Back to top Go down

Re: video stop after black screen ans after a few seconds it accelerates / Ryzen / x265

Post by Admin on Wed Jun 21, 2017 1:12 pm

If you don't get any video at all, then it could be a splitter problem.

MPC-HC menu > Play > Filters
You should see LAV Splitter in the list. You should not use Haali splitter because that does not support HEVC.

Admin
Admin

Posts : 3625
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: video stop after black screen ans after a few seconds it accelerates / Ryzen / x265

Post by nemanjic on Wed Jun 21, 2017 2:20 pm

that makes sense. sir could you be much more specific "you should see LAV filter in the list" ok and then? namely there are at least five drop down menus when i get to the splitter. attached are printscreens.







nemanjic

Posts : 7
Join date : 2017-06-17

View user profile

Back to top Go down

Re: video stop after black screen ans after a few seconds it accelerates / Ryzen / x265

Post by Admin on Wed Jun 21, 2017 2:37 pm

1) Run the codec pack installer
2) Uncheck "Perform quick upgrade"
3) On the "Select Components" page scroll down to the "DirectShow source filters" section. Change Matroska/MP4/MPEG-TS choice to LAV.

Admin
Admin

Posts : 3625
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: video stop after black screen ans after a few seconds it accelerates / Ryzen / x265

Post by nemanjic on Wed Jun 21, 2017 2:51 pm

thank you for your swift replies. i gather the problem has been solved by checking exactly all lav boxes. the only thing i didn't touch is the dialogue upon installation pertaining to software decoding. what do you suggest me and all users to select. thanks once again for your support
damjan, belgrade, the kingdom of serbia/europe

nemanjic

Posts : 7
Join date : 2017-06-17

View user profile

Back to top Go down

Re: video stop after black screen ans after a few seconds it accelerates / Ryzen / x265

Post by Admin on Wed Jun 21, 2017 2:54 pm

Use either software decoding or DXVA2 native. Your GPU only supports hardware acceleration for H.264.

Admin
Admin

Posts : 3625
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum