Impossible to disable subtitles for MKV by default

View previous topic View next topic Go down

Impossible to disable subtitles for MKV by default

Post by Fogsight on Fri Feb 24, 2017 9:21 am

I had to install without DirectVobSub, because it doesn't have any way to prevent subs auto-display, in MKV at least.

Fogsight

Posts : 4
Join date : 2017-02-24

View user profile

Back to top Go down

Re: Impossible to disable subtitles for MKV by default

Post by Admin on Fri Feb 24, 2017 4:20 pm

Easy to do:
LAV Splitter settings > Subtitle Selection Mode > No subtitles

Admin
Admin

Posts : 3625
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Impossible to disable subtitles for MKV by default

Post by Fogsight on Fri Feb 24, 2017 4:35 pm

Admin wrote:Easy to do:
LAV Splitter settings > Subtitle Selection Mode > No subtitles
Tested, that does nothing. VSFilter is the one that overrides all defaults. I've installed with all preferred language options and detection turned off as well. Unless I reinstall cleanly without DirectVobSub subtitles are always on by default.

Fogsight

Posts : 4
Join date : 2017-02-24

View user profile

Back to top Go down

Re: Impossible to disable subtitles for MKV by default

Post by Admin on Fri Feb 24, 2017 6:11 pm

It works here with MPC-HC and WMP. Which player are you using? The player may be overriding the choice. VSFilter itself does not do that. Of course this only works for embedded subtitles, not for external ones.

To hide subtitles by default:
VSFilter option > Misc > Hide subtitles
(no the same as disabling, but them aren't visible)

Admin
Admin

Posts : 3625
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Impossible to disable subtitles for MKV by default

Post by Fogsight on Fri Feb 24, 2017 6:34 pm

Using MPC-HC, from standard pack latest release on Windows 10. The problem is specific to MKV files with internal subtitles. And "Hide subtitles" option is temporary, it does not become default.

Last pack I used was installed few month ago, do not remember having these problems before.

P.S. Not relevant to this particular problem, but installing this pack on advanced, while setting specifically to use MPC-HC for video and winamp for audio files, sets all file associations to WPM for some reason.

Fogsight

Posts : 4
Join date : 2017-02-24

View user profile

Back to top Go down

Re: Impossible to disable subtitles for MKV by default

Post by Admin on Fri Feb 24, 2017 7:42 pm

The "Hide subtitles" option in the settings should be permanent. The entry in the right-click menu of VSFilter is temporary.

Strange thing is that VSFilter should not even be used by default on Windows 10. By default the internal subtitle renderer of MPC-HC is used by the pack. There are two exceptions: (1) if Enhanced Video Renderer is missing (Windows N), or (2) there was an issue with the graphics driver

You can change the video renderer in:
MPC-HC options > Playback > Output

There is an option that makes the player override the track selection of the splitter:
MPC-HC options > Playback > Default track preference
(this option is disabled by default)

With regard to the file associations, this should only occur for a handful of extensions. To be specific, all selected settings with regard to MPC-HC should work as expected. In case of Winamp, the installer does not make any file associations, so any existing associations for audio should remain as is. The only extra thing that the installer does is create a fallback association for any file extension that does not yet have a proper association. Perhaps this is what you are seeing? Or was WMP for everything, including video?

Admin
Admin

Posts : 3625
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Impossible to disable subtitles for MKV by default

Post by Fogsight on Fri Feb 24, 2017 8:28 pm

Clean install: set preferred video to MPC-HC, audio to WinAmp, checked "Create file associations", reset to default all settings checked, default Enhanced Video Renderer (Custom Presenter), enable internal sub renderer (ISR) on, File associations MPC-HC checked, specific associations selected only for video files.

Result: Associations for the video do not get set, used WMP, audio untouched. On MKV VSFilter not used, subs are displayed by default. At this point setting "No Subtitles" in LAV Splitter configuration "Subtitle Selection Mode" and relaunching video still shows subs by default. But enabling and disabling subtitles track does get saved and used by default. So no problem here.

VSFilter got used when I switched to Enhanced Video Renderer - without (Custom Presenter) part, in old version when I was experiencing audio desyncs, which fixed it, but introduced subs (BTW "VSFilter option > Misc > Hide subtitles" worked at this point, thanks) and settings were carried over upon upgrade.

Latest version does not have desyncs on default renderer, so this whole thing is a non issue now, apart from associations thing.

Thanks again. Cheers!

Fogsight

Posts : 4
Join date : 2017-02-24

View user profile

Back to top Go down

Re: Impossible to disable subtitles for MKV by default

Post by Admin on Fri Feb 24, 2017 9:16 pm

It is not possible for programs to automatically set themselves as default in Windows 10. The codec pack uses some tricks to reset a file association (when it isn't equal to the desired one yet). Visually it will (temporarily) look like the file is associated with WMP (or whatever Microsoft program is default). Once you click on a file to open it, you will get a prompt asking you which program should be used to open it. After you select the desired program, then the file icon will be updated.

You can also adjust file associations through:
Codec Tweak Tool > File Associations

Admin
Admin

Posts : 3625
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum