FFShow Configuration missing?

View previous topic View next topic Go down

FFShow Configuration missing?

Post by supersmilers on Mon Jan 30, 2017 10:35 pm

Hello,

I installed the latest Cumulative update and FFShow configurations isn't working. Basically I can click on the option but the config window isn't showing up even if I manually run "Rundll32.exe" on that config file. I even install the beta version of the pack also to see if its fixed but no go.

Can this be fixed soon?

Here's the log file in code:

Code:
Codec Tweak Tool | Log file | Generated at 2017-01-30 16:29:47

#####  System Information  #####

OS:           Windows 10 Pro Insider Preview  (10.00.15019) (x64)
DirectX:      9.0c + 10 + 10.1 + 11 + 12
CPU name:     Intel(R) Core(TM) i5-4300U CPU @ 1.90GHz
CPU speed:    2494 MHz (4t)
Memory:       2048 MB
Screen size:  2160x1440 (32bits) (60Hz) (150%)
Video card:   Intel(R) HD Graphics Family
              VendorID: 8086, DeviceID: 0a16, SubSys: 00051414
Video driver: igdumdim64.dll (Version 20.19.15.4331) (11-18-2015)
Audio device: Intel(R) Display Audio
              VendorID: 8086, DeviceID: 2807, SubSys: 80860101
Audio driver: IntcDAud.sys (Version 6.16.0.3197) (5-10-2016)

#####  K-Lite Codec Pack  #####

KLCP version: 12.8.9
KLCP type:    mega

Speaker conf: as is

MPC renderer: EVR CP
MPC subs:     ISR

#####  Decoder Settings #####

LAV Video:
H264=1|4 HEVC=1|4 VP9=1|4 VC1=1|4 MPEG2=1|4 MPEG4=1 WMV3=0

LAV Audio:
MP3=1 AAC=1 Vorbis=1 AC3=1 DTS=1 LPCM=1 WMA=0

ffdshow (x86):
H264=0 VC1=0 MPEG2=0 XVID=0 DX50=0 DIV3=0 FLV1=0 RAW=0
MP3=0 AAC=0 Vorbis=0 AC3=0 DTS=0 LPCM=0 RAW=0

ffdshow (x64):
H264=0 VC1=0 MPEG2=0 XVID=0 DX50=0 DIV3=0 FLV1=0 RAW=0
MP3=0 AAC=0 Vorbis=0 AC3=0 DTS=0 LPCM=0 RAW=0


#####  DirectShow Filters (32-bit)  #####

(A total of 84 filters, 0 shown, 84 hidden)

#####  DirectShow Filters (64-bit)  #####

(A total of 75 filters, 0 shown, 75 hidden)

#####  ICM Class Manager (32-bit)  #####

(A total of 3 filters, 0 shown, 3 hidden)

#####  ICM Class Manager (64-bit)  #####

(A total of 3 filters, 0 shown, 3 hidden)

#####  Default source filters (32-bit)  #####

.avi    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.avs    {D3588AB0-0781-11CE-B03A-0020AF0BA770}  AVI/WAV File Source
.divx   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source

(A total of 65 default source filters, 3 shown, 62 hidden)

#####  Default source filters (64-bit)  #####

.avi    {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source
.avs    {D3588AB0-0781-11CE-B03A-0020AF0BA770}  AVI/WAV File Source
.divx   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source

(A total of 58 default source filters, 3 shown, 55 hidden)

#####  ACM and VFW Codecs (32-bit)  #####

(A total of 26 codecs, 0 shown, 26 hidden)


#####  ACM and VFW Codecs (64-bit)  #####

(A total of 19 codecs, 0 shown, 19 hidden)


#####  DirectX Media Objects (32-bit)  #####

(A total of 31 DMO, 0 shown, 31 hidden)

#####  DirectX Media Objects (64-bit)  #####

(A total of 31 DMO, 0 shown, 31 hidden)
avatar
supersmilers

Posts : 5
Join date : 2017-01-30
Age : 22
Location : Eagan, MN

View user profile

Back to top Go down

Re: FFShow Configuration missing?

Post by Admin on Tue Jan 31, 2017 12:52 am

If you deselected all options for ffdshow during the update, then it is possible that the filters were disabled. In that case, the shortcuts will not work.

You can re-enable with:
Codec Tweak Tool > Codec and Filter Management > DirectShow

Admin
Admin

Posts : 3625
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: FFShow Configuration missing?

Post by supersmilers on Tue Jan 31, 2017 3:44 am

Admin wrote:If you deselected all options for ffdshow during the update, then it is possible that the filters were disabled. In that case, the shortcuts will not work.

You can re-enable with:
Codec Tweak Tool > Codec and Filter Management > DirectShow
I did not disable all the options for ffdshow during those updates. So they should work but they aren't working.
avatar
supersmilers

Posts : 5
Join date : 2017-01-30
Age : 22
Location : Eagan, MN

View user profile

Back to top Go down

Re: FFShow Configuration missing?

Post by Admin on Tue Jan 31, 2017 1:18 pm

Check anyway if ffdshow is currently disabled. That is the most likely reason why the shortcuts don't work. Or just run the installer again and choose ffdshow for the desired formats.

Admin
Admin

Posts : 3625
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: FFShow Configuration missing?

Post by supersmilers on Wed Feb 01, 2017 1:17 am

Admin wrote:Check anyway if ffdshow is currently disabled. That is the most likely reason why the shortcuts don't work. Or just run the installer again and choose ffdshow for the desired formats.
Even if I changed the desired formats to use ffdshow in the installer, the options are there but doesn't open the config windows.

EDIT: I looked into the start menu shortcuts for this filter (both 32bit and 64bit), apparently if I run them as admin, the UAC shows Rundll32.exe requesting permission, and I click yes. the Task manager doesn't show the rundll32.exe process afterwards.


Last edited by supersmilers on Wed Feb 01, 2017 3:06 am; edited 2 times in total (Reason for editing : updates)
avatar
supersmilers

Posts : 5
Join date : 2017-01-30
Age : 22
Location : Eagan, MN

View user profile

Back to top Go down

Re: FFShow Configuration missing?

Post by Admin on Wed Feb 01, 2017 4:15 pm

Strange. Running as admin is obviously not needed normally. This could indicate some sort of permissions issue with your Windows user account. That can happen due to data corruption, malware, etc.

Do the LAV shortcuts work correctly? Have you noticed any strange behavior in other applications?

Admin
Admin

Posts : 3625
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: FFShow Configuration missing?

Post by supersmilers on Sun Feb 05, 2017 4:44 pm

Admin wrote:Strange. Running as admin is obviously not needed normally. This could indicate some sort of permissions issue with your Windows user account. That can happen due to data corruption, malware, etc.

Do the LAV shortcuts work correctly? Have you noticed any strange behavior in other applications?

Well I was able to configure it from PotPlayer's configuration window not from rundll32.exe. "Running as admin" thing was me using "Windows Compatibility Troubleshooter" but after I look into the problem, I reverted the troubleshooting settings and used PotPlayer's Configuration Window for Ffdshow configuration only, but for LAV shortcuts they indeed work correctly.
avatar
supersmilers

Posts : 5
Join date : 2017-01-30
Age : 22
Location : Eagan, MN

View user profile

Back to top Go down

Re: FFShow Configuration missing?

Post by supersmilers on Fri Feb 17, 2017 10:27 pm

The Latest K-lite update (1.9.4) fixed my problem. It can now load FFDShow configuration window without going into PotPlayer's config wizard.


Last edited by supersmilers on Fri Feb 17, 2017 10:28 pm; edited 1 time in total (Reason for editing : a word or 2)
avatar
supersmilers

Posts : 5
Join date : 2017-01-30
Age : 22
Location : Eagan, MN

View user profile

Back to top Go down

Re: FFShow Configuration missing?

Post by Admin on Sat Feb 18, 2017 6:04 pm

That is strange, since the update doesn't touch anything related to ffdshow.

It is most likely just some weird bug in Windows. You are using the Insider Preview builds, those have these kind of random bugs very often.

Admin
Admin

Posts : 3625
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum