Fast playback problem

View previous topic View next topic Go down

Fast playback problem

Post by omar_bakly95 on Fri Dec 02, 2016 12:10 pm

In faster playback speeds with fractions as 1.25 and 1.50 I have problem with frame rate drops I feel like the screen freezes or hangs every 2-3 sec but when I increase to a whole number like 2 or 4 it works fine and I use internal audio renderer and enhanced video renderer (custom presenter)
But when I use enhanced video renderer as an external filter all these problems is solved but I canot add any subtitle , the subtitle menu is unusable even i make the subtitle same name like the video nothing appears
1-what is the problem why in default setting fast playback is problem and by using a enhanced video renderer filter the problem is solved ?
2-can i use enhanced video renderer and also add subtitles or there is something like it which can do this job knowing that enhanced video renderer (custom presenter) and madvr doesn't do the the job even by trying to adjust all the setting I know to increase performance and smooth the motion
3-I am using full hd monitor that optimal refresh rate 60 hz does overclocking it to 75hz would help ?

omar_bakly95

Posts : 7
Join date : 2016-09-30

View user profile

Back to top Go down

Re: Fast playback problem

Post by Admin on Fri Dec 02, 2016 3:22 pm

"Enhanced Video Renderer" is a standard video renderer from Microsoft. This renderer itself does not support subtitles, but you can use VSFilter for displaying subtitles in this case, and that should happen automatically when using the codec pack.
You can select this renderer in MPC-HC options > Playback > Output. No need to mess with external filter settings.

"Enhanced Video Renderer (custom presenter)" is a enhanced version of the standard EVR. This one is compatible with the internal subtitle functionality.

Changing the refreshrate should not make any difference.

I don't get any framedrops on my system with 1.25x or 1.5x speed. I have a nvidia GPU. Hardware acceleration is disabled.

MadVR doesn't work because the rendertime (Ctrl+J) is too high? I recommend to keep smooth motion disabled in this case.

Admin
Admin

Posts : 3689
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Reply

Post by omar_bakly95 on Fri Dec 02, 2016 4:58 pm

1- when i use Enhanced Video Renderer the subtitle panel in output is not accessible and vs filter doesn't automatically starts  although it is accessible in Enhanced Video Renderer (custom presenter) and madvr and i changed block vs fliter to false in advanced tab
2-Enhanced Video Renderer (custom presenter) is not better for me as when i use it i face problems even if it's better for all
3-Hardware acceleration is disabled.and i have switchable graphic memory and i tried both give the same result
4-I want youto  suggest me the Video Renderer and subtitle renderer that fits me and will be better for me , The fact when i used madvr or Enhanced Video Renderer (custom presenter)  I face these problem which is only fixed when i use Enhanced Video Renderer so now tell me how to allow subtitles in Enhanced Video Renderer or how to adjust Enhanced Video Renderer (custom presenter) or madvr to work as  Enhanced Video Renderer and give the same result as i tried everything and get the same result  I will show u madvr render time
" /> ,
I am confidently sure that my pc capable of making it as it does it easily in  Enhanced Video Renderer

omar_bakly95

Posts : 7
Join date : 2016-09-30

View user profile

Back to top Go down

Re: Fast playback problem

Post by Admin on Fri Dec 02, 2016 8:46 pm

1. Standard EVR is not compatible with all the internal subtitle functionality in MPC-HC.
You can select VSFilter as subtitle renderer in Options>Playback>Output
The BlockVSFilter option in advanced settings is only doing something when the internal subtitle renderer is used. Disabling this setting allows having two subtitles. Not relevant for your situation.
3. Your Intel GPU should have lowest performance of the two.
4. The render time is 35 milliseconds per frame. That is not fast enough. 1000 ms / 24 fps / 150% = 27.7 ms as a maximum.
Playback in fullscreen (press F11) should give better rendertime for that file, because madVR needs to do no image scaling in that case.

You can also try Sync Renderer. That is similar to EVR-CP.

Admin
Admin

Posts : 3689
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Reply

Post by omar_bakly95 on Fri Dec 02, 2016 8:58 pm

How to do that Look subtitle renderer is not accesible

I am forcing to use amd 7730m which I think capable of viewing videos at any speed and why everything works fine in evr that means it is not lack of requirements as it can be done easily

omar_bakly95

Posts : 7
Join date : 2016-09-30

View user profile

Back to top Go down

Reply

Post by omar_bakly95 on Fri Dec 02, 2016 9:13 pm

while forcing amd 7730m in madvr i get lower rendering time but that has no effect on viewing as i still suffer from freezing and hanging in fraction speed disappears only on whole numbers like 2 or while using evr only ,

omar_bakly95

Posts : 7
Join date : 2016-09-30

View user profile

Back to top Go down

Re: Fast playback problem

Post by Admin on Fri Dec 02, 2016 9:51 pm

In case of EVR, it will use VSFilter automatically. You should see it in Menu>play>Filters.

Does the rendertime increase during those hangs? Or does any of the queues go empty?

madvr options > rendering > enable "separate device for presentation"

Admin
Admin

Posts : 3689
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Fast playback problem

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum