Color Space on Render X264vfw

View previous topic View next topic Go down

Color Space on Render X264vfw

Post by Jericho on Fri Nov 11, 2016 3:52 am

Good to all, sure this problem has happened to several people, and sure to have a solution, but I do not see it.

I am rendering a video captured on. AVI using Action !. I put here the characteristics:
Format                      : AVI
Format/Info                 : Audio Video Interleave
File size                   : 132 MiB
Duration                    : 29 s 950 ms
Overall bit rate            : 37.1 Mb/s
Video
ID                          : 0
Format                      : FICV
Codec ID                    : FICV
Duration                    : 29 s 950 ms
Bit rate                    : 35.4 Mb/s
Width                       : 1 920 pixels
Height                      : 1 080 pixels
Display aspect ratio        : 16:9
Frame rate                  : 60.000 FPS
Bits/(Pixel*Frame)          : 0.285
Stream size                 : 126 MiB (96%)

The audio does not matter. My problem is that when I render it with Premiere, Vegas Pro 14, or AE, using the X264vfw codec, it comes out with bright and clear colors. If the color is red it becomes orange.

I have tried several changes in the codec, and in the ffdshow ... and nothing. I know it has to do with my setup, because before a couple of months ago I was doing great. Update the programs, the drivers and nothing. I know it's something from Color Space, I even uploaded the rendered video to YT, and it looks orange when they process it.

Comparing the render and the original within a timeline (within a program) also appears the color difference. I think it has to do with the Codec, but it also happens with Divx. I have already configured the x264 in many ways, with the same results, except for "Keep input color space" that is much darker than the original.

Please take 4 days trying to solve this, and I do not think I'm the only one with this problem. I appreciate all the help you can give me.

Attached is a photo of the results and the original. Where to the right is the original and to the left the render.


Jericho

Posts : 2
Join date : 2016-11-11

View user profile

Back to top Go down

Re: Color Space on Render X264vfw

Post by Admin on Fri Nov 11, 2016 6:56 am

Given that black and white are correct, the problem seems to be the colormatrix. HD video usually uses bt709 colormatrix, and SD video uses bt601.

Your input video probably uses bt601, but bt709 is assumed during playback. This is a guess based on the resolution (when matrix is unknown). You can fix it by specifying the correct colormatrix.

Try putting this in the "extra command line" field in x264VFW settings:
--colormatrix bt601

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Color Space on Render X264vfw

Post by Jericho on Fri Nov 11, 2016 7:30 am

Thank you very much, seeing the line commands that the x264vfw accepts, I have noticed that it does not accept the value you gave me "bt601", or it has another name. I tried with the HD, and it worked to perfection. Then what is rendering quality is something else XD.

Thank you very much for everything. Four days ago I'm looking for a solution and you've solved my XD work.

I attach the photo of the result, it has worse quality for a quick test.


Jericho

Posts : 2
Join date : 2016-11-11

View user profile

Back to top Go down

Re: Color Space on Render X264vfw

Post by Admin on Fri Nov 11, 2016 8:17 am

Great! For reference, you can get full list of available options by clicking on the question mark.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Color Space on Render X264vfw

Post by Sponsored content Today at 7:09 pm


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum