Cannot change preferred decoder with Tweak Tool

View previous topic View next topic Go down

Cannot change preferred decoder with Tweak Tool

Post by galton on Sat Oct 08, 2016 1:52 am

I am attempting to use Presentation (from Neurobehavioural Systems) to present video stimuli for an experiment in a Windows 10 machine. For proper playback quality, the Presentation wiki recommends using avi files with Xvid encoding, and decoding via ffdshow. I've downloaded the Codec Tweak Tool and selected "ffdshow" for Xvid as they suggest, but when I check the video files in GraphEdit, I can see that the Mpeg4s Decoder DMO is still being used, not ffdshow. (And the quality of playback in Presentation is poor, with a nonconstant framerate.)

Is there something else I need to do to get ffdshow to override the normal Windows decoder? I've also tried disabling Mpeg4s Decoder DMO (under MS Codec Tweaks), but that doesn't work. I have no experience with any of these things, so this could be quite a straightforward problem! I would appreciate some help, though.

galton

Posts : 1
Join date : 2016-10-08

View user profile

Back to top Go down

Re: Cannot change preferred decoder with Tweak Tool

Post by Admin on Sat Oct 08, 2016 4:31 am

You can disable that Microsoft decoder in the "MS Codec Tweaks" section. Then it should use the desired decoder. I recommend using LAV Video decoder instead of ffdshow.

I think that wiki contains 'outdated' information. Xvid is a pretty old video format. A modern format like H.264 has much better quality.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum