Visual artefacts on VP8 webm file

View previous topic View next topic Go down

Visual artefacts on VP8 webm file

Post by Kissaki on Tue Aug 30, 2016 1:00 am

When playing this webm file with VP8 video data in MPC-HC I have visual artifacts:


I had noticed this with a K-Lite and CCCP installed.
I uninstalled both, and installed the most recent K-Lite Codecs Pack 1235_Standard.

It plays fine in VLC and my webbrowser.

Can you test if this is an issue for others as well?
Where would I report this bug?

Kissaki

Posts : 4
Join date : 2016-08-30

View user profile

Back to top Go down

Re: Visual artefacts on VP8 webm file

Post by Admin on Tue Aug 30, 2016 2:19 am

It plays correctly here.

MPC-HC menu > Play > Filters
This should show "LAV Splitter Source" and "LAV Video" during playback.

Only the colors are shifted. So it could possibly be a video renderer problem with the chroma handling. The video has uneven height and width, which sometimes is an issue. Updating your graphics driver might be a solution.

Admin
Admin

Posts : 2987
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Visual artefacts on VP8 webm file

Post by Kissaki on Tue Aug 30, 2016 3:27 am

Admin wrote:MPC-HC menu > Play > Filters
This should show "LAV Splitter Source" and "LAV Video" during playback.

Yup, it does show LAV Video Decoder and LAV Splitter Source.

Thanks for testing.

I’ll restart in a bit, maybe the uninstalls didn’t go too well.

Kissaki

Posts : 4
Join date : 2016-08-30

View user profile

Back to top Go down

Re: Visual artefacts on VP8 webm file

Post by Kissaki on Tue Aug 30, 2016 5:00 am

I restarted, reinstalled K-Lite, reinstalled my AMD GPU driver, and none helped.

I then changed the Direct Show Video renderer(?) from Enhanced Video Renderer (custom presenter) to madVR, which fixes the issue.

Anything I can further check, with different configuration or something?

Kissaki

Posts : 4
Join date : 2016-08-30

View user profile

Back to top Go down

Re: Visual artefacts on VP8 webm file

Post by Admin on Tue Aug 30, 2016 8:22 am

I am afraid it is a driver problem.

It works fine here on a NVIDIA system with the same renderer. There is one setting that you can try:
options > playback > output > resizer

Admin
Admin

Posts : 2987
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Visual artefacts on VP8 webm file

Post by Kissaki on Tue Aug 30, 2016 8:15 pm

None of the resizer options visibly change anything.

Kissaki

Posts : 4
Join date : 2016-08-30

View user profile

Back to top Go down

Re: Visual artefacts on VP8 webm file

Post by Admin on Thu Sep 01, 2016 2:33 am

Then it is not something that can be solved through the codecs. You will have to report this to AMD or use madVR for the cases where you encounter such a file with odd dimensions.

Admin
Admin

Posts : 2987
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Visual artefacts on VP8 webm file

Post by Sponsored content Today at 10:47 pm


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum