capture error

View previous topic View next topic Go down

capture error

Post by berserk on Fri Aug 05, 2016 9:58 pm

Hello

Im useing media player classic that was with K-Lite Codec Pack
I am useing a usb 2820 device to capture video
when I press the record button I get a capture error ,Cant connect the video to the multiplexer filter , then the preveiw screen locks and there is a still picture .
can I have some walk through steps to find out whats going wrong .

berserk

Posts : 13
Join date : 2016-08-05

View user profile

Back to top Go down

Re: capture error

Post by Admin on Sat Aug 06, 2016 1:58 am

You need to configure things in Options > Playback > Capture.

Capture does not work in combination with DXVA (native). So if you have enabled hardware acceleration in the video decoder, then you either need to disable it or switch to DXVA2 (copy-back).

Admin
Admin

Posts : 2982
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: capture error

Post by berserk on Sat Aug 06, 2016 10:39 am

hello
in file  > open device
settings are .
out put .
record video= check , preview=check , uncompressed
record audio=check , preview audio=check , uncompressed
then
avi

and Configuration lav video
settings are
hardware acceleration
hardware decoder to use=none
active decoder=inactive
active hardware accelerator=none
hardware devise to use =greyed out not Selectable

i still cant capture video i press record  a avi file appears in location and the picture freezes then stop recording and the avi file disappears .
now should i be able to capture with these settings


Last edited by berserk on Tue Aug 09, 2016 12:11 pm; edited 1 time in total

berserk

Posts : 13
Join date : 2016-08-05

View user profile

Back to top Go down

Re: capture error

Post by Admin on Sun Aug 07, 2016 12:08 am

But did you select the correct hardware in MPC-HC options > Playback > Capture? Because I don't think it always selects the correct things automatically.

Otherwise I dodn't know what might be wrong. I never used capture myself.

Admin
Admin

Posts : 2982
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: capture error

Post by berserk on Sun Aug 07, 2016 1:43 am

Hello
ok hold on a second i will get to options > Playback > Capture?
but
can you tell me if the above configuration is right and would work .
as in screen shots




berserk

Posts : 13
Join date : 2016-08-05

View user profile

Back to top Go down

Re: capture error

Post by Admin on Sun Aug 07, 2016 9:34 am

The settings of LAV Video decoder are correct.


Admin
Admin

Posts : 2982
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: capture error

Post by berserk on Mon Aug 08, 2016 9:25 pm

hello
Options > Playback > Capture
settings are
analog=2820
audio=sound card
country=ntscm .

new information
i have found that its to do with the audio .
when setting the audio to= sound card line in . i can hear sound but when i press record it crashes .
when i set the audio to= video capture device i have no sound but can record video without out any sound .

berserk

Posts : 13
Join date : 2016-08-05

View user profile

Back to top Go down

Re: capture error

Post by Admin on Tue Aug 09, 2016 3:12 am

You could try updating the drivers of the capture device and the sound card.

Admin
Admin

Posts : 2982
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: capture error

Post by berserk on Tue Aug 09, 2016 3:24 am

hello
the drivers are the latest , also i can capture with other software example vlc player and several others .
i dont think its my end i think its at your end thats not working .

berserk

Posts : 13
Join date : 2016-08-05

View user profile

Back to top Go down

Re: capture error

Post by Admin on Tue Aug 09, 2016 3:38 am

I don't make MPC-HC. You can report bugs specific to MPC-HC here:
https://trac.mpc-hc.org/report/9

Admin
Admin

Posts : 2982
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: capture error

Post by berserk on Tue Aug 09, 2016 4:16 am

hello
what is it that you make , also i have tried to make a account at https://trac.mpc-hc.org/report/9 but they are not sending me the confirmation email so i cant post .

new information

i have now found how to capture video with sound , if i dont  preview video and sound then i press record i am able to capture video with sound .

in file  > open device
settings are .
out put .
record video= check , preview=un check , uncompressed
record audio=check , preview audio=un check , uncompressed


tomorrow i will try with video preview on and audio preview off

new information

yes i can capture with video preview on and audio preview off

record video= check , preview=check , uncompressed
record audio=check , preview audio=un check , uncompressed


berserk

Posts : 13
Join date : 2016-08-05

View user profile

Back to top Go down

Re: capture error

Post by berserk on Wed Aug 10, 2016 4:25 am

hello
now i can capture to avi i would like instead to capture to Ogg media how do i do that .
can it be done.

berserk

Posts : 13
Join date : 2016-08-05

View user profile

Back to top Go down

Re: capture error

Post by Admin on Thu Aug 11, 2016 1:33 am

It does not have an Ogg muxer. But why do you want the use such an old format?

You can convert the AVI file to for example MP4 or MKV with a free tool such as Handbrake.

Admin
Admin

Posts : 2982
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: capture error

Post by berserk on Thu Aug 11, 2016 2:27 am

hello
ok i have Handbrake and im test converting to mp4 .

can you tell me how to improve capture quality .
here are my settings



berserk

Posts : 13
Join date : 2016-08-05

View user profile

Back to top Go down

Re: capture error

Post by Admin on Thu Aug 11, 2016 3:04 am

The default settings of LAV are already optimal. If your video is interlaced, then you could enable software deinterlacing (Yadif). But you can also deinterlace during conversion.

You are capturing as uncompressed audio/video, so that should give best quality (and large size).

Admin
Admin

Posts : 2982
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: capture error

Post by berserk on Sun Aug 14, 2016 11:29 pm

hello
dose any settings of the ffdshow video decoder (x64) have any impact on video capture .

berserk

Posts : 13
Join date : 2016-08-05

View user profile

Back to top Go down

Re: capture error

Post by Admin on Mon Aug 15, 2016 1:11 am

I recommend using LAV Video Decoder.

Admin
Admin

Posts : 2982
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: capture error

Post by berserk on Mon Aug 15, 2016 1:46 am

Admin wrote:I recommend using LAV Video Decoder.

hello
so do i have to disable anything to only use LAV Video Decoder and not use ffdshow video decoder (x64) for video capture

berserk

Posts : 13
Join date : 2016-08-05

View user profile

Back to top Go down

Re: capture error

Post by Admin on Mon Aug 15, 2016 1:53 am

If you selected LAV as preferred decoder during installation, then you don't need to change anything.

But if you use an analog capture card, then I think it doesn't need any decoder at all, since the data is not compressed.

Admin
Admin

Posts : 2982
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: capture error

Post by berserk on Mon Aug 15, 2016 2:45 am

is there a way of checking the preferred decoder without re installation .

berserk

Posts : 13
Join date : 2016-08-05

View user profile

Back to top Go down

Re: capture error

Post by Admin on Mon Aug 15, 2016 5:35 am

Look at the right bottom corner of your screen during playback (or capturing). There you should see icons from the decoders that are being used. They are white/red/blue with letter FF or LAV.

Admin
Admin

Posts : 2982
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: capture error

Post by berserk on Mon Aug 15, 2016 8:04 am

hello
is there anything in Media Player Classic options> that affects video capture other than options > Playback > Capture?

berserk

Posts : 13
Join date : 2016-08-05

View user profile

Back to top Go down

Re: capture error

Post by Admin on Mon Aug 15, 2016 8:21 am

No. Nothing else has effect either.

You are currently capturing exactly the quality of the input. What source are you capturing from?

Admin
Admin

Posts : 2982
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: capture error

Post by berserk on Mon Aug 15, 2016 8:36 am

hello
i am capturing from usb 2820 device .
so its play back settings that i probably need to configure then

berserk

Posts : 13
Join date : 2016-08-05

View user profile

Back to top Go down

Re: capture error

Post by Admin on Mon Aug 15, 2016 9:30 am

Is that this device?
https://www.startech.com/AV/Converters/Video/USB-S-Video-Capture-Cable~SVID2USB2NS

What have you connected to the composite cable?

Is the resolution that you are using correct? Maybe try 720x480 instead of 640x480.

Admin
Admin

Posts : 2982
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: capture error

Post by Sponsored content Today at 11:48 am


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum