[Media Player Classic] Can't alt+tab in fullscreen mode

View previous topic View next topic Go down

[Media Player Classic] Can't alt+tab in fullscreen mode

Post by Kross_nn on Fri Jul 01, 2016 5:34 am

My problem is that I can't alt+tab in fullscreen mode. Media Player stays at front of the screen. It appeared approximately 2 moths ago. Yes, I can live with this, but it kinda uncomfortable. So I searced internet, this forum and FAQs but couldn't find anything. So, I hope someone can help me with my problem.
By the way, If I turn on option "always visible" within other open programms/windows and Media Player itself - then alt+tab works correctly. I've tried to change settings at View => On Top, but there was no effect. I've tried to uninstall KLCP at least two times, but it also didn't work. Also visited View => Options => Fullscreen, but didn't find there something related to "always visible/on top". So I ran out of ideas and ended up here.

My system: Windows 7.
KLCP version 12.2.3 (Updated it today, was hoping it'll fix problem - made a full uninstall; I'm updating every time I see new update, so last was approximately 1.5-2 weeks ago)

Kross_nn

Posts : 2
Join date : 2016-07-01
Age : 22
Location : Russia

View user profile

Back to top Go down

Re: [Media Player Classic] Can't alt+tab in fullscreen mode

Post by Admin on Fri Jul 01, 2016 9:33 am

If you use the default video renderer (EVR-CP):
MPC-HC options > Playback > Output > uncheck "D3D Fullscreen"

If you use MadVR:
MadVR options > Rendering > General Settings > uncheck "enable automatic fullscreen exclusive mode"


Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: [Media Player Classic] Can't alt+tab in fullscreen mode

Post by Kross_nn on Fri Jul 01, 2016 9:51 pm

Yes, I'm using default renderer, and tried to switch to MadVR and tried both of your recommendations. D3D Fullscreen was unchecked already, so I tried to check it, and I can't do anything in fullscreen, so unchecked it, but it stayed as was. Same, trying MadVR.
After this I supposed, that it isn't fault of Player, so some crazy thought visited me - I have "classic Windows" style at Windows Color Scheme, so I decided to change it back to "Standard Windows 7". And wow! It worked. Now I can alt+tab in media player classic fullscreen freely. But when I return to "classic Windows", problem happens again.
Well, now I can live really freely, because Color Scheme is not such a pain for me - it's only a matter of habit. But, I really want to know the source of problem. Why it's happening only at "classic" scheme (by the way, other schemes related to classic such as "contrast white" and other can't help at my problem, it's "Standtart Windows 7" solve only).
I don't know whose this problem is, windows problem, or MPC problem, or it's just my computer only, so I just want to hear your thoughts now, mb I should go on windows forums/support.
And thanks for this advices. I would never decided to change color scheme without you.

Kross_nn

Posts : 2
Join date : 2016-07-01
Age : 22
Location : Russia

View user profile

Back to top Go down

Re: [Media Player Classic] Can't alt+tab in fullscreen mode

Post by Admin on Sat Jul 02, 2016 3:37 am

You can customize the theme here:
Control panel > System > Advanced system settings > Performance

Try enabling "desktop composition". That is one of the things most related to video playback behavior, as it for example controls stuff like VSync.

Aero peek is also a feature related to Alt+Tab.

The behavior might also depend on your graphics driver, so updating that may make a difference.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: [Media Player Classic] Can't alt+tab in fullscreen mode

Post by Sponsored content Today at 9:28 am


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum