Can't get DTS FLAC to play in pass-through

Page 1 of 2 1, 2  Next

View previous topic View next topic Go down

Can't get DTS FLAC to play in pass-through

Post by DanielF on Thu Jun 09, 2016 7:16 pm

I've been using the K-Lite codec pack for years, but was encouraged (by the welcome web page) after the latest update to post about a problem I have.  I'm not even sure if this is connected with the K-Lite pack or something else, but hopefully someone here will tell me to get lost if it's nothing to do with K-Lite! ;-)

On my previous PC, running Windows 2000 Pro and with a particular sound-card having DTS pass-through capability, I was able to play (via a Toslink/digital-optical connection to an external surround receiver) DTS-encoded FLAC music files, using a variety of player software (Spider, WinAmp, etc).  But when I replaced that PC with a new one running Windows 7 Pro/64-bit, with a different sound-card (I've tried two), I can no longer get those same DTS-FLAC files to play through the same receiver (also via Toslink).

Today I updated to K-Lite 12.1.5 then to 12.1.8, and tested again.  Same result.

The sound-cards I've tried are the Diamond XtremeSound PCI-e XS71HD and the Asus Xonar D2X/XDT/A PCI-e (this is the one currently installed).  Their behaviour is exactly the same.

If I go into Windows Control Panel/Sound and select the Asus Digital Output (which is set as default device), and then click Properties/Supported formats, I have both DTS and DD selected, and when I hit the <Test> button (for either mode) the external receiver switches to the corresponding mode (DTS or DD) and correctly plays the test sounds through each of my four speakers.

This tells me that the hardware is all working correctly.

But if I now run WinAmp (or Spider, or VLC, or Media Player Classic, or Windows Media Player [or whatever it's called these days - I never use it, normally!]) and try to play a DTS-FLAC file (that played correctly on my old PC), all I get is silence - not even the usual white noise, and certainly no 'DTS' indication on the external receiver.  If I play a stereo FLAC track through the same setup, it plays correctly.

However, if I play a DVD through PowerDVD 10, and select the DTS soundtrack, it plays correctly through the external receiver, which displays 'DTS', as it should!  So PowerDVD 10 is doing something that my audio players are failing to do, and I'm completely at a loss to know how to fix it.

I've checked and double-checked the Xonar D2X Audio Center setup, and experimented with every possible setting in there, but still can't get DTS pass-through to work.  As an aside, if I connect the sound-card to the external surround receiver via analogue cables (and change the system and driver sound settings to analogue), all I get for DTS tracks is white noise from the speakers.  This usually occurs when the DTS-encoded signal is being corrupted by some process, most commonly a volume control not at 100%.  I've checked that the volumes (system, driver, player) are all set at 100%.

Could this inability to play DTS music be related to the K-Lite codecs, or am I in the wrong forum?  Any help would be greatly appreciated.

(PS: WinAmp is my preferred player [because it handles ReplayGain, and Spider doesn't – needless to say the DTS tracks don't have any gain tags!], so if all that's required is some special player setup, this is the one I'd prefer to have settings for.)

Regards,
DanielF

DanielF

Posts : 18
Join date : 2016-06-09

View user profile

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by Admin on Thu Jun 09, 2016 11:34 pm

There is no such thing as a DTS-FLAC file. Those are completely different audio formats. You have converted DTS into a FLAC file that has 5.1 audio channels.

It is not possible to passthrough FLAC audio directly. It will always be decoded on the computer, and you will end up with uncompressed PCM audio. Stereo PCM can be send over a S/PDIF connection, but not 5.1 due to the limited bandwidth of the connection.

A solution:
Use the Mega pack. Select AC3Filter as the audio decoder. Then in AC3Filter settings, on the System tab, enable FLAC. On the SPDIF tab, verify that "Use AC3 Encoder" is enabled. Also enable AC3 and DTS passthrough.

AC3Filter will now decode the FLAC audio and convert it into Dolby AC3 in realtime and send that to your receiver.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by DanielF on Thu Jun 09, 2016 11:56 pm

Thanks for the reply, Admin, but that's not quite the situation...

What I meant by 'DTS-FLAC', but failed to explain initially, is a DTS-encoded WAV file compressed with FLAC. So when it's uncompressed on the PC, it yields a 2-channel PCM file that contains DTS-encoded 5.1 channels.

Those 2 PCM signals will pass through the Toslink connection, the receiver will recognise the DTS header, and switch on its decoder that decodes the 5.1 channels from the two PCM channels.

Since the 2-channel audio is already encoded by DTS, which is higher quality than Dolby Digital, I certainly don't want to decode and re-encode the 5.1 channels using AC3! I want the two PCM channels to be passed-through bit-perfect, so the receiver's DTS decoder can do the only decoding required, at the best possible quality for this encoding scheme.

As mentioned, it worked before. I just need help working out what's stopping it from working under Win 7.

Daniel

DanielF

Posts : 18
Join date : 2016-06-09

View user profile

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by Admin on Fri Jun 10, 2016 9:10 am

Any modification to the PCM data (which actually is DTS in this case) could destroy the DTS headers and corrupt the audio. So you need bitperfect output. You could try Foobar. Or find a WASAPI or ASIO plugin for Winamp.

Could you upload a sample file for me? I want to do some tests.
http://www.sendspace.com

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by DanielF on Fri Jun 10, 2016 11:12 am

I think I tried Foobar 2000 some time ago, with no fix. I'll look for the Winamp plug-ins you mentioned to see if they help.

Here's a DTS-FLAC file for testing: (I'll delete it after a few days.)
mediafire.com download/lt5vlux22di91jz/Apollo%28DTS%29%5BE74F86_08faded%5D_s.flac

Thanks for your help efforts.

Daniel

DanielF

Posts : 18
Join date : 2016-06-09

View user profile

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by Admin on Sat Jun 11, 2016 3:59 am

Found a solution for you.

1) Use LAV Audio as decoder for FLAC. This is already the default in the pack.
2) Select Stereo output, or alternatively disable the Mixer in LAV Audio. This way it doesn't modify the PCM output.
3) Choose AC3Filter as processor for PCM audio. This option is visible in Advanced/Expert install mode, or when unchecking "Quick Upgrade" during an update install.
4) In AC3Filter settings enable "Detect SPDIF stream in PCM data", and also enable "Use SPDIF" for DTS.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by DanielF on Sat Jun 11, 2016 2:31 pm

I'm encouraged that you've found a solution, but I'm having trouble implementing it...

I Googled and found out how to access the K-Lite configuration options, but my LAV Audio (v0.68.1.4-git) setup screen doesn't have the same options as yours.

And even after setting what I think are the equivalent of your settings, I still get no DTS playback from Winamp. How can I ensure Winamp is using the LAV Audio codec? It doesn't appear anywhere in Winamp's Options screens.

Thanks,
Daniel

DanielF

Posts : 18
Join date : 2016-06-09

View user profile

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by Admin on Mon Jun 13, 2016 3:17 am

AC3Filter is not part of LAV Audio. It is a separate codec. You can select it during installation of the codec pack.

The settings I mentioned will work with Media Player Classic and Windows Media Player. Winamp doesn't load AC3Filter for processing audio, so it won't work with that player.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by DanielF on Mon Jun 13, 2016 12:33 pm

I tried reinstalling K-Lite, un-ticking 'Quick Install', but could not see 'AC3Filter' in any of the subsequent screens.

I also went through MPC-HC x64 settings, and couldn't see it anywhere there either.

Thanks again for your patience.

Daniel

DanielF

Posts : 18
Join date : 2016-06-09

View user profile

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by DanielF on Mon Jun 13, 2016 12:42 pm

PS: I have a stand-alone copy of ac3filter-2-6-0b-en-win.exe, which I think I installed several weeks ago when someone else suggested it might help with my problem.

It's also possible I uninstalled it (if that's possible) when it did nothing, but I can't be sure. Should I try installing it again?

DanielF

Posts : 18
Join date : 2016-06-09

View user profile

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by Admin on Tue Jun 14, 2016 12:00 am

AC3Filter is included with the MEGA version of the pack. You may be using the FULL version right now (which is smaller).

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by DanielF on Tue Jun 14, 2016 12:13 am

Yes, I am using the Full version.

I'll download and install the Mega version when I get a moment.

Thanks,
Daniel

DanielF

Posts : 18
Join date : 2016-06-09

View user profile

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by DanielF on Tue Jun 14, 2016 12:43 pm

I downloaded and installed the Mega version, which uninstalled and re-installed MPC. I configured LAV and AC3filter as per your instructions. But still total silence when I play a DTS-FLAC track in MPC.

Perhaps your success is due to other system differences? I'm almost convinced it's Win7Pro64 that's causing the trouble. ;-)

Daniel

DanielF

Posts : 18
Join date : 2016-06-09

View user profile

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by Admin on Tue Jun 14, 2016 11:02 pm

I have Win7Pro64 too. Only difference is that I am not using SPDIF output. I am playing on the computer speakers. But I got the music, and not the typical white noise.

If you click on the AC3Filter icon in your systemtray (bottom right corner) during playback, then you can see what it is doing. Look in the "Decoder Info" box. Copy the details here, and maybe I can see if anything is wrong.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by DanielF on Wed Jun 15, 2016 12:47 am

Ah, that explains the different behaviour - you're relying on software decoding of the DTS whereas I'm looking for pass-through, which for some unknown reason isn't happening.

Here's the decoder info from AC3Filter:
-----
Input format: PCM16 Stereo 44100
User format: PCM16 - 0
Output format: SPDIF 5.1 44100

Use SPDIF
SPDIF status: SPDIF passthrough
SPDIF passthrough for: AC3 DTS
Use AC3 encoder (do not encode stereo PCM)
Do not check SPDIF sample rate
Query for SPDIF output support

Filter chain:
(PCM16 Stereo 44100) -> Detector -> (SPDIF 5.1 44100) -> Demux -> (DTS 5.1 44100) -> Spdifer -> (SPDIF 5.1 44100) -> Dejitter -> (SPDIF 5.1 44100)

Detector
Stream format: SPDIF 5.1 44100
Bitstream type: 16bit low endian
Frame size: 4096
Samples: 1024
Bitrate: 1411kbps

Demux
(SPDIF 5.1 44100) -> FrameSplitter -> SPDIFParser -> (DTS 5.1 44100)

FrameSplitter
Stream format: SPDIF 5.1 44100
Bitstream type: 16bit low endian
Frame size: 4096
Samples: 1024
Bitrate: 1411kbps


Spdifer
Output format: SPDIF 5.1 44100
SPDIF format: padded
Bitstream: 14bit LE

Dejitter
Enabled: true
Threshold: 100ms
Time shift: 0ms
Time scale: 1.0
-----

I'm no expert on this, but the filter chain seems to be doing a lot more than just passing the PCM through to the S/PDIF port.

Thanks for your help.
Daniel

DanielF

Posts : 18
Join date : 2016-06-09

View user profile

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by Admin on Wed Jun 15, 2016 3:56 am

Yes, it does some seemingly unnecessary steps, but that is done for flexibility. It shouldn't have much impact on performance.

It indicates that it is successfully outputting to SPDIF. So silence is strange. Did you select the correct audio device as default in the sound settings of the Windows Control Panel? And is everything turned on and connected? Does your soundcard support 44.1 kHz SPDIF output? Some only support 48 kHz.

You could try changing the "SPDIF/DTS mode" and "SPDIF/DTS conversion" options in AC3Filter.

http://www.ac3filter.net/wiki/AC3Filter_%26_SPDIF

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by Admin on Wed Jun 15, 2016 3:59 am

I also recommend these changes:
Windows Control Panel > Sounds > Speakers > Properties > Advanced > uncheck "allow applications to take exclusive control of this device"
Windows Control Panel > Sounds > Speakers > Properties > Enhancements > enable "Disable all sound effects"

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by DanielF on Wed Jun 15, 2016 1:31 pm

Yes, everything is correctly selected in the Windows Control Panel/Sounds settings. As mentioned at the start, I can click on the Windows 'Test' buttons and get correct DTS and DD playback through the external receiver. I can also run the test using either 44.1 or 48 kHz and also get correct (stereo) sounds from the receiver, via the Toslink connection. And I can play stereo music fine, so 44.1 kHz is definitely supported.

Thanks for the link to the AC3Filter & SPDIF article - quite interesting. But I didn't see anything there that would make me select any different options than those already selected.

As for the Control Panel/Sounds settings, I, of course, select 'Digital Output' rather than 'Speakers' (Digital Output through the Asus Xonar D2X is my default Playback device). Apart from that difference, I can uncheck 'Allow applications to take exclusive control of this device' in the Advanced tab, but there is no 'Enhancements' tab anywhere. The best I can do is go to the Sounds/Sounds tab and confirm that 'No Sounds' is selected (I always have it that way).

After un-ticking 'Allow applications to take exclusive control of this device', MPC (or AC3Filter, or whatever) now down-mixes my DTS tracks to stereo and plays them (through Toslink to the receiver) as stereo only. So I reverted it to allowing exclusive control.

Worse than that, after all this mucking around with MPC and AC3Filter, I just tried playing a video with MPC, and now get NO SOUND at all from the video (stereo soundtrack)! I can still play stereo music (FLAC) tracks, through MPC or Winamp, but silence for videos. I'm about to give up! I'll probably have to uninstall K-Lite Mega and re-install the Full version?

I think Win7 has defeated me. I don't know where to turn to get DTS working through a Toslink connection.

Thanks for trying, anyway.

Daniel

DanielF

Posts : 18
Join date : 2016-06-09

View user profile

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by Admin on Wed Jun 15, 2016 10:26 pm

You could try VLC Player.

To enable S/PDIF in VLC:
Tools > Preferences > (left bottom corner) Show Settings = All > Audio > enable "Use S/PDIF when available"

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by DanielF on Wed Jun 15, 2016 10:43 pm

VLC was amongst the many players I've tried. I just checked the setting you mentioned, and it was already selected.

When I play a DTS track with VLC, it produces white noise from the receiver. So the player/codec is modifying the DTS code in some way.

Thanks again.

Daniel

DanielF

Posts : 18
Join date : 2016-06-09

View user profile

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by Admin on Wed Jun 15, 2016 10:54 pm

But the receiver does indicate that it is getting DTS input?

I am not sure if VLC supports the DTS in FLAC trick. So try with a regular movie too.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by DanielF on Wed Jun 15, 2016 11:05 pm

If a DTS-decoding receiver plays white noise when it receives what should be a DTS data stream, it means the DTS data is corrupted, so the receiver assumes it's plain stereo and plays it as such. The (corrupted) DTS data sounds like white noise.

So no, of course it doesn't display 'DTS', since that's not what it's receiving.

Daniel

DanielF

Posts : 18
Join date : 2016-06-09

View user profile

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by Admin on Wed Jun 15, 2016 11:14 pm

Playing valid DTS as if it were PCM also gives white noise.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by Admin on Wed Jun 15, 2016 11:21 pm


Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by DanielF on Wed Jun 15, 2016 11:24 pm

Admin wrote:Playing valid DTS as if it were PCM also gives white noise.

Yes, but the receiver still wouldn't display 'DTS', because that's not what it's receiving.

Daniel

DanielF

Posts : 18
Join date : 2016-06-09

View user profile

Back to top Go down

Re: Can't get DTS FLAC to play in pass-through

Post by Sponsored content Today at 9:08 pm


Sponsored content


Back to top Go down

Page 1 of 2 1, 2  Next

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum