Subtitles not working

View previous topic View next topic Go down

Subtitles not working

Post by rflsl on Thu Apr 21, 2016 9:27 am

Hi,
I'm using windows 7 ultimate edition, 64 bits. MPC-HC 1.7.10.180 and codec pack 12.1.0 (mega).
So, here's the problem. Whenever I try to download a subtitle with help from MPC-HC, by using the D key and selecting the language I want it to be, said subtitle does not show. It only shows if the subtitles are external, I mean if it is already downloaded and with the same name as the video to be played. I've tried to do what is recommended to be done by the FAQ and it didn't work. I've downloaded DirectVobSub and ffdshow, and also it didn't solve the problem. And interesting enough, saturday everything was fine, working with no problems whatsoever.
Before I'm asked to post a list of things, here it is:

Codec Tweak Tool | Log file | Generated at 2016-04-20 19:17:21

#####  System Information  #####

OS:           Windows 7 Ultimate  (6.01.7601) (x64)
DirectX:      9.0c + 10 + 10.1 + 11
CPU name:     AMD Athlon(tm) II X2 270 Processor
CPU speed:    3415 MHz
Memory:       4096 MB
Screen size:  2560x1080 (32bits) (60Hz)
Video card 1: NVIDIA GeForce GT 630
             VendorID: 10de, DeviceID: 0f00
Video mem:    4096 MB
Video driver: nvd3dumx.dll (Version 340.52)
Video card 2: NVIDIA GeForce GTS 250
             VendorID: 10de, DeviceID: 0615
Video mem:    1024 MB
Video driver: nvd3dumx.dll (Version 340.52)
Audio device: Dispositivo de High Definition Audio
Audio driver: HdAudio.sys (Version 6.1.7601.17514) (11-19-2010)

#####  K-Lite Codec Pack  #####

KLCP version: 12.1.0 (base 12.0.5)
KLCP type:    mega

Speaker conf: 2.0

MPC renderer: EVR CP
MPC subs:     VSFilter
MPC decoder:  h264=1 vc1=1 mpeg2=1

#####  Decoder Settings #####

LAV Video:
H264=1|0 VC1=1|0 MPEG2=1|0 MPEG4=1|0 FLV1=1 WMV3=0

LAV Audio:
MP3=1 AAC=1 Vorbis=1 AC3=1 DTS=1 LPCM=1 WMA=0


#####  DirectShow Filters (32-bit)  #####

(A total of 89 filters, 0 shown, 89 hidden)

#####  DirectShow Filters (64-bit)  #####

Description:  ffdshow Video Decoder
File name:    c:\program files (x86)\k-lite codec pack\filters\ffdshow\ffdshow.ax
CLSID:        {04FE9017-F873-410E-871E-AB91661A4EF7}
Merit:        FF800001

Description:  ffdshow DXVA Video Decoder
File name:    c:\program files (x86)\k-lite codec pack\filters\ffdshow\ffdshow.ax
CLSID:        {0B0EFF97-C750-462C-9488-B10E7D87F1A6}
Merit:        FF800002

Description:  ffdshow Audio Decoder
File name:    c:\program files (x86)\k-lite codec pack\filters\ffdshow\ffdshow.ax
CLSID:        {0F40E1E5-4F79-4988-B1A9-CC98794E6B55}
Merit:        FF800001

Description:  VSFilter (auto-loading version)
File name:    c:\program files\vsfilter\vsfilter.dll
CLSID:        {9852A670-F845-491B-9BE6-EBD841B8A613}
Merit:        00800002 = MERIT_PREFERRED + 2

(A total of 86 filters, 4 shown, 82 hidden)

#####  ICM Class Manager (32-bit)  #####

(A total of 3 filters, 0 shown, 3 hidden)

#####  ICM Class Manager (64-bit)  #####

Description:  ffdshow video encoder
File name:    c:\program files (x86)\k-lite codec pack\filters\ffdshow\ffdshow.ax
CLSID:        {4DB2B5D9-4556-4340-B189-AD20110D953F} (ffdshow video encoder)
Merit:        00100000 = MERIT_SW_COMPRESSOR

(A total of 3 filters, 1 shown, 2 hidden)

#####  Default source filters (32-bit)  #####

.ssif   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source

(A total of 55 default source filters, 1 shown, 54 hidden)

#####  Default source filters (64-bit)  #####

.ssif   {B98D13E7-55DB-4385-A33D-09FD1BA26338}  LAV Splitter Source

(A total of 55 default source filters, 1 shown, 54 hidden)

#####  ACM and VFW Codecs (32-bit)  #####

(A total of 21 codecs, 0 shown, 21 hidden)


#####  ACM and VFW Codecs (64-bit)  #####

(A total of 19 codecs, 0 shown, 19 hidden)


#####  DirectX Media Objects (64-bit)  #####

(A total of 31 DMO, 0 shown, 31 hidden)

rflsl

Posts : 2
Join date : 2016-04-21

View user profile

Back to top Go down

Re: Subtitles not working

Post by Admin on Fri Apr 22, 2016 12:17 am

The subtitle download functionality only works with the internal subtitle renderer of MPC-HC.

After downloading the subtitle. Does it appear in: Menu > Play > Subtitle Track ?
There also is an option to enable/disable subtitles in that same menu. Maybe that option is not checked?

Admin
Admin

Posts : 2986
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Subtitles not working

Post by rflsl on Mon Apr 25, 2016 12:08 am

It was greyed out. However, the subtitles began to work fine all on its own, I haven't changed any options prior to what I said above. Weird right?

rflsl

Posts : 2
Join date : 2016-04-21

View user profile

Back to top Go down

Re: Subtitles not working

Post by Admin on Mon Apr 25, 2016 8:39 am

Yes weird. Maybe there was some kind of issue with the downloaded file. Good to hear that it works again.

Admin
Admin

Posts : 2986
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Subtitles not working

Post by Sponsored content Today at 10:56 pm


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum