Blurry video

View previous topic View next topic Go down

Blurry video

Post by Davidnext on Mon Apr 11, 2016 1:19 pm

After installing the newest K-lite codec, video in my WMP became very blurry (like old VHS), but when using Classic player everything is fine, the same video is sharp and crisp. No matter what type (h264, 265, xvid, etc.), no matter what resolution (SD to FHD), every time is the same: good video in MPC-hc and very bad in WMP. I have tried erasing WMP, clear the registry, uninstalling and reinstalling codec pack, but nothing helps. What to do now?

pc specs: i5, 8gb ram, vga Ati r9 380, Win 10 64-bit

Davidnext

Posts : 3
Join date : 2016-04-11

View user profile

Back to top Go down

Re: Blurry video

Post by Admin on Tue Apr 12, 2016 1:30 am

It is not directly codec related but a problem with the video renderer.

Some questions to narrow down the cause:
Does it also happen when you view the video at 100% size? Or only when it is resized or full screen.
Does it also happen with: MPC-HC options > Playback > Output > "Enhanced Video Render" (non-custom version)?
Is it a laptop or a regular PC?

First suggestions:
Update AMD graphics driver. Latest version is 16.4.1.
Adjust settings in AMD Control Panel. Look for settings named like "Dynamic Contrast", "Denoise", "Edge Enhancement". Disable them. They reduce performance and generally have a negative effect on quality.


Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Blurry video

Post by Admin on Tue Apr 12, 2016 1:58 am

Codec Tweak Tool > Media Foundation > disable for .mkv and .mp4

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Blurry video

Post by Davidnext on Tue Apr 12, 2016 7:38 am

Admin wrote:It is not directly codec related but a problem with the video renderer.

Some questions to narrow down the cause:
Does it also happen when you view the video at 100% size? Or only when it is resized or full screen.
Does it also happen with: MPC-HC options > Playback > Output > "Enhanced Video Render" (non-custom version)?
Is it a laptop or a regular PC?

First suggestions:
Update AMD graphics driver. Latest version is 16.4.1.
Adjust settings in AMD Control Panel. Look for settings named like "Dynamic Contrast", "Denoise", "Edge Enhancement". Disable them. They reduce performance and generally have a negative effect on quality.


1. Same at small and full size.
2. Sometimes when changing render in MPC from mad to Enhanced it also changes video quality in WMP (crystal clear full hd), but just that one time. Closing and opening again WMP (same video) everything reverts back and blur again.
3. Regular PC (desktop).
4. Latest video drivers.
Everything was fine untill K-lite.

Davidnext

Posts : 3
Join date : 2016-04-11

View user profile

Back to top Go down

Re: Blurry video

Post by Admin on Tue Apr 12, 2016 8:33 am

Can you copy this information here:
Codec Tweak Tool > Generate Log

Did you search for those settings in the AMD control panel? Another setting that should be turned off is "Fleshtone correction".

If you open MPC-HC first and leave it open, does WMP give proper quality then?

Can you make a screenshot so I can see how the video quality is?

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Blurry video

Post by Davidnext on Tue Apr 12, 2016 10:30 am

Admin wrote:Can you copy this information here:
Codec Tweak Tool > Generate Log

Did you search for those settings in the AMD control panel? Another setting that should be turned off is "Fleshtone correction".

If you open MPC-HC first and leave it open, does WMP give proper quality then?

Can you make a screenshot so I can see how the video quality is?


I have tried two things what you and other user recommended, but unfortunately I have done both at same time so I don't know what really helped (I can't remember what was enabled in drivers). I made reset of all amd driver settings and also disabled mp4 and mkv in Codec Tweak Tool/Media Foundation and that finally worked!
My WMP shows normal, crisp FHD video again. Thank you guys. cheers

Davidnext

Posts : 3
Join date : 2016-04-11

View user profile

Back to top Go down

Re: Blurry video

Post by Sponsored content Today at 7:09 pm


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum