K-Lite Codec Pack beta versions 12.0.6 thru 12.0.8 cannot install

View previous topic View next topic Go down

K-Lite Codec Pack beta versions 12.0.6 thru 12.0.8 cannot install

Post by yetisyny on Fri Apr 08, 2016 4:53 am

Hi, I have used your codec pack for years and usually it works great. The installers for the latest stable release of K-Lite Mega Codec Pack, 12.0.5, works fine. The updaters for versions 12.0.6 and the current 12.0.8 also work fine. The problem is the beta installers for versions 12.0.6 and the current 12.0.8, neither of which worked after I downloaded them from http://www.codecguide.com/klcp_beta.htm.

The current beta installers give me the error message "Floating point division by zero." in a popup window with the title bar saying "Error" and the computer plays the error sound. This is on Windows XP Professional with Service Pack 3, 32-bit, running on a computer with a CPU that does NOT have the SSE2 instruction set but DOES have the SSE instruction set, i.e., an AMD Sempron 2800+ from early 2005, right before AMD switched from 32-bit chips to 64-bit chips, equivalent to an AMD Athlon XP 2800+. The SSE2 instruction set was introduced in Intel chips with the Pentium IV but introduced several years later in AMD chips with the Athlon 64. I am guessing this is probably the cause of the error, your installer for beta versions 12.0.6 and later probably uses SSE2 instructions, I have seen a lot of programs doing this and crashing on my computer lately.

The codec pack itself works fine on my computer and all the various codecs, utilities, and of course the Media Player Classic - Home Cinema are 100% compatible with my non-SSE2 CPU as well as with Windows XP, so since the software itself works with my CPU and operating system after being installed the installer ought to be fixed too. As are the installers for your stable version 12.0.5 and the update installers for the 12.0.6 and 12.0.8 updates. But the beta installers don't work anymore... beta installers for versions prior to 12.0.5 used to work fine on this computer. You need to fix your beta installers before you put out the next stable version or else a lot of people could have problems once the next stable version is out. Thanks.

I am not sure whether or not this problem occurs on other Windows versions or other CPUs. It might or might not. I would suggest other people try the beta installer from the above link and see if it works for them and if they have problems they can report them on this thread to confirm if this problem occurs for them too.

Oh and after I click the OK button in the window or X it out in the corner the installer exits, that is all that the beta version installer does, in both 12.0.6 and 12.0.8. The stable version installer for 12.0.5 and the updaters for 12.0.6 and 12.0.8 work fine, no problems at all.

Screenshot of error with beta installer:


EDIT: I noticed someone else posted about the same bug earlier here: http://codecs.forumotion.net/t2258-floating-point-division-by-zero But I hope the detail in my report of the same bug might be helpful.


Last edited by yetisyny on Fri Apr 08, 2016 6:10 am; edited 2 times in total (Reason for editing : noticed someone else reported same bug earlier)

yetisyny

Posts : 1
Join date : 2016-04-08

View user profile

Back to top Go down

Re: K-Lite Codec Pack beta versions 12.0.6 thru 12.0.8 cannot install

Post by Admin on Fri Apr 08, 2016 6:59 am

The problem is not in the files. They are all compiled to only require SSE. Otherwise the update would fail too.

Can you enable logging of the installer? Then I can where problem occurs. Use this as command-line for the installer:
/log="c:\klcplog.txt"

Copy the last 20 lines of the log here.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: K-Lite Codec Pack beta versions 12.0.6 thru 12.0.8 cannot install

Post by talombo on Sat Apr 09, 2016 1:51 pm

The installer crashes immediately after I double click it so there isn't much info in the log:

Code:

2016-04-09 05:46:20.000   Log opened. (Time zone: UTC+02:00)
2016-04-09 05:46:20.000   Setup version: Inno Setup version 5.5.9 (u)
2016-04-09 05:46:20.000   Original Setup EXE: c:\downloads\K-Lite_Codec_Pack_1208_Full.exe
2016-04-09 05:46:20.000   Setup command line: /SL5="$90040,35014031,259072,c:\downloads\K-Lite_Codec_Pack_1208_Full.exe" /log="c:\klcplog.txt"
2016-04-09 05:46:20.000   Windows version: 5.1.2600 SP3  (NT platform: Yes)
2016-04-09 05:46:20.000   64-bit Windows: No
2016-04-09 05:46:20.000   Processor architecture: x86
2016-04-09 05:46:20.000   User privileges: Administrative
2016-04-09 05:46:20.046   Exception message:
2016-04-09 05:46:20.046   Message box (OK):
                          Floating point division by zero.
2016-04-09 05:46:20.640   User chose OK.
2016-04-09 05:46:20.640   Deinitializing Setup.
2016-04-09 05:46:20.656   Log closed.

talombo

Posts : 2
Join date : 2016-04-03

View user profile

Back to top Go down

Re: K-Lite Codec Pack beta versions 12.0.6 thru 12.0.8 cannot install

Post by Admin on Sun Apr 10, 2016 2:33 am

Found the problem. XP can't handle certain bitmap images. Next version should work normally again.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: K-Lite Codec Pack beta versions 12.0.6 thru 12.0.8 cannot install

Post by Sponsored content Today at 5:43 pm


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum