AAC is not set by K-Lite Mega Codec Pack

View previous topic View next topic Go down

AAC is not set by K-Lite Mega Codec Pack

Post by cold on Mon Nov 23, 2015 1:06 am

Hello Guys,

I'm reporting here in hope that some Administrator from K-Lite Mega Codec Pack see this.

At the installation of K-Lite Mega Codec Pack (in Unattended mode, not tested in "normal mode", but probably the same problem happens) is that AAC is not set to FFDShow when it is marked. (It uses LAV, even when we select FFDShow in installation).

It happens because the key HKLM\Software\LAV\Audio\Formats (In 64-bit OSes: HKLM\Software\Wow6432Node\LAV\Audio\Formats) the value aac (REG_DWORD) is set as "1". It should be "0" when FFDShow is selected by default in installation.

As an Workaround, I added the following lines into kclp_mega_unnatended.bat:

Code:
if %PROCESSOR_ARCHITECTURE%==x86 (
  set key=HKLM\Software\LAV\Audio\Formats
) else (
  set key=HKLM\Software\Wow6432Node\LAV\Audio\Formats
)
reg add %key% /v aac /t REG_DWORD /d 0 /f
reg add HKCU\Software\LAV\Audio\Formats /v aac /t REG_DWORD /d 0 /f

It detects if OS is 32 or 64-bit, then edit aac key to "0" to use FFDShow to this format.
It also overrides HKCU value from actual user.
It could edit every user file from computer using https://github.com/MicksMix/RegUpdateAllUsers/blob/master/RegUpdateAllHkcuHkcr
But I did not developed it any further. It is an workaround and I do not pretend use it in a production environment.

Hopping anyone could reproduce this and apply the required fix at the K-Lite Mega Codec Pack installation logic.

Thanks.

cold

Posts : 2
Join date : 2015-11-23

View user profile

Back to top Go down

Re: AAC is not set by K-Lite Mega Codec Pack

Post by Admin on Mon Nov 23, 2015 1:25 am

ffdshow has a higher filter merit than LAV. So if a format is enabled in ffdshow it will be used even when it also is enabled in LAV. It is not a bug that AAC is enabled in LAV. It is done intentionally.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: AAC is not set by K-Lite Mega Codec Pack

Post by cold on Mon Nov 23, 2015 1:50 am

I didn't know that, thanks for the info!

But the problem is that LAV is being used EVEN when I set it to explicity set it to FFDshow. Only when I disable it in LAV or disable LAV Audio completely (unregister it through Codec Tweak interface) it uses FFDshow filter.

The problem is that FFDshow is not being set to aac in installation when this option is marked (it uses LAV by default, I want to use ffdshow for it). It is using LAV when it should not!

cold

Posts : 2
Join date : 2015-11-23

View user profile

Back to top Go down

Re: AAC is not set by K-Lite Mega Codec Pack

Post by Admin on Mon Nov 23, 2015 9:34 am

Are you using Windows Media Player? In that case:
Codec Tweak Tool > Preferred Decoders

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: AAC is not set by K-Lite Mega Codec Pack

Post by Sponsored content Today at 9:28 am


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum