AC3 and DTS audio stream = jitters and crackle

View previous topic View next topic Go down

AC3 and DTS audio stream = jitters and crackle

Post by comicchaser on Sun Nov 22, 2015 2:53 pm

Hey everyone.
After a recent update of the codec pack, I've run into a weird problem when playing video files with DTS or AC3 audio in Zoom Player.
Instead of the actual audio I only get white noise or constant crackling.
AAC and FLAC work fine.
I use ZP for watching videos on my desktop monitor with my default sound card and stereo speakers.
I use MPC when streaming the video/audio to my external surround receiver and my TV via HDMI pass-through, which works fine for all formats.
I'd like to be able to keep using both players for their specific purposes.
I assumed the problem might lie with the LAV filters and tried to force ZP to use FFDshow instead of LAV via its smartplay function, but that didn't get me any results, since ZP still chooses LAV over FFDshow for unknown reasons.
Any ideas what the issue might be and how to fix it?

Much regards
cc

comicchaser

Posts : 4
Join date : 2014-04-26

View user profile

Back to top Go down

Re: AC3 and DTS audio stream = jitters and crackle

Post by Admin on Mon Nov 23, 2015 1:02 am

Disable audio pass-though. It will then decode the audio and send it as uncompressed PCM audio.

Admin
Admin

Posts : 2987
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: AC3 and DTS audio stream = jitters and crackle

Post by comicchaser on Mon Nov 23, 2015 12:29 pm

Admin wrote:Disable audio pass-though. It will then decode the audio and send it as uncompressed PCM audio.

Thanks for the help.
Before I read your post I separately downloaded the FFDshow config files via ZP's install center and then forced smart play to use FFDshow instead of LAV. Got it working that way instead.

Sorry for the hassle
cc

comicchaser

Posts : 4
Join date : 2014-04-26

View user profile

Back to top Go down

Re: AC3 and DTS audio stream = jitters and crackle

Post by Admin on Tue Nov 24, 2015 1:35 am

No special ffdshow configuration is needed. To use ffdshow instead of LAV all you need to do is enable the relevant formats in ffdshow settings (on the "Codecs" page). Or simply choose ffdshow as a preferred decoder during installation of the codec pack.

To disable pass-through:
Codec Tweak Tool > Audio Output

You probably enabled that during installation because you recognized the term HDMI.

Admin
Admin

Posts : 2987
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: AC3 and DTS audio stream = jitters and crackle

Post by Sponsored content Today at 10:48 pm


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum