K-lite codek pack and ALAC playback problems

View previous topic View next topic Go down

K-lite codek pack and ALAC playback problems

Post by mirkorm on Fri Jul 31, 2015 7:46 am

Hi everybody,

It's the first time I stumble into a  media file I'm not able to play with K-lite codec pack mega installed, and I really don't know what to do:

I had to download and listen for a study this file from the web http://www.greatsound.info/media/01czjZE64K/01snd09.mov It's encoded with the Apple loseless format and I really can't find a way to play it.

this is the MPC Warning message

Code:
File Source (Async.)::Output
LAV Splitter::Audio

Media Type 0:
--------------------------
Audio: ALAC 44100Hz stereo 985kbps

AM_MEDIA_TYPE:
majortype: MEDIATYPE_Audio {73647561-0000-0010-8000-00AA00389B71}
subtype: Unknown GUID Name {63616C61-0000-0010-8000-00AA00389B71}
formattype: FORMAT_WaveFormatEx {05589F81-C356-11CE-BF01-00AA0055595A}
bFixedSizeSamples: 1
bTemporalCompression: 0
lSampleSize: 256000
cbFormat: 18

WAVEFORMATEX:
wFormatTag: 0x6c61
nChannels: 2
nSamplesPerSec: 44100
nAvgBytesPerSec: 123141
nBlockAlign: 0
wBitsPerSample: 0
cbSize: 0 (extra bytes)

pbFormat:
0000: 61 6c 02 00 44 ac 00 00 05 e1 01 00 00 00 00 00 al..D¬...á......
0010: 00 00                                           ..


Media Type 1:
--------------------------
Audio

AM_MEDIA_TYPE:
majortype: MEDIATYPE_Audio {73647561-0000-0010-8000-00AA00389B71}
subtype: Unknown GUID Name {AFBC2343-3DCB-4047-9655-E1E62A61B1C5}
formattype: Unknown GUID Name {35189950-CAC9-4C8D-819D-B6FAEE15DD9D}
bFixedSizeSamples: 1
bTemporalCompression: 0
lSampleSize: 256000
cbFormat: 24

WAVEFORMATEXFFMPEG:
nCodecId: 0x15010

WAVEFORMATEX:
wFormatTag: 0x6c61
nChannels: 2
nSamplesPerSec: 44100
nAvgBytesPerSec: 123141
nBlockAlign: 0
wBitsPerSample: 0
cbSize: 0 (extra bytes)

pbFormat:
0000: 10 50 01 00 61 6c 02 00 44 ac 00 00 05 e1 01 00 .P..al..D¬...á..
0010: 00 00 00 00 00 00 00 00                         ........



I add that I just upgraded yesterday to Windows 10 64-bit, in case it would be relevant, but I doubt it

Thanks a lot

mirkorm

Posts : 2
Join date : 2015-07-31

View user profile

Back to top Go down

Re: K-lite codek pack and ALAC playback problems

Post by Admin on Fri Jul 31, 2015 9:47 am

I can confirm the problem with this file. The decoder fails because some of the data is different from what it expects.

I shall submit a bug report for this. I will update this topic if there is any news.

Admin
Admin

Posts : 2987
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: K-lite codek pack and ALAC playback problems

Post by mirkorm on Fri Jul 31, 2015 10:31 am

Thank you very much admin

mirkorm

Posts : 2
Join date : 2015-07-31

View user profile

Back to top Go down

Re: K-lite codek pack and ALAC playback problems

Post by Admin on Fri Aug 28, 2015 12:23 am

The problem has been fixed in FFmpeg. This kind of files should play correctly once LAV Filters are updated with latest FFmpeg. Probably in next version of the pack.

Admin
Admin

Posts : 2987
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: K-lite codek pack and ALAC playback problems

Post by Sponsored content Today at 10:46 pm


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum