XviD videos stutter on latest version of K-Lite Mega

View previous topic View next topic Go down

XviD videos stutter on latest version of K-Lite Mega

Post by PJAmerica on Mon Jun 08, 2015 3:46 am

All of my XviD avi videos stutter with the latest version of K-Lite Mega. MKV and MP4 H264 play perfectly fine. I had to revert back to the version prior to correct the issue.

PJAmerica

Posts : 29
Join date : 2013-08-04

View user profile

Back to top Go down

Re: XviD videos stutter on latest version of K-Lite Mega

Post by Admin on Tue Jun 09, 2015 12:48 am

With latest you mean 11.2.1 or 11.2.0?

Admin
Admin

Posts : 2987
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: XviD videos stutter on latest version of K-Lite Mega

Post by PJAmerica on Tue Jun 09, 2015 1:50 am

Admin wrote:With latest you mean 11.2.1 or 11.2.0?

the latest is 11.2.1. I had to revert back to 11.2.0 for stability on this issue.

PJAmerica

Posts : 29
Join date : 2013-08-04

View user profile

Back to top Go down

Re: XviD videos stutter on latest version of K-Lite Mega

Post by Admin on Wed Jun 10, 2015 1:27 am

It seems to be working normally here. Are you using any non-default settings that might be relevant?

What kind of stuttering is it? Frames being displayed in wrong order? Framedrops? Irregular framerate?

Admin
Admin

Posts : 2987
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: XviD videos stutter on latest version of K-Lite Mega

Post by PJAmerica on Wed Jun 10, 2015 4:02 am

Everything is normal. No changes and it happens in WMP and MPC. When I revert back to the prior version it doesn't do it so I know it's software related and not something to do with me or settings. The frames thing I cannot explain. It stutters and that's rthe best I can explain it. I am not up on technical terms. It is not flowing seemless like it should and it does it under all of the output options available to me in MPC.

PJAmerica

Posts : 29
Join date : 2013-08-04

View user profile

Back to top Go down

Re: XviD videos stutter on latest version of K-Lite Mega

Post by Admin on Thu Jun 11, 2015 6:25 am

Are any of those files recently downloaded from a torrent, newsgroup or website? If so, can you give me a link? Then I can test with the same file.

Admin
Admin

Posts : 2987
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: XviD videos stutter on latest version of K-Lite Mega

Post by PJAmerica on Thu Jun 11, 2015 8:16 am

No, these are dvdrips of a tv show I have had for years. I can upload some for you if you PM me. I have been able to reproduce this with a variety of Xvid with different tools used to make them within scene groups. It even does it on my own xvid rips. Which just shocked me. I tested this issue on two different PCs and replicated it.

PJAmerica

Posts : 29
Join date : 2013-08-04

View user profile

Back to top Go down

Re: XviD videos stutter on latest version of K-Lite Mega

Post by Admin on Fri Jun 12, 2015 1:01 am

An interesting test that you could do is to see if the same thing happens with FFplay. That uses FFmpeg for decoding, just like LAV Filters does.

You can download it here:
http://ffmpeg.zeranoe.com/builds/win32/static/
(you can open .7z files with WinRAR or 7-Zip)

To play a file, use at the Windows command prompt:
ffplay video.avi

Try the latest version first. Then the ones from June 4th and May 7th. I would expect the one from May 7th to work correctly, and the one from June 4th to have the stuttering. If that is correct, then please try versions in between. Then we know when the problem was introduced.

Admin
Admin

Posts : 2987
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: XviD videos stutter on latest version of K-Lite Mega

Post by PJAmerica on Fri Jun 12, 2015 2:36 am

That is all over my head. I wanna help here but that is more technical than I can delve into. I know nothing about useing Windows command prompt or the like.

PJAmerica

Posts : 29
Join date : 2013-08-04

View user profile

Back to top Go down

Re: XviD videos stutter on latest version of K-Lite Mega

Post by Admin on Fri Jun 12, 2015 9:13 am

It is actually very easy. Here are detailed steps:

1) Download the .7z file
2) Extract it with WinRAR
3) Copy ffplay.exe and put it in the same folder as one of your video files
4) Select the folder that contains the file.
5) Hold the Shift button and right-click on the folder. (shift adds additional options to the menu)
6) Select `Open command window here`.
7) At the command prompt just type
ffplay.exe video.avi

Admin
Admin

Posts : 2987
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: XviD videos stutter on latest version of K-Lite Mega

Post by PJAmerica on Fri Jun 12, 2015 11:38 am

I didn't experience the stutter with either versions upon testing.

PJAmerica

Posts : 29
Join date : 2013-08-04

View user profile

Back to top Go down

Re: XviD videos stutter on latest version of K-Lite Mega

Post by PJAmerica on Sat Jun 13, 2015 9:53 am

This seems to be fixed with the latest updated. However, now the Medi Player doesn't skip to the next file in the folder when set in play back. I tested this in the latest MPC beta release in stand alone and it does the same thing so it is down to the latest beta in the latest update pack.

PJAmerica

Posts : 29
Join date : 2013-08-04

View user profile

Back to top Go down

Re: XviD videos stutter on latest version of K-Lite Mega

Post by Admin on Sat Jun 13, 2015 10:12 am

Yes, it's a new bug in MPC-HC. Same bug causes repeat to be broken. A fix is already in testing, new version should be available soon.

Meanwhile, you can use PageDown button to manually go to next file in folder.

Admin
Admin

Posts : 2987
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: XviD videos stutter on latest version of K-Lite Mega

Post by PJAmerica on Sat Jun 13, 2015 10:21 am

Admin wrote:Yes, it's a new bug in MPC-HC. Same bug causes repeat to be broken. A fix is already in testing, new version should be available soon.

Meanwhile, you can use PageDown button to manually go to next file in folder.

Yeah, I am already using Page Down at current. Just thought I would mention it. I wish I knew what caused the issues with xvid before the latest update though.

PJAmerica

Posts : 29
Join date : 2013-08-04

View user profile

Back to top Go down

Re: XviD videos stutter on latest version of K-Lite Mega

Post by Admin on Sat Jun 13, 2015 11:37 pm

Should be fixed in 11.2.3

Admin
Admin

Posts : 2987
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: XviD videos stutter on latest version of K-Lite Mega

Post by PJAmerica on Sun Jun 14, 2015 5:06 am

Yep everything as far as I experienced is now fix. Thanks Admin. Cool Cool Cool

PJAmerica

Posts : 29
Join date : 2013-08-04

View user profile

Back to top Go down

Re: XviD videos stutter on latest version of K-Lite Mega

Post by Sponsored content Today at 9:17 am


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum