PowerPoint 2007 No longer Plays M4a after Installing Mega Pack 7.0

View previous topic View next topic Go down

PowerPoint 2007 No longer Plays M4a after Installing Mega Pack 7.0

Post by sniblit on Mon Aug 15, 2011 7:24 pm

After installing K-Lite Mega Pack 7.0 (I need 7.0 for specific configurations on ffdshow video that aren't in the newer versions) PowerPoint will no longer Play M4a audio files. I get an MCI error when trying to double click the audio file on the slide. Uninstalling K-Lite doesn't help. I can go back to the windows restore point to get it working again. How can I fix this issue?

sniblit

Posts: 6
Join date: 2011-08-15

View user profile

Back to top Go down

Re: PowerPoint 2007 No longer Plays M4a after Installing Mega Pack 7.0

Post by Admin on Mon Aug 15, 2011 9:16 pm

Which ffdshow options are you talking about?

Uninstalling the pack undoes all changes. So it would be weird if the behavior before is different from after using the pack. Maybe Windows does something funky on its own.

I tried it with PowerPoint 2010, and I did not have any problems. But since I use a 64-bit version of office, it uses 64-bit codecs, so the behavior is a bit different.

By default the 32-bit pack uses the DC-Bass Source filter for m4a files. So you could try with that option deselected in the installer.

I assume the same m4a file plays fine outside of PowerPoint?

Admin
Admin

Posts: 1416
Join date: 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: PowerPoint 2007 No longer Plays M4a after Installing Mega Pack 7.0

Post by sniblit on Mon Aug 15, 2011 9:34 pm

Yes it plays fine outside of PowerPoint. Something isn't getting undone after uninstalling. The only thing I can get to undo it is a system restore. I'll take a look at DC Bass filter. I was using the simple install. I'll see what the advanced install lets me do. This only affects PowerPoint 2007. 2010 is not affected.

In the older version of ffdshow, it allowed me to uncheck the option to use rgb32 option. I need to be able to do this because I'm using it with software that uses the extra 8 bits for something else.

sniblit

Posts: 6
Join date: 2011-08-15

View user profile

Back to top Go down

Re: PowerPoint 2007 No longer Plays M4a after Installing Mega Pack 7.0

Post by Admin on Mon Aug 15, 2011 9:36 pm

The new version also allows disabling RGB32. Or did you mean forcing RGB24 output?

Admin
Admin

Posts: 1416
Join date: 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: PowerPoint 2007 No longer Plays M4a after Installing Mega Pack 7.0

Post by sniblit on Mon Aug 15, 2011 9:40 pm

When I did the advanced install with no DC Bass it gets rid of the error message, but the m4a will not play. I'll do a system restore and try something else. Uninstalling didn't fix it.

sniblit

Posts: 6
Join date: 2011-08-15

View user profile

Back to top Go down

Re: PowerPoint 2007 No longer Plays M4a after Installing Mega Pack 7.0

Post by sniblit on Mon Aug 15, 2011 9:40 pm

Yes I need to be able to force 24 i believe.

sniblit

Posts: 6
Join date: 2011-08-15

View user profile

Back to top Go down

Re: PowerPoint 2007 No longer Plays M4a after Installing Mega Pack 7.0

Post by Admin on Mon Aug 15, 2011 9:42 pm

Here is a registry tweak to try:
Code:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\MCI Extensions]
"m4a"="MPEGVideo"

Admin
Admin

Posts: 1416
Join date: 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: PowerPoint 2007 No longer Plays M4a after Installing Mega Pack 7.0

Post by sniblit on Mon Aug 15, 2011 9:46 pm

I exported that earlier and restored it and it didn't make any difference. I'll try it again though. Do I need to make this change in the Wow6432Node?

sniblit

Posts: 6
Join date: 2011-08-15

View user profile

Back to top Go down

Re: PowerPoint 2007 No longer Plays M4a after Installing Mega Pack 7.0

Post by sniblit on Mon Aug 15, 2011 9:54 pm

Ok, it's fixed. I had to add the key m4a with MPEGVideo as the data under.
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\MCI Extensions. I also used the filter tweaker to disable dc bass. Not sure if that's required at this point or not. I enable it and see how it goes. Thanks for your help!

sniblit

Posts: 6
Join date: 2011-08-15

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum