Codecs not initializing with WMP12 on Win7/64

View previous topic View next topic Go down

Codecs not initializing with WMP12 on Win7/64

Post by Spazite on Wed Oct 29, 2014 1:46 pm

Hello,

I've been using Win XP for a while now with WMP11 and klite mega. It always worked flawlessly.

Now that I have installed Windows 7 Home Premium/64, I cant seem to get the codecs to activate when watching video files. WMP and all other video players including vlc have poor image quality.

I can tell just by looking at the videos that there is something wrong. There is more artifacting and/or pixelation then should be. It doesn't matter the file type I play.

I installed the latest klite codec pack (tried both 32 and 64 bit) and tried configuring some settings all to no avail..The decoders are not showing in my system tray either (they are not inactive- I have them enabled in all settings). So I'm assuming the codecs are not being initialized somehow.

I uninstalled all the media players and the codecs as well and reinstalled klite mega pack..Still the same :/

I'm running an ATI HD6970 with the latest drivers. Is there something I'm missing...I haven't found a resolution for this since i installed the OS over a week ago.

Any help is greatly appreciated!

Spazite

Posts : 4
Join date : 2014-10-29

View user profile

Back to top Go down

Re: Codecs not initializing with WMP12 on Win7/64

Post by Admin on Thu Oct 30, 2014 3:22 am

Go to the ATI control panel. There you should find a few options to claim to enhance the video. Disable all of them. They only reduce quality. They have names like "Noise reduction", "Adaptive contrast", "Dynamic Contrast", "Edge Enhancement", and "Skin Tone Enhancement". More generic options like anisotropic filtering and things like that should all be set to "let application decide".

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Codecs not initializing with WMP12 on Win7/64

Post by Spazite on Thu Oct 30, 2014 1:22 pm

Admin wrote:Go to the ATI control panel. There you should find a few options to claim to enhance the video. Disable all of them. They only reduce quality. They have names like "Noise reduction", "Adaptive contrast", "Dynamic Contrast", "Edge Enhancement", and "Skin Tone Enhancement". More generic options like anisotropic filtering and things like that should all be set to "let application decide".

Thank you for your response.

I don't have CCC installed, I never install it when I update my drivers ,as I only want the driver itself on the system. Is that the only way to disable the aforementioned options?

Spazite

Posts : 4
Join date : 2014-10-29

View user profile

Back to top Go down

Re: Codecs not initializing with WMP12 on Win7/64

Post by Admin on Fri Oct 31, 2014 4:11 am

You can disable some of them by editing the Windows Registry. Search for "DynamicContrast_NA" and "Fleshtone_NA".

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Codecs not initializing with WMP12 on Win7/64

Post by Spazite on Fri Oct 31, 2014 3:26 pm

Admin wrote:You can disable some of them by editing the Windows Registry. Search for "DynamicContrast_NA" and "Fleshtone_NA".

I will try this when I figure out why the Decoders are not initializing when watching vids. Anything I can do to get them to run (in system tray)?  I already have them enabled in settings :/

Spazite

Posts : 4
Join date : 2014-10-29

View user profile

Back to top Go down

Re: Codecs not initializing with WMP12 on Win7/64

Post by Admin on Sat Nov 01, 2014 3:57 am

WMP12 uses Media Foundation codecs for some file formats. You can disable Media Foundation with the Codec Tweak Tool. In case of AC3/DTS audio you are need to disable the Microsoft DTV-DVD Audio decoder.

But that won't solve the quality problem, since VLC uses totally different codecs (its own private ones).

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Codecs not initializing with WMP12 on Win7/64

Post by Spazite on Sat Nov 01, 2014 3:02 pm

Admin wrote:WMP12 uses Media Foundation codecs for some file formats. You can disable Media Foundation with the Codec Tweak Tool. In case of AC3/DTS audio you are need to disable the Microsoft DTV-DVD Audio decoder.

But that won't solve the quality problem, since VLC uses totally different codecs (its own private ones).

Thank you! This is what I was searching for!

I'm in the LAV Decoder settings now trying to get my center and rears to show...I have it set for 5.1, it is playing from the center and rears but I cant adjust them 3. Also, they center and rears are not showing as active in the details activity tab. only the L&R are are showing as active.

Spazite

Posts : 4
Join date : 2014-10-29

View user profile

Back to top Go down

Re: Codecs not initializing with WMP12 on Win7/64

Post by Admin on Tue Nov 04, 2014 2:16 am

LAV does not upmix the audio. If the input is stereo, then the rest of the audio channels will be filled with silence.

ffdshow audio decoder is capable of upmixing if you enable "expand stereo" option in its Mixer settings.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Codecs not initializing with WMP12 on Win7/64

Post by Sponsored content Today at 7:07 pm


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum