Problem with linked chapters

View previous topic View next topic Go down

Problem with linked chapters

Post by mantis2892 on Sun Sep 28, 2014 9:26 pm

I have this weird problem where the subtitle styles are not rendering properly after a linked chapter switch...
I have an anime which uses OP/ED (opening/ending) as separate files and the episodes link to them. The problem is whenever the episode does not start first in the chapter list the subtitle styles for that episode are not loading at all.

Basically if I have a chapter structure like this:
OP -> episode -> ED, only the styles for OP and ED are loading, the styles for the episode part default to SRT render style set in mpc-hc.

However there's no problem with a structure like this:
episode -> OP -> episode -> ED

Any help is appreciated.

EDIT: Works fine in VLC. Also if the episode file does not start with the episode (i.e it starts with OP), even ED styles are not loading. One more thing, the size of the rendered font does not match with the size set for SRTs, only the style matches. Klite version is 10.7.5 Mega with default settings.

EDIT: Pot player also has same problem. However, Klite Mega v10.0.5 released way back in Sept 12, 2013, works perfectly

mantis2892

Posts : 7
Join date : 2014-09-28

View user profile

Back to top Go down

Re: Problem with linked chapters

Post by Admin on Mon Sep 29, 2014 8:57 pm

Current version uses LAV Splitter, while the older ones might have still used Haali by default.

Does each files contain all styles and the required fonts? I suspect it might only load the styles from the first opened file.

I can download those files somewhere?

Admin
Admin

Posts : 2986
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Problem with linked chapters

Post by mantis2892 on Mon Sep 29, 2014 9:14 pm

Yes, it seems the problem lies with LAV splitter 0.62 and a few earlier versions (I don't know from which version the problem occurs). Before that LAV splitter worked fine.

Switching to Haali splitter works fine and subtitles load properly.

And btw even Klite 10.0.5 used LAV splitter by default (I think). Smile

As for downloading the files : http://coalgirls.wakku.to/2122/eden-of-the-east   the 720p torrent. Try playing episode 1 & 2, 1 works properly, 2 has the problem

EDIT: I posted the issue on https://code.google.com/p/lavfilters/issues/list

mantis2892

Posts : 7
Join date : 2014-09-28

View user profile

Back to top Go down

Re: Problem with linked chapters

Post by Admin on Mon Sep 29, 2014 9:23 pm

The developer of LAV is usually quick to fix regressions. You should add the torrent link to your bug report. Fixing is easier for him with a good sample.

Admin
Admin

Posts : 2986
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Problem with linked chapters

Post by mantis2892 on Mon Sep 29, 2014 10:12 pm

Thanks, I will do that Smile

mantis2892

Posts : 7
Join date : 2014-09-28

View user profile

Back to top Go down

Re: Problem with linked chapters

Post by Admin on Tue Sep 30, 2014 10:30 pm

The bug has been fixed. It should work properly again after the next update.

Admin
Admin

Posts : 2986
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Problem with linked chapters

Post by mantis2892 on Wed Oct 01, 2014 1:20 am

Yeah, till then I'll just use Haali

mantis2892

Posts : 7
Join date : 2014-09-28

View user profile

Back to top Go down

Re: Problem with linked chapters

Post by Sponsored content Today at 10:55 pm


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum