Using alternative codec instead of Mpeg Decoder DMO

View previous topic View next topic Go down

Using alternative codec instead of Mpeg Decoder DMO

Post by MaxEagle on Fri May 30, 2014 2:52 am

Hi everyone

I'm having trouble with colors in Warcraft III cinematics. Instead of clear and shine image I can see ugly washed up mess.

Using Win7DSFilterTweaker I managed to figuire out which of the codecs War 3 uses, and it is Mpeg4s Decoder Dmo. When I disable it the image in cinematics dissapears and only sound can be heard.

What I need to know is how to make War 3 use ffdshow or something else instead of DMO. Maybe I can somehow change codecs associations.

My operation system is Win 7 64bit, I have all the k-lite codecs installed.

MaxEagle

Posts : 3
Join date : 2014-05-30

View user profile

Back to top Go down

Re: Using alternative codec instead of Mpeg Decoder DMO

Post by Admin on Fri May 30, 2014 9:33 am

Solution for the washed out colors:
Right-click on Warcraft 3. On the Compatibility tab select “Disable desktop composition” and also enable Windows XP SP3 compatibility mode.

To use LAV Video decoder:
1) Start > Run > Regedit.exe
2) Go to: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\LAV\Video\Blacklist
3) remove war3.exe value

To use ffdshow:
1) ffdshow video decoder > DirectShow Control > remove war3.exe from the "Do not use in" list.
2) ffdshow video decoder > Codecs > enable Other MPEG4

I recommend trying the compatibility settings first. LAV Video decoder is better than ffdshow.

Admin
Admin

Posts : 2982
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Using alternative codec instead of Mpeg Decoder DMO

Post by MaxEagle on Fri May 30, 2014 10:30 am

Thanks for the reply. Unfortunately, nothing from the list helped.

What puzzles me is that in my virtual Win XP SP2 at first run there were no image, only sound. Then I installed K-Lite codecs pack and voila! - worked like a charm!

But I pretty shure that Win 7 uses another principle with its DMO codecs. When I change color depth of the desktop to 16 bits, image in cinematics gets little better, though none of the changes in software (codecs tools and other) made sense.

If I hide the MP4SDECD.DLL renaming it so the game couldn't see it, the image in the cinematics dissapear.

MaxEagle

Posts : 3
Join date : 2014-05-30

View user profile

Back to top Go down

Re: Using alternative codec instead of Mpeg Decoder DMO

Post by Admin on Sat May 31, 2014 1:47 am

You should open one if the videos with the GraphStudioNext tool. That shows you which DirectShow filters are used to render the file.

It is strange that MP4SDECD is used. Because as far as I know this game uses a custom FourCC to identify the video format. "BLZ0" to be precise. So normally only decoders that support this particular FourCC should get used. Perhaps you are not using the standard AVI splitter from Microsoft? LAV Splitter changes the FourCC to a generic one for MPEG-4.

The game also includes a decoder by itself. It is called "blizzard.ax". I don't know if it actually registers and uses that codec on Windows 7.

Both ffdshow and LAV video decoder should become useable by the game, once the blacklist settings have been adjusted. So a black screen is strange, assuming that this means no video decoder is active. It is possible that the game itself blocks certain decoders, or prefers certain decoders. Renaming MP4SDECD.dll does not remove its registration, so the game still things it is available. It will just fail to load, so if the game has no fallback method, it could explain the black screen.

Admin
Admin

Posts : 2982
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Using alternative codec instead of Mpeg Decoder DMO

Post by MaxEagle on Sat May 31, 2014 10:03 am

GraphStudio Tool showed:

intro.mpq (output) => (input) LAV Splitter video=> (input) LAV Video Decoder (output) => (Vmr input) Video Renderer

Audio was for mp3 DMO Windows or something like that. I disabled MP3 DMO and it changed to ffdshow audio.

Again, this is how it works in windows, but when running a game, no pop ups and no tray icons apper and violet color comes. Its very likely that game do use its prefered codecs.

I googled about blizzard.ax and found these:

dont know wrote:
Codec Request.... With luck... I'll find who i'm suppost to email request too..


blizzard.ax is the codec file...

UndeadEd.mpq is the sample DivX File.

FourCC : Unknown, Doesn't seem to have one. {0x305a4c42}

[HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID\{CF49D4E0-1115-11CE-B03A-0020AF0BA770}\Instance\CLSID_Blizzard]

"FriendlyName"="DivX for Blizzard Decoder Filter"
"CLSID"="{307A6C42-0000-0010-8000-00AA00389B71}"
"FilterData"=hex:02,00,00,00,00,00,80,00,02,00,00,00,00,00,00,00,30,70,69,33,\
 00,00,00,00,00,00,00,00,02,00,00,00,00,00,00,00,00,00,00,00,30,74,79,33,00,\
 00,00,00,70,00,00,00,80,00,00,00,31,74,79,33,00,00,00,00,70,00,00,00,90,00,\
 00,00,31,70,69,33,08,00,00,00,00,00,00,00,01,00,00,00,00,00,00,00,00,00,00,\
 00,30,74,79,33,00,00,00,00,70,00,00,00,a0,00,00,00,76,69,64,73,00,00,10,00,\
 80,00,00,aa,00,38,9b,71,42,6c,7a,30,00,00,10,00,80,00,00,aa,00,38,9b,71,42,\
 4c,5a,30,00,00,10,00,80,00,00,aa,00,38,9b,71,00,00,00,00,00,00,00,00,00,00,\
 00,00,00,00,00,00

When I went to those register paths I only found [HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID\{CF49D4E0-1115-11CE-B03A-0020AF0BA770}. There is nothing further in the path.


MaxEagle

Posts : 3
Join date : 2014-05-30

View user profile

Back to top Go down

Re: Using alternative codec instead of Mpeg Decoder DMO

Post by Admin on Sun Jun 01, 2014 1:34 am

GraphStudioNext behaves like a standard DirectShow player. So the codecs are working as desired.

Since Warcraft isn't loading LAV Video it can mean three things:
1) It has been programmed to prefer the MS DMO codec
2) The game has an internal blacklist for ffdshow and/or lav decoders
3) The game is still blacklisted in the codec settings. On a 64-bit system, most things are present in two locations. Once for 32-bit versions and once for 64-bit versions. The 32-bit versions are relevant for the game.

You can register the blizzard.ax filter with these steps:
1) Start > Accessories > Command Prompt
Right-click on it and choose "Run as administrator"
2) Navigate to the folder that contains blizzard.ax with a command like this:
cd c:\path\to\warcraft\folder
3) Register the filter with this command:
regsvr32 blizzard.ax

Which version of the codec pack are you using? You should try the MEGA version. That included the Xvid VFW codec. Maybe the game is able to utilize that for decoding the video.

Admin
Admin

Posts : 2982
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Using alternative codec instead of Mpeg Decoder DMO

Post by Sponsored content Today at 11:49 am


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum